summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-06-04 19:07:15 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-06-04 19:07:15 +0000
commitf0ecc3e816cdab1c64165c40d7752ab9f51a6864 (patch)
treea35777a22e2b2f4a0d1e199a23857af86730ab46 /x11-libs/cairo/cairo-1.6.4.ebuild
parentVersion bump (diff)
downloadgentoo-2-f0ecc3e816cdab1c64165c40d7752ab9f51a6864.tar.gz
gentoo-2-f0ecc3e816cdab1c64165c40d7752ab9f51a6864.tar.bz2
gentoo-2-f0ecc3e816cdab1c64165c40d7752ab9f51a6864.zip
remove 1.6.x pre-releases
(Portage version: 2.1.5.3)
Diffstat (limited to 'x11-libs/cairo/cairo-1.6.4.ebuild')
-rw-r--r--x11-libs/cairo/cairo-1.6.4.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/x11-libs/cairo/cairo-1.6.4.ebuild b/x11-libs/cairo/cairo-1.6.4.ebuild
index 897cf1e832eb..d2399ea4e809 100644
--- a/x11-libs/cairo/cairo-1.6.4.ebuild
+++ b/x11-libs/cairo/cairo-1.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.6.4.ebuild,v 1.2 2008/04/11 23:50:59 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.6.4.ebuild,v 1.3 2008/06/04 19:07:15 cardoe Exp $
inherit eutils flag-o-matic libtool
@@ -57,6 +57,8 @@ src_unpack() {
}
src_compile() {
+ local use_xcb
+
#gets rid of fbmmx.c inlining warnings
append-flags -finline-limit=1200
@@ -64,11 +66,15 @@ src_compile() {
export glitz_LIBS=-lglitz-glx
fi
- econf $(use_enable X xlib) $(use_enable doc gtk-doc) $(use_enable directfb) \
- $(use_enable svg) $(use_enable glitz) $(use_enable X xlib-xrender) \
- $(use_enable debug test-surfaces) --enable-pdf --enable-png \
- --enable-freetype --enable-ps $(use_enable xcb) \
- || die "configure failed"
+ use_xcb="--disable_xcb"
+ use X && use xcb && use_xcb="--enable-xcb"
+
+ econf $(use_enable X xlib) $(use_enable doc gtk-doc) \
+ $(use_enable directfb) ${use_xcb} \
+ $(use_enable svg) $(use_enable glitz) $(use_enable X xlib-xrender) \
+ $(use_enable debug test-surfaces) --enable-pdf --enable-png \
+ --enable-freetype --enable-ps \
+ || die "configure failed"
emake || die "compile failed"
}