summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-26 10:50:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-26 10:50:45 +0000
commita35b9a5e0af6702624ebad4f7fa173a011f8b90d (patch)
tree848ab5b02921389841a444250c4ab18a5b8c986e /x11-libs/fox
parentdrop old of EAPI=0 (diff)
downloadgentoo-2-a35b9a5e0af6702624ebad4f7fa173a011f8b90d.tar.gz
gentoo-2-a35b9a5e0af6702624ebad4f7fa173a011f8b90d.tar.bz2
gentoo-2-a35b9a5e0af6702624ebad4f7fa173a011f8b90d.zip
Bump
(Portage version: 2.2.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-libs/fox')
-rw-r--r--x11-libs/fox/ChangeLog7
-rw-r--r--x11-libs/fox/fox-1.7.40.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/x11-libs/fox/ChangeLog b/x11-libs/fox/ChangeLog
index b817642e9f07..790ebed01f98 100644
--- a/x11-libs/fox/ChangeLog
+++ b/x11-libs/fox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/fox
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.170 2013/08/03 06:51:09 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.171 2013/08/26 10:50:45 patrick Exp $
+
+*fox-1.7.40 (26 Aug 2013)
+
+ 26 Aug 2013; Patrick Lauer <patrick@gentoo.org> +fox-1.7.40.ebuild:
+ Bump
03 Aug 2013; Agostino Sarubbo <ago@gentoo.org> fox-1.6.45.ebuild:
Stable for sparc, wrt bug #475654
diff --git a/x11-libs/fox/fox-1.7.40.ebuild b/x11-libs/fox/fox-1.7.40.ebuild
new file mode 100644
index 000000000000..cc41671284d9
--- /dev/null
+++ b/x11-libs/fox/fox-1.7.40.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.7.40.ebuild,v 1.1 2013/08/26 10:50:45 patrick Exp $
+
+EAPI=4
+
+inherit fox
+
+LICENSE="LGPL-2.1"
+SLOT="1.7"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib"
+
+# newish autoconf needed for working mmap check
+RDEPEND="x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/fox-wrapper
+ >=sys-devel/autoconf-2.67
+ bzip2? ( app-arch/bzip2 )
+ jpeg? ( virtual/jpeg )
+ opengl? ( virtual/glu virtual/opengl )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+ truetype? ( media-libs/freetype:2
+ x11-libs/libXft )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+src_configure() {
+ FOXCONF="$(use_enable bzip2 bz2lib) \
+ $(use_enable jpeg) \
+ $(use_with opengl) \
+ $(use_enable png) \
+ $(use_enable tiff) \
+ $(use_with truetype xft) \
+ $(use_enable zlib)" fox_src_configure
+}
+
+src_install() {
+ fox_src_install
+ CP="${ED}/usr/bin/ControlPanel"
+ if [[ -f ${CP} ]] ; then
+ mv "${CP}" "${ED}/usr/bin/fox-ControlPanel-${SLOT}" || \
+ die "Failed to install ControlPanel"
+ fi
+}
+
+pkg_postinst() {
+ fox_pkg_postinst
+
+ einfo "ControlPanel has been installed to 'fox-ControlPanel-${SLOT}' to avoid conflicts"
+ einfo "with other packages."
+}