summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-04-04 17:42:49 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-04-04 17:42:49 +0000
commit8ba4aa14ea3df3985dbfc5f38687fe874d8812d2 (patch)
tree4bed2920edf4f248b224d6c4b8a4e3723ac66fc6 /x11-libs/gdk-pixbuf
parentDepend on correct Xorg Server ABI, #359841 (diff)
downloadgentoo-2-8ba4aa14ea3df3985dbfc5f38687fe874d8812d2.tar.gz
gentoo-2-8ba4aa14ea3df3985dbfc5f38687fe874d8812d2.tar.bz2
gentoo-2-8ba4aa14ea3df3985dbfc5f38687fe874d8812d2.zip
Fix building with libpng-1.5, bug 354557
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gdk-pixbuf')
-rw-r--r--x11-libs/gdk-pixbuf/ChangeLog6
-rw-r--r--x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.22.1-fix-libpng15.patch67
-rw-r--r--x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.1.ebuild5
3 files changed, 76 insertions, 2 deletions
diff --git a/x11-libs/gdk-pixbuf/ChangeLog b/x11-libs/gdk-pixbuf/ChangeLog
index ae01c5ac1dbe..7fedd68cacbc 100644
--- a/x11-libs/gdk-pixbuf/ChangeLog
+++ b/x11-libs/gdk-pixbuf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/gdk-pixbuf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/ChangeLog,v 1.10 2011/03/22 19:47:21 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/ChangeLog,v 1.11 2011/04/04 17:42:49 nirbheek Exp $
+
+ 04 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ gdk-pixbuf-2.22.1.ebuild, +files/gdk-pixbuf-2.22.1-fix-libpng15.patch:
+ Fix building with libpng-1.5, bug 354557
22 Mar 2011; Brent Baude <ranger@gentoo.org> gdk-pixbuf-2.22.1.ebuild:
Marking gdk-pixbuf-2.22.1 ppc stable for bug 353436
diff --git a/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.22.1-fix-libpng15.patch b/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.22.1-fix-libpng15.patch
new file mode 100644
index 000000000000..424938e81577
--- /dev/null
+++ b/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.22.1-fix-libpng15.patch
@@ -0,0 +1,67 @@
+From e6a5b2472a4a5d554b587dfcb798b95035caa6fd Mon Sep 17 00:00:00 2001
+From: Maarten Bosmans <mkbosmans@gmail.com>
+Date: Mon, 24 Jan 2011 10:39:22 +0000
+Subject: Use png_jmpbuf macro
+
+This makes the png loader compatible with libpng 1.5
+---
+diff --git a/gdk-pixbuf/io-png.c b/gdk-pixbuf/io-png.c
+index 79c81fd..76f3304 100644
+--- a/gdk-pixbuf/io-png.c
++++ b/gdk-pixbuf/io-png.c
+@@ -183,7 +183,7 @@ png_simple_error_callback(png_structp png_save_ptr,
+ error_msg);
+ }
+
+- longjmp (png_save_ptr->jmpbuf, 1);
++ longjmp (png_jmpbuf(png_save_ptr), 1);
+ }
+
+ static void
+@@ -287,7 +287,7 @@ gdk_pixbuf__png_image_load (FILE *f, GError **error)
+ return NULL;
+ }
+
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(png_ptr))) {
+ g_free (rows);
+
+ if (pixbuf)
+@@ -459,7 +459,7 @@ gdk_pixbuf__png_image_begin_load (GdkPixbufModuleSizeFunc size_func,
+ return NULL;
+ }
+
+- if (setjmp (lc->png_read_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(lc->png_read_ptr))) {
+ if (lc->png_info_ptr)
+ png_destroy_read_struct(&lc->png_read_ptr, NULL, NULL);
+ g_free(lc);
+@@ -531,7 +531,7 @@ gdk_pixbuf__png_image_load_increment(gpointer context,
+ lc->error = error;
+
+ /* Invokes our callbacks as needed */
+- if (setjmp (lc->png_read_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(lc->png_read_ptr))) {
+ lc->error = NULL;
+ return FALSE;
+ } else {
+@@ -769,7 +769,7 @@ png_error_callback(png_structp png_read_ptr,
+ error_msg);
+ }
+
+- longjmp (png_read_ptr->jmpbuf, 1);
++ longjmp (png_jmpbuf(png_read_ptr), 1);
+ }
+
+ static void
+@@ -978,7 +978,7 @@ static gboolean real_save_png (GdkPixbuf *pixbuf,
+ success = FALSE;
+ goto cleanup;
+ }
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(png_ptr))) {
+ success = FALSE;
+ goto cleanup;
+ }
+--
+cgit v0.9
diff --git a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.1.ebuild b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.1.ebuild
index 62750c2ba89c..f836b876b174 100644
--- a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.1.ebuild
+++ b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.1.ebuild,v 1.7 2011/03/22 19:47:21 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.1.ebuild,v 1.8 2011/04/04 17:42:49 nirbheek Exp $
EAPI="3"
@@ -39,6 +39,9 @@ src_prepare() {
# Only build against libX11 if the user wants to do so
epatch "${FILESDIR}"/${PN}-2.21.4-fix-automagic-x11.patch
+ # Fix libpng-1.5 compatibility, bug 354557 — taken from upstream
+ epatch "${FILESDIR}/${P}-fix-libpng15.patch"
+
elibtoolize
eautoreconf
}