summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-02-22 22:33:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-02-22 22:33:38 +0000
commitbdb46f237cb44e03b73e4fcc1b20333bae118f12 (patch)
treed17aaa69475cb36e2092a46f661cd32ef868fd26 /x11-libs/goocanvas
parentVersion bump. Enable gzip compression, dropped dependency on dbus-glib. (diff)
downloadgentoo-2-bdb46f237cb44e03b73e4fcc1b20333bae118f12.tar.gz
gentoo-2-bdb46f237cb44e03b73e4fcc1b20333bae118f12.tar.bz2
gentoo-2-bdb46f237cb44e03b73e4fcc1b20333bae118f12.zip
Version bump, bug #342273.
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'x11-libs/goocanvas')
-rw-r--r--x11-libs/goocanvas/ChangeLog9
-rw-r--r--x11-libs/goocanvas/goocanvas-1.0.0.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/x11-libs/goocanvas/ChangeLog b/x11-libs/goocanvas/ChangeLog
index cad7590035f7..92009283798f 100644
--- a/x11-libs/goocanvas/ChangeLog
+++ b/x11-libs/goocanvas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/goocanvas
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/ChangeLog,v 1.20 2010/11/19 09:01:14 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/ChangeLog,v 1.21 2011/02/22 22:33:38 eva Exp $
+
+*goocanvas-1.0.0 (22 Feb 2011)
+
+ 22 Feb 2011; Gilles Dartiguelongue <eva@gentoo.org> +goocanvas-1.0.0.ebuild:
+ Version bump, bug #342273.
19 Nov 2010; Justin Lecher <jlec@gentoo.org> goocanvas-0.14.ebuild:
Cleaned DESCRIPTION to fit ebuild writing guide lines
diff --git a/x11-libs/goocanvas/goocanvas-1.0.0.ebuild b/x11-libs/goocanvas/goocanvas-1.0.0.ebuild
new file mode 100644
index 000000000000..5f2e6b3e9382
--- /dev/null
+++ b/x11-libs/goocanvas/goocanvas-1.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/goocanvas-1.0.0.ebuild,v 1.1 2011/02/22 22:33:38 eva Exp $
+
+EAPI="3"
+
+GCONF_DEBUG="no"
+
+inherit gnome2 libtool
+
+DESCRIPTION="Canvas widget for GTK+ using the cairo 2D library for drawing"
+HOMEPAGE="http://live.gnome.org/GooCanvas"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=x11-libs/gtk+-2.12:2
+ >=dev-libs/glib-2.10:2
+ >=x11-libs/cairo-1.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.8 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF} --disable-rebuilds --disable-static"
+}
+
+src_prepare() {
+ # Fails to build with recent GTK+
+ sed -e "s/-D.*_DISABLE_DEPRECATED//g" \
+ -i src/Makefile.am src/Makefile.in demo/Makefile.am demo/Makefile.in \
+ || die "sed 1 failed"
+
+ sed -e 's/^\(SUBDIRS =.*\)demo\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 2 failed"
+
+ # Needed for FreeBSD - Please do not remove
+ elibtoolize
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/examples/
+ doins demo/*.c demo/flower.png demo/toroid.png
+ fi
+}