summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-04-11 14:19:57 +0000
committerMarinus Schraal <foser@gentoo.org>2003-04-11 14:19:57 +0000
commit3acbebd108369339cff011c9b68084c2da57d5e1 (patch)
tree5204594112021234f5a8f4d7b7c05df887cd3203 /x11-libs/gtk+
parentAdded hppa to KEYWORDS. (diff)
downloadgentoo-2-3acbebd108369339cff011c9b68084c2da57d5e1.tar.gz
gentoo-2-3acbebd108369339cff011c9b68084c2da57d5e1.tar.bz2
gentoo-2-3acbebd108369339cff011c9b68084c2da57d5e1.zip
added treeview patch
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog7
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.2.1-r11
-rw-r--r--x11-libs/gtk+/files/gtk+-2.2.1-scrollfix.patch12
-rw-r--r--x11-libs/gtk+/gtk+-2.2.1-r1.ebuild89
4 files changed, 108 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 6af8c6fa1c3f..805e1532d5b6 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.61 2003/04/05 03:16:02 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.62 2003/04/11 14:19:57 foser Exp $
+
+*gtk+-2.2.1-r1 (11 Apr 2003)
+
+ 11 Apr 2003; foser <foser@gentoo.org> gtk+-2.2.1-r1.ebuild :
+ Added gtktreeview patch for eclipse (#19084)
*gtk+-1.2.10-r10 (08 Mar 2003)
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.2.1-r1 b/x11-libs/gtk+/files/digest-gtk+-2.2.1-r1
new file mode 100644
index 000000000000..4674a66630c4
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.2.1-r1
@@ -0,0 +1 @@
+MD5 dfd5755fddb26a46c96bfaa813280ac4 gtk+-2.2.1.tar.bz2 6515939
diff --git a/x11-libs/gtk+/files/gtk+-2.2.1-scrollfix.patch b/x11-libs/gtk+/files/gtk+-2.2.1-scrollfix.patch
new file mode 100644
index 000000000000..b45dcddc081f
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-2.2.1-scrollfix.patch
@@ -0,0 +1,12 @@
+--- gtk+-2.2.1/gtk/gtktreeview.c.scrollfix 2003-02-20 20:23:15.000000000 -0500
++++ gtk+-2.2.1/gtk/gtktreeview.c 2003-02-20 20:24:52.000000000 -0500
+@@ -4166,8 +4166,7 @@
+ need_redraw = TRUE;
+ }
+
+- if (tree_view->priv->scroll_to_path &&
+- ! GTK_RBNODE_FLAG_SET (tree_view->priv->tree->root, GTK_RBNODE_DESCENDANTS_INVALID))
++ if (tree_view->priv->scroll_to_path)
+ {
+ gtk_tree_row_reference_free (tree_view->priv->scroll_to_path);
+ tree_view->priv->scroll_to_path = NULL;
diff --git a/x11-libs/gtk+/gtk+-2.2.1-r1.ebuild b/x11-libs/gtk+/gtk+-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..3d98404cc2a5
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.2.1-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.2.1-r1.ebuild,v 1.1 2003/04/11 14:19:57 foser Exp $
+
+inherit eutils libtool flag-o-matic
+
+IUSE="tiff doc jpeg"
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Gimp ToolKit + "
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.2/${P}.tar.bz2"
+HOMEPAGE="http://www.gtk.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ >=dev-libs/glib-2.2.0
+ >=dev-libs/atk-1.2.0
+ >=x11-libs/pango-1.1.3
+ >=media-libs/libpng-1.2.1
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+src_unpack() {
+ unpack ${A}
+
+ # Turn of --export-symbols-regex for now, since it removes
+ # the wrong symbols
+ cd ${S}; epatch ${FILESDIR}/gtk+-2.0.6-exportsymbols.patch
+ # should speed up metacity
+ cd ${S}; epatch ${FILESDIR}/gtk+-wm.patch
+ # beautifying patch for disabled icons
+ epatch ${FILESDIR}/${P}-disable_icons_smooth_alpha.patch
+ # fixing expose loops in GtkTreeView (gnome #106311)
+ epatch ${FILESDIR}/${P}-scrollfix.patch
+
+ if [ "${ARCH}" == "ppc" ]
+ then
+ einfo "Fixing endianness issue in gdkpixbuf for 24-bit and 15-bit displays"
+ cd ${S}; epatch ${FILESDIR}/gtk+-2.2.1-gdkpixbuf-bigendian.patch
+ fi
+}
+
+src_compile() {
+ # bug 8762
+ replace-flags "-O3" "-O2"
+
+ elibtoolize
+
+ local myconf=""
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ use jpeg || myconf="${myconf} --without-libjpeg"
+ use tiff || myconf="${myconf} --without-libtiff"
+ if [ -n "$DEBUGBUILD" ]; then
+ myconf="${myconf} --enable-debug"
+ fi
+
+ econf --with-gdktarget=x11 ${myconf} || die
+
+ # gtk+ isn't multithread friendly due to some obscure code generation bug
+ make || die
+}
+
+src_install() {
+ dodir /etc/gtk-2.0
+
+ make DESTDIR=${D} \
+ prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog* HACKING INSTALL NEWS* README*
+}
+
+pkg_postinst() {
+ gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+ gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders
+
+ einfo "For your gtk themes to work correctly after an update,"
+ einfo "you might have to rebuild your theme engines."
+ einfo "Executing 'qpkg -I -nc gtk-engines | xargs emerge' should do the trick (requires gentoolkit)"
+}