summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-06-16 11:33:22 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-06-16 11:33:22 +0000
commitcc5583859464ef2c5c471c38ebb76bd99f675156 (patch)
tree55b06f5ed9b31f40698bd9f6fd482ff27f6ac0de /x11-libs/gtk+
parentVersion bump. (diff)
downloadgentoo-2-cc5583859464ef2c5c471c38ebb76bd99f675156.tar.gz
gentoo-2-cc5583859464ef2c5c471c38ebb76bd99f675156.tar.bz2
gentoo-2-cc5583859464ef2c5c471c38ebb76bd99f675156.zip
Skip tests known to fail, fix introspection eautoreconf failure
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog6
-rw-r--r--x11-libs/gtk+/gtk+-2.24.4.ebuild9
-rw-r--r--x11-libs/gtk+/gtk+-2.24.5.ebuild11
3 files changed, 21 insertions, 5 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 961a980b58f1..e7f713265e85 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/gtk+
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.514 2011/06/16 11:07:26 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.515 2011/06/16 11:33:22 nirbheek Exp $
+
+ 16 Jun 2011; Nirbheek Chauhan <nirbheek@gentoo.org> gtk+-2.24.4.ebuild,
+ gtk+-2.24.5.ebuild:
+ Skip tests known to fail, fix introspection eautoreconf failure
16 Jun 2011; Nirbheek Chauhan <nirbheek@gentoo.org> gtk+-2.24.5.ebuild:
Fix bug 371907 by creating m4, and passing the appropriate AT_M4DIR
diff --git a/x11-libs/gtk+/gtk+-2.24.4.ebuild b/x11-libs/gtk+/gtk+-2.24.4.ebuild
index 55f847b28014..434052914ac0 100644
--- a/x11-libs/gtk+/gtk+-2.24.4.ebuild
+++ b/x11-libs/gtk+/gtk+-2.24.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.24.4.ebuild,v 1.1 2011/06/03 18:58:10 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.24.4.ebuild,v 1.2 2011/06/16 11:33:22 nirbheek Exp $
EAPI="3"
GNOME2_LA_PUNT="yes"
@@ -123,6 +123,11 @@ src_prepare() {
if ! use test; then
# don't waste time building tests
strip_builddir SRC_SUBDIRS tests Makefile.am Makefile.in
+ else
+ # Skip tests known to fail
+ # https://bugzilla.gnome.org/show_bug.cgi?id=646609
+ sed -e '/g_test_add_func.*test_text_access/s:^://:' \
+ -i "${S}/gtk/tests/testing.c" || die
fi
if ! use examples; then
@@ -130,9 +135,9 @@ src_prepare() {
strip_builddir SRC_SUBDIRS demos Makefile.am Makefile.in
fi
+ eautoreconf
# Use elibtoolize in place of eautoreconf when it will be dropped
#elibtoolize
- eautoreconf
}
src_configure() {
diff --git a/x11-libs/gtk+/gtk+-2.24.5.ebuild b/x11-libs/gtk+/gtk+-2.24.5.ebuild
index cb229ff976ff..f442f7404c90 100644
--- a/x11-libs/gtk+/gtk+-2.24.5.ebuild
+++ b/x11-libs/gtk+/gtk+-2.24.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.24.5.ebuild,v 1.2 2011/06/16 11:07:26 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.24.5.ebuild,v 1.3 2011/06/16 11:33:22 nirbheek Exp $
EAPI="3"
GNOME2_LA_PUNT="yes"
@@ -11,6 +11,7 @@ inherit eutils flag-o-matic gnome.org libtool python virtualx autotools
DESCRIPTION="Gimp ToolKit +"
HOMEPAGE="http://www.gtk.org/"
+SRC_URI="${SRC_URI} mirror://gentoo/introspection.m4.bz2"
LICENSE="LGPL-2"
SLOT="2"
@@ -124,6 +125,11 @@ src_prepare() {
if ! use test; then
# don't waste time building tests
strip_builddir SRC_SUBDIRS tests Makefile.am Makefile.in
+ else
+ # Skip tests known to fail
+ # https://bugzilla.gnome.org/show_bug.cgi?id=646609
+ sed -e '/g_test_add_func.*test_text_access/s:^://:' \
+ -i "${S}/gtk/tests/testing.c" || die
fi
if ! use examples; then
@@ -132,7 +138,8 @@ src_prepare() {
fi
# http://bugs.gentoo.org/show_bug.cgi?id=371907
- mkdir -p "${S}/m4"
+ mkdir -p "${S}/m4" || die
+ mv "${WORKDIR}/introspection.m4" "${S}/m4macros" || die
AT_M4DIR=m4macros eautoreconf
# Use elibtoolize in place of eautoreconf when it will be dropped
#elibtoolize