summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-12-06 21:45:55 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-12-06 21:45:55 +0000
commit2107c006e0ccd2e0fea3a8f1582e957620ef115f (patch)
treed26f58c399ac568c288ec83d2cd04435497b2149 /x11-libs/gtkmathview/files
parentAdd x32 ABI backport (for x86-64 targets) from gcc-4.7. (diff)
downloadgentoo-2-2107c006e0ccd2e0fea3a8f1582e957620ef115f.tar.gz
gentoo-2-2107c006e0ccd2e0fea3a8f1582e957620ef115f.tar.bz2
gentoo-2-2107c006e0ccd2e0fea3a8f1582e957620ef115f.zip
Fix underlinking (bug #369117, thanks to flameeyes and Oschtan), and move to EAPI4 and drop .la files.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtkmathview/files')
-rw-r--r--x11-libs/gtkmathview/files/binreloc.m477
-rw-r--r--x11-libs/gtkmathview/files/gtkmathview-0.8.0-underlinking.patch61
2 files changed, 138 insertions, 0 deletions
diff --git a/x11-libs/gtkmathview/files/binreloc.m4 b/x11-libs/gtkmathview/files/binreloc.m4
new file mode 100644
index 000000000000..46696bf64567
--- /dev/null
+++ b/x11-libs/gtkmathview/files/binreloc.m4
@@ -0,0 +1,77 @@
+# Check for binary relocation support
+# Hongli Lai
+# http://autopackage.org/
+
+AC_DEFUN([AM_BINRELOC],
+[
+ AC_ARG_ENABLE(binreloc,
+ [ --enable-binreloc compile with binary relocation support
+ (default=disable)],
+ enable_binreloc=$enableval,enable_binreloc=no)
+
+ AC_ARG_ENABLE(binreloc-threads,
+ [ --enable-binreloc-threads compile binary relocation with threads support
+ (default=yes)],
+ enable_binreloc_threads=$enableval,enable_binreloc_threads=yes)
+
+ BINRELOC_CFLAGS=
+ BINRELOC_LIBS=
+ if test "x$enable_binreloc" = "xauto"; then
+ AC_CHECK_FILE([/proc/self/maps])
+ AC_CACHE_CHECK([whether everything is installed to the same prefix],
+ [br_cv_valid_prefixes], [
+ if test "$bindir" = '${exec_prefix}/bin' -a "$sbindir" = '${exec_prefix}/sbin' -a \
+ "$datadir" = '${prefix}/share' -a "$libdir" = '${exec_prefix}/lib' -a \
+ "$libexecdir" = '${exec_prefix}/libexec' -a "$sysconfdir" = '${prefix}/etc'
+ then
+ br_cv_valid_prefixes=yes
+ else
+ br_cv_valid_prefixes=no
+ fi
+ ])
+ fi
+ AC_CACHE_CHECK([whether binary relocation support should be enabled],
+ [br_cv_binreloc],
+ [if test "x$enable_binreloc" = "xyes"; then
+ br_cv_binreloc=yes
+ elif test "x$enable_binreloc" = "xauto"; then
+ if test "x$br_cv_valid_prefixes" = "xyes" -a \
+ "x$ac_cv_file__proc_self_maps" = "xyes"; then
+ br_cv_binreloc=yes
+ else
+ br_cv_binreloc=no
+ fi
+ else
+ br_cv_binreloc=no
+ fi])
+
+ if test "x$br_cv_binreloc" = "xyes"; then
+ BINRELOC_CFLAGS="-DENABLE_BINRELOC"
+ AC_DEFINE(ENABLE_BINRELOC,,[Use binary relocation?])
+ if test "x$enable_binreloc_threads" = "xyes"; then
+ AC_CHECK_LIB([pthread], [pthread_getspecific])
+ fi
+
+ AC_CACHE_CHECK([whether binary relocation should use threads],
+ [br_cv_binreloc_threads],
+ [if test "x$enable_binreloc_threads" = "xyes"; then
+ if test "x$ac_cv_lib_pthread_pthread_getspecific" = "xyes"; then
+ br_cv_binreloc_threads=yes
+ else
+ br_cv_binreloc_threads=no
+ fi
+ else
+ br_cv_binreloc_threads=no
+ fi])
+
+ if test "x$br_cv_binreloc_threads" = "xyes"; then
+ BINRELOC_LIBS="-lpthread"
+ AC_DEFINE(BR_PTHREAD,1,[Include pthread support for binary relocation?])
+ else
+ BINRELOC_CFLAGS="$BINRELOC_CFLAGS -DBR_PTHREADS=0"
+ AC_DEFINE(BR_PTHREAD,0,[Include pthread support for binary relocation?])
+ fi
+ fi
+ AC_SUBST(BINRELOC_CFLAGS)
+ AC_SUBST(BINRELOC_LIBS)
+])
diff --git a/x11-libs/gtkmathview/files/gtkmathview-0.8.0-underlinking.patch b/x11-libs/gtkmathview/files/gtkmathview-0.8.0-underlinking.patch
new file mode 100644
index 000000000000..35cb9bec6a9d
--- /dev/null
+++ b/x11-libs/gtkmathview/files/gtkmathview-0.8.0-underlinking.patch
@@ -0,0 +1,61 @@
+From 319c39458e72be82ed1ce60f0a386a146964f507 Mon Sep 17 00:00:00 2001
+From: Sylvestre Ledru <sylvestre@debian.org>
+Date: Sun, 13 Mar 2011 19:00:15 +0100
+Subject: [PATCH] Fix underlinking (required to build with gold link editor)
+
+See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=554753
+---
+ mathmlps/Makefile.am | 1 +
+ mathmlsvg/Makefile.am | 2 ++
+ viewer/Makefile.am | 3 +++
+ 3 files changed, 6 insertions(+), 0 deletions(-)
+
+diff --git a/mathmlps/Makefile.am b/mathmlps/Makefile.am
+index 201f410..717cd20 100644
+--- a/mathmlps/Makefile.am
++++ b/mathmlps/Makefile.am
+@@ -17,6 +17,7 @@ mathmlps_LDADD = \
+ $(GLIB_LIBS) \
+ $(top_builddir)/src/backend/ps/libmathview_backend_ps.la \
+ $(top_builddir)/src/view/libmathview_frontend_libxml2.la \
++ $(top_builddir)/src/libmathview.la \
+ $(NULL)
+
+ INCLUDES = \
+diff --git a/mathmlsvg/Makefile.am b/mathmlsvg/Makefile.am
+index 2290230..8007350 100644
+--- a/mathmlsvg/Makefile.am
++++ b/mathmlsvg/Makefile.am
+@@ -30,6 +30,8 @@ mathmlsvg_LDADD = \
+ $(GLIB_LIBS) \
+ $(top_builddir)/src/backend/svg/libmathview_backend_svg.la \
+ $(top_builddir)/src/view/libmathview_frontend_libxml2.la \
++ $(top_builddir)/src/libmathview.la \
++ -lxml2 \
+ $(NULL)
+
+ INCLUDES = \
+diff --git a/viewer/Makefile.am b/viewer/Makefile.am
+index 7b950a0..67220b4 100644
+--- a/viewer/Makefile.am
++++ b/viewer/Makefile.am
+@@ -31,6 +31,7 @@ mathmlviewer_static_LDADD = \
+ $(DOM_LIBS) \
+ $(GTK_LIBS) \
+ $(top_builddir)/src/widget/libgtkmathview_gmetadom.la \
++ $(top_builddir)/src/engine/boxml/libboxml.la \
+ $(T1_LIBS) \
+ $(T1_LIBS_X) \
+ $(NULL)
+@@ -88,6 +89,8 @@ test_rendering_LDADD = \
+ $(T1_LIBS_X) \
+ $(GLIB_LIBS) \
+ $(top_builddir)/src/backend/gtk/libmathview_backend_gtk.la \
++ $(top_builddir)/src/libmathview.la \
++ $(top_builddir)/src/engine/boxml/libboxml.la \
+ $(top_builddir)/src/view/libmathview_frontend_libxml2.la \
+ $(NULL)
+
+--
+1.7.8
+