summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-07-24 13:23:46 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-07-24 13:23:46 +0000
commit2bf043e3465e85b3f2e9b083f4e456d0033a990e (patch)
treed5807e6fd0853d53aabc4c60d0b593a2c7e057ca /x11-libs/gtksourceview
parentVersion bump. Translation updates. (diff)
downloadgentoo-2-2bf043e3465e85b3f2e9b083f4e456d0033a990e.tar.gz
gentoo-2-2bf043e3465e85b3f2e9b083f4e456d0033a990e.tar.bz2
gentoo-2-2bf043e3465e85b3f2e9b083f4e456d0033a990e.zip
Version bump. Misc bugfixes.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/ChangeLog8
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.0.5.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/x11-libs/gtksourceview/ChangeLog b/x11-libs/gtksourceview/ChangeLog
index 8d832d55d79a..d71bb2fa6a0b 100644
--- a/x11-libs/gtksourceview/ChangeLog
+++ b/x11-libs/gtksourceview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gtksourceview
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.204 2011/06/20 11:45:03 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.205 2011/07/24 13:23:46 eva Exp $
+
+*gtksourceview-3.0.5 (24 Jul 2011)
+
+ 24 Jul 2011; Gilles Dartiguelongue <eva@gentoo.org>
+ +gtksourceview-3.0.5.ebuild:
+ Version bump. Misc bugfixes.
*gtksourceview-3.0.4 (20 Jun 2011)
diff --git a/x11-libs/gtksourceview/gtksourceview-3.0.5.ebuild b/x11-libs/gtksourceview/gtksourceview-3.0.5.ebuild
new file mode 100644
index 000000000000..f9af36779221
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.0.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-3.0.5.ebuild,v 1.1 2011/07/24 13:23:46 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://projects.gnome.org/gtksourceview/"
+
+LICENSE="GPL-2"
+SLOT="3.0"
+IUSE="doc glade +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+# Note: has native OSX support, prefix teams, attack!
+RDEPEND=">=x11-libs/gtk+-3.0:3[introspection?]
+ >=dev-libs/libxml2-2.6:2
+ >=dev-libs/glib-2.28:2
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1.11 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+ G2CONF="${G2CONF}
+ --disable-deprecations
+ --enable-providers
+ $(use_enable glade glade-catalog)
+ $(use_enable introspection)"
+}
+
+src_prepare() {
+ sed -i -e 's:--warn-all::' gtksourceview/Makefile.in || die
+
+ # Skip broken test until upstream bug #621383 is solved
+ sed -e "/guess-language/d" \
+ -e "/get-language/d" \
+ -i tests/test-languagemanager.c || die
+
+ gnome2_src_prepare
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}