summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-03-21 14:05:45 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-03-21 14:05:45 +0000
commit2ecadce8418af86de23a373106e7d0b049e731fd (patch)
treee8050d665b6e9c2000aa02a2b75907e5ba62a64f /x11-libs/libX11
parentDefault to /etc/portage/make.conf #338032 by Dennis Schridde. (diff)
downloadgentoo-2-2ecadce8418af86de23a373106e7d0b049e731fd.tar.gz
gentoo-2-2ecadce8418af86de23a373106e7d0b049e731fd.tar.bz2
gentoo-2-2ecadce8418af86de23a373106e7d0b049e731fd.zip
Fix cross-compile hack to work with current xorg-2 and autotools-utils eclasses' out-of-tree builds. Also apply it only when actually cross-compiling.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libX11')
-rw-r--r--x11-libs/libX11/ChangeLog7
-rw-r--r--x11-libs/libX11/libX11-1.4.2.ebuild9
2 files changed, 13 insertions, 3 deletions
diff --git a/x11-libs/libX11/ChangeLog b/x11-libs/libX11/ChangeLog
index ac42227aadfc..0bec2d4010ff 100644
--- a/x11-libs/libX11/ChangeLog
+++ b/x11-libs/libX11/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libX11
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/ChangeLog,v 1.170 2011/03/18 18:29:08 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/ChangeLog,v 1.171 2011/03/21 14:05:45 flameeyes Exp $
+
+ 21 Mar 2011; Diego E. Pettenò <flameeyes@gentoo.org> libX11-1.4.2.ebuild:
+ Fix cross-compile hack to work with current xorg-2 and autotools-utils
+ eclasses' out-of-tree builds. Also apply it only when actually
+ cross-compiling.
*libX11-1.4.2 (18 Mar 2011)
diff --git a/x11-libs/libX11/libX11-1.4.2.ebuild b/x11-libs/libX11/libX11-1.4.2.ebuild
index 22ba190c9161..323488f5bba1 100644
--- a/x11-libs/libX11/libX11-1.4.2.ebuild
+++ b/x11-libs/libX11/libX11-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.4.2.ebuild,v 1.1 2011/03/18 18:29:08 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.4.2.ebuild,v 1.2 2011/03/21 14:05:45 flameeyes Exp $
EAPI=4
@@ -45,6 +45,11 @@ src_configure() {
src_compile() {
# [Cross-Compile Love] Disable {C,LD}FLAGS and redefine CC= for 'makekeys'
- ( filter-flags -m* ; cd src/util && make CC=$(tc-getBUILD_CC) CFLAGS="${CFLAGS}" LDFLAGS="" clean all)
+ if tc-is-cross-compiler; then
+ (
+ filter-flags -m*
+ emake -C "${AUTOTOOLS_BUILD_DIR}"/src/util CC=$(tc-getBUILD_CC) CFLAGS="${CFLAGS}" LDFLAGS="" clean all || die
+ )
+ fi
xorg-2_src_compile
}