summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-20 12:51:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-20 12:51:52 +0000
commitaf052c50df14bec486b78c11bab543b9e35b0f5e (patch)
treeb5ad22226f3c0c824bc30bcf858d2b5b93bf12fb /x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild
parentia64/s390/sh/sparc stable wrt #356545 (diff)
downloadgentoo-2-af052c50df14bec486b78c11bab543b9e35b0f5e.tar.gz
gentoo-2-af052c50df14bec486b78c11bab543b9e35b0f5e.tar.bz2
gentoo-2-af052c50df14bec486b78c11bab543b9e35b0f5e.zip
Fix libpng-1.4.x patch wrt #359583.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild')
-rw-r--r--x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild b/x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild
new file mode 100644
index 000000000000..b9e3276adfc8
--- /dev/null
+++ b/x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild,v 1.1 2011/03/20 12:51:52 ssuominen Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="The Matchbox Library."
+HOMEPAGE="http://matchbox-project.org/"
+SRC_URI="http://matchbox-project.org/sources/${PN}/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
+IUSE="debug doc jpeg pango png test truetype X xsettings"
+
+RDEPEND="x11-libs/libXext
+ truetype? ( x11-libs/libXft )
+ pango? ( x11-libs/pango )
+ jpeg? ( virtual/jpeg )
+ png? ( media-libs/libpng )
+ xsettings? ( x11-libs/libxsettings-client )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/check )"
+
+# Test suite broken, missing files and such.
+RESTRICT="test"
+
+pkg_setup() {
+ # Bug #138135
+ if use truetype && use pango; then
+ ewarn "You have both the truetype and pango USE flags set, pango"
+ ewarn "overrides and disables the XFT support truetype enables."
+ ewarn "If this isn't what you intended you should stop the build!"
+ ebeep 3
+ epause 3
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-libpng14.patch
+ elibtoolize
+}
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable doc doxygen-docs) \
+ $(use_enable truetype xft) \
+ $(use_enable pango) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable xsettings) \
+ $(use_with X x) \
+ $(use_enable test unit-tests) \
+ || die "Configuration failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+ use doc && dohtml doc/html/*
+}