summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-05 08:08:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-05 08:08:39 +0000
commit1af6fc1986715bc48a3e33ef1d4dd3b83818885c (patch)
treee593a1fe20bcf395bd77c1a7aa13804c3e0a654d /x11-libs/qscintilla
parentset explicit RDEPEND (diff)
downloadgentoo-2-1af6fc1986715bc48a3e33ef1d4dd3b83818885c.tar.gz
gentoo-2-1af6fc1986715bc48a3e33ef1d4dd3b83818885c.tar.bz2
gentoo-2-1af6fc1986715bc48a3e33ef1d4dd3b83818885c.zip
Repoman warnings
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qscintilla')
-rw-r--r--x11-libs/qscintilla/qscintilla-1.5.1.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/x11-libs/qscintilla/qscintilla-1.5.1.ebuild b/x11-libs/qscintilla/qscintilla-1.5.1.ebuild
index b6c4dfbeafc5..69b44cfc02b4 100644
--- a/x11-libs/qscintilla/qscintilla-1.5.1.ebuild
+++ b/x11-libs/qscintilla/qscintilla-1.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/qscintilla-1.5.1.ebuild,v 1.1 2007/11/20 05:17:20 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/qscintilla-1.5.1.ebuild,v 1.2 2009/05/05 08:08:39 ssuominen Exp $
inherit eutils toolchain-funcs
@@ -20,31 +20,31 @@ LICENSE="GPL-2"
KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
IUSE="doc"
-DEPEND="virtual/libc
- sys-apps/sed
- =x11-libs/qt-3*"
+RDEPEND="=x11-libs/qt-3*"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
LIBDIR="/usr/$(get_libdir)"
src_unpack() {
- unpack ${A} ; cd ${S}/qt
+ unpack ${A} ; cd "${S}"/qt
sed -i -e "s:DESTDIR = \$(QTDIR)/lib:DESTDIR = \${destdir}:" qscintilla.pro
echo -e "\nQMAKE_CFLAGS_RELEASE=${CFLAGS} -w\nQMAKE_CXXFLAGS_RELEASE=${CXXFLAGS} -w\nQMAKE_LFLAGS_RELEASE=${LDFLAGS}" >> qscintilla.pro
${QTDIR}/bin/qmake -o Makefile qscintilla.pro
- epatch ${FILESDIR}/${PN}-1.5-sandbox.patch
+ epatch "${FILESDIR}"/${PN}-1.5-sandbox.patch
}
src_compile() {
- cd ${S}/qt
+ cd "${S}"/qt
# It uses g++'s syntax while linking (-Wl,) so it can't use tc-getLD.
make destdir=${LIBDIR} all staticlib CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" || die "make failed"
}
src_install() {
- dodoc ChangeLog LICENSE NEWS README README.MacOS
+ dodoc ChangeLog NEWS README
dodir /usr/include ${LIBDIR} /usr/share/qscintilla/translations
- cd ${S}/qt
+ cd "${S}"/qt
cp qextscintilla*.h "${D}/usr/include"
cp qscintilla*.qm "${D}/usr/share/qscintilla/translations"
cp libqscintilla.a* "${D}${LIBDIR}"
@@ -54,8 +54,8 @@ src_install() {
dosym "/usr/share/qscintilla/translations/${I}" "${QTDIR}/translations/${I}"
done
if use doc ; then
- dohtml ${S}/doc/html/*
+ dohtml "${S}"/doc/html/*
insinto /usr/share/doc/${PF}/Scintilla
- doins ${S}/doc/Scintilla/*
+ doins "${S}"/doc/Scintilla/*
fi
}