summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-10-09 20:26:39 +0000
committerAlex Alexander <wired@gentoo.org>2010-10-09 20:26:39 +0000
commitbc8791be889d00a274ce623a058d2f5dc0315c7f (patch)
treece68d4edb42e624af0a049c0006d182686e29547 /x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
parentStable on amd64 wrt bug #339475 (diff)
downloadgentoo-2-bc8791be889d00a274ce623a058d2f5dc0315c7f.tar.gz
gentoo-2-bc8791be889d00a274ce623a058d2f5dc0315c7f.tar.bz2
gentoo-2-bc8791be889d00a274ce623a058d2f5dc0315c7f.zip
added optional compatibility package support
(Portage version: 2.2_rc89/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild')
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild31
1 files changed, 29 insertions, 2 deletions
diff --git a/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild b/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
index 3418ac9384d6..0924800d524c 100644
--- a/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
+++ b/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild,v 1.4 2010/10/09 16:50:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild,v 1.5 2010/10/09 20:26:38 wired Exp $
EAPI="3"
inherit qt4-build
@@ -8,7 +8,8 @@ inherit qt4-build
DESCRIPTION="The assistant help module for the Qt toolkit"
SLOT="4"
KEYWORDS="~amd64 ~arm ~ia64 ~x86"
-IUSE="doc +glib trace"
+IUSE="compat doc +glib trace"
+SRC_URI+=" compat? ( ftp://ftp.qt.nokia.com/qt/source/${PN}-qassistantclient-library-compat-src-4.6.3.tar.gz )"
DEPEND="~x11-libs/qt-gui-${PV}[aqua=,glib=,trace?]
~x11-libs/qt-sql-${PV}[aqua=,sqlite]
@@ -38,6 +39,27 @@ pkg_setup() {
qt4-build_pkg_setup
}
+src_unpack() {
+ qt4-build_src_unpack
+ # compat version
+ # http://labs.qt.nokia.com/2010/06/22/qt-assistant-compat-version-available-as-extra-source-package/
+ if use compat; then
+ unpack "${PN}"-qassistantclient-library-compat-src-4.6.3.tar.gz
+ mv "${WORKDIR}"/"${PN}"-qassistantclient-library-compat-version-4.6.3 \
+ "${S}"/tools/assistant/compat ||
+ die "moving compat to the right place failed"
+ tar xzf "${FILESDIR}"/"${PN}"-4.7-include.tar.gz -C "${S}"/include/ ||
+ die "unpacking the include files failed"
+ fi
+}
+
+src_prepare() {
+ qt4-build_src_prepare
+ if use compat; then
+ epatch "${FILESDIR}"/"${PN}"-4.7-fix-compat.patch
+ fi
+}
+
src_configure() {
myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
-no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
@@ -85,4 +107,9 @@ src_install() {
make_desktop_entry "${EPREFIX}"/usr/bin/assistant Assistant \
"${EPREFIX}"/usr/share/pixmaps/assistant.png 'Qt;Development;GUIDesigner' ||
die "make_desktop_entry failed"
+
+ if use compat; then
+ insinto /usr/share/qt4/mkspecs/features || die "insinto failed"
+ doins tools/assistant/compat/features/assistant.prf || die "doins failed"
+ fi
}