summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-10-16 16:46:57 +0000
committerAlex Alexander <wired@gentoo.org>2009-10-16 16:46:57 +0000
commitb1910fff9f423a6518da1172dd45c4e6ee5d5812 (patch)
treea2f7be4e2775a483ca737f872eb3af35948c77a4 /x11-libs/qt-assistant
parentadded version 4.6.0_beta1 (diff)
downloadgentoo-2-b1910fff9f423a6518da1172dd45c4e6ee5d5812.tar.gz
gentoo-2-b1910fff9f423a6518da1172dd45c4e6ee5d5812.tar.bz2
gentoo-2-b1910fff9f423a6518da1172dd45c4e6ee5d5812.zip
added version 4.6.0_beta1
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-assistant')
-rw-r--r--x11-libs/qt-assistant/ChangeLog8
-rw-r--r--x11-libs/qt-assistant/files/qt-assistant-4.6-tools.patch37
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.6.0_beta1.ebuild76
3 files changed, 120 insertions, 1 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index 03971c74d867..5fc69ff5ec20 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.48 2009/10/11 17:22:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.49 2009/10/16 16:46:56 wired Exp $
+
+*qt-assistant-4.6.0_beta1 (16 Oct 2009)
+
+ 16 Oct 2009; Alex Alexander <wired@gentoo.org>
+ +qt-assistant-4.6.0_beta1.ebuild, +files/qt-assistant-4.6-tools.patch:
+ added version 4.6.0_beta1
11 Oct 2009; Raúl Porcel <armin76@gentoo.org> qt-assistant-4.5.2.ebuild:
alpha/ia64 stable wrt #286653
diff --git a/x11-libs/qt-assistant/files/qt-assistant-4.6-tools.patch b/x11-libs/qt-assistant/files/qt-assistant-4.6-tools.patch
new file mode 100644
index 000000000000..b9f897dfdeab
--- /dev/null
+++ b/x11-libs/qt-assistant/files/qt-assistant-4.6-tools.patch
@@ -0,0 +1,37 @@
+diff --git a/tools/tools.pro b/tools/tools.pro
+index 4b36115..d3dd1a5 100644
+--- a/tools/tools.pro
++++ b/tools/tools.pro
+@@ -4,31 +4,9 @@ no-png {
+ message("Some graphics-related tools are unavailable without PNG support")
+ } else {
+ SUBDIRS += assistant \
+ pixeltool \
+- porting \
+- qtestlib \
+- qttracereplay
+- contains(QT_EDITION, Console) {
+- SUBDIRS += designer/src/uitools # Linguist depends on this
+- } else {
+- SUBDIRS += designer
+- }
+- SUBDIRS += linguist
+- symbian: SUBDIRS = designer
+- wince*: SUBDIRS = qtestlib designer
+- unix:!mac:!embedded:contains(QT_CONFIG, qt3support):SUBDIRS += qtconfig
+- win32:!wince*:SUBDIRS += activeqt
++ qdoc3
+ }
+
+-mac {
+- SUBDIRS += macdeployqt
+-}
+-
+-embedded:SUBDIRS += kmap2qmap
+-
+-contains(QT_CONFIG, dbus):SUBDIRS += qdbus
+-!wince*:contains(QT_CONFIG, xmlpatterns): SUBDIRS += xmlpatterns xmlpatternsvalidator
+-embedded: SUBDIRS += makeqpf
+-
+ CONFIG+=ordered
+ QTDIR_build:REQUIRES = "contains(QT_CONFIG, full-config)"
diff --git a/x11-libs/qt-assistant/qt-assistant-4.6.0_beta1.ebuild b/x11-libs/qt-assistant/qt-assistant-4.6.0_beta1.ebuild
new file mode 100644
index 000000000000..1806cfecde65
--- /dev/null
+++ b/x11-libs/qt-assistant/qt-assistant-4.6.0_beta1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.6.0_beta1.ebuild,v 1.1 2009/10/16 16:46:56 wired Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The assistant help module for the Qt toolkit."
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ ~x11-libs/qt-gui-${PV}
+ ~x11-libs/qt-sql-${PV}[sqlite]
+ ~x11-libs/qt-webkit-${PV}
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.6-tools.patch"
+)
+
+# Pixeltool isn't really assistant related, but it relies on
+# the assistant libraries. doc/qch/
+QT4_TARGET_DIRECTORIES="
+tools/assistant
+tools/pixeltool
+tools/qdoc3"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+tools/
+demos/
+examples/
+src/
+include/
+doc/"
+src_configure() {
+ myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-multimedia -no-qt3support -no-svg"
+ qt4-build_src_configure
+}
+
+src_compile() {
+ qt4-build_src_compile
+ # ugly hack to build docs
+ cd "${S}"
+ export LD_LIBRARY_PATH="${S}/lib"
+ qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" projects.pro || die "qmake projects faied"
+ emake qch_docs || die "emake docs failed"
+}
+
+src_install() {
+ qt4-build_src_install
+ # install documentation
+ # note that emake install_qchdocs fails for undefined reason so we use a
+ # workaround
+ cd "${S}"
+ insinto "${QTDOCDIR}"
+ doins -r "${S}"/doc/qch || die "doins qch documentation failed"
+ dobin "${S}"/bin/qdoc3 || die "Installing qdoc3 failed"
+ #emake INSTALL_ROOT="${D}" install_qchdocs || die "emake install_qchdocs failed"
+ # install correct assistant icon, bug 241208
+ dodir /usr/share/pixmaps/ || die "dodir failed"
+ insinto /usr/share/pixmaps/ || die "insinto failed"
+ doins tools/assistant/tools/assistant/images/assistant.png \
+ || die "doins failed"
+ # Note: absolute image path required here!
+ make_desktop_entry /usr/bin/assistant Assistant \
+ /usr/share/pixmaps/assistant.png 'Qt;Development;GUIDesigner' \
+ || die "make_desktop_entry failed"
+
+}