summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-10-04 10:22:29 +0000
committerAlex Alexander <wired@gentoo.org>2009-10-04 10:22:29 +0000
commitf6ba117aaa1bd9988d5b0fbc79c2b2182f7ff214 (patch)
tree79b7c9a6031b87c21825ff6a462295e40c83efa3 /x11-libs/qt-assistant
parentversion bump (diff)
downloadgentoo-2-f6ba117aaa1bd9988d5b0fbc79c2b2182f7ff214.tar.gz
gentoo-2-f6ba117aaa1bd9988d5b0fbc79c2b2182f7ff214.tar.bz2
gentoo-2-f6ba117aaa1bd9988d5b0fbc79c2b2182f7ff214.zip
version bump
(Portage version: 2.2_rc43/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-assistant')
-rw-r--r--x11-libs/qt-assistant/ChangeLog7
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.5.3.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index adbba28c99a1..264a1a46e81a 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.44 2009/08/18 12:54:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.45 2009/10/04 10:22:29 wired Exp $
+
+*qt-assistant-4.5.3 (04 Oct 2009)
+
+ 04 Oct 2009; Alex Alexander <wired@gentoo.org> +qt-assistant-4.5.3.ebuild:
+ version bump
18 Aug 2009; Jeroen Roovers <jer@gentoo.org> qt-assistant-4.5.1.ebuild:
Stable for HPPA too.
diff --git a/x11-libs/qt-assistant/qt-assistant-4.5.3.ebuild b/x11-libs/qt-assistant/qt-assistant-4.5.3.ebuild
new file mode 100644
index 000000000000..b641333eab08
--- /dev/null
+++ b/x11-libs/qt-assistant/qt-assistant-4.5.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.5.3.ebuild,v 1.1 2009/10/04 10:22:29 wired Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The assistant help module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="~x11-libs/qt-gui-${PV}[debug=]
+ ~x11-libs/qt-sql-${PV}[debug=,sqlite]
+ ~x11-libs/qt-webkit-${PV}[debug=]"
+RDEPEND="${DEPEND} !<x11-libs/qt-4.4.0:4"
+
+# Pixeltool isn't really assistant related, but it relies on
+# the assistant libraries. And qdoc3 is needed by qt-creator...
+QT4_TARGET_DIRECTORIES="tools/assistant tools/pixeltool tools/qdoc3"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+src/3rdparty/clucene/
+tools/shared/fontpanel
+include/
+src/
+doc/"
+
+src_configure() {
+ myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-qt3support -no-svg -no-gtkstyle"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+ insinto ${QTDOCDIR}
+ doins -r "${S}"/doc/qch/ || die "Installing qch documentation failed"
+ dobin "${S}"/tools/qdoc3/qdoc3 || die "Installing qdoc3 failed"
+
+ # install correct assistant icon, bug 241208
+ dodir /usr/share/pixmaps/ || die "dodir failed"
+ insinto /usr/share/pixmaps/ || die "insinto failed"
+ doins tools/assistant/tools/assistant/images/assistant.png \
+ || die "doins failed"
+ # Note: absolute image path required here!
+ make_desktop_entry /usr/bin/assistant Assistant \
+ /usr/share/pixmaps/assistant.png 'Qt;Development;GUIDesigner' \
+ || die "make_desktop_entry failed"
+}