summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-09-19 00:13:45 +0000
committerBen de Groot <yngwin@gentoo.org>2008-09-19 00:13:45 +0000
commit03818f865bcad8011c47625f6c7732bd2bfa34e0 (patch)
treeb51d67c4da3886fa880ba2f90223e1294f93aac0 /x11-libs/qt-phonon
parentqt-4.4.2 version bump (diff)
downloadgentoo-2-03818f865bcad8011c47625f6c7732bd2bfa34e0.tar.gz
gentoo-2-03818f865bcad8011c47625f6c7732bd2bfa34e0.tar.bz2
gentoo-2-03818f865bcad8011c47625f6c7732bd2bfa34e0.zip
qt-4.4.2 version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.5 i686)
Diffstat (limited to 'x11-libs/qt-phonon')
-rw-r--r--x11-libs/qt-phonon/ChangeLog7
-rw-r--r--x11-libs/qt-phonon/qt-phonon-4.4.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/x11-libs/qt-phonon/ChangeLog b/x11-libs/qt-phonon/ChangeLog
index 4d33aecfbda9..9c5fccdb1416 100644
--- a/x11-libs/qt-phonon/ChangeLog
+++ b/x11-libs/qt-phonon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-phonon
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.11 2008/08/13 23:14:37 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.12 2008/09/19 00:13:45 yngwin Exp $
+
+*qt-phonon-4.4.2 (19 Sep 2008)
+
+ 19 Sep 2008; Ben de Groot <yngwin@gentoo.org> +qt-phonon-4.4.2.ebuild:
+ Version bump
*qt-phonon-4.4.1-r1 (13 Aug 2008)
diff --git a/x11-libs/qt-phonon/qt-phonon-4.4.2.ebuild b/x11-libs/qt-phonon/qt-phonon-4.4.2.ebuild
new file mode 100644
index 000000000000..5917f20e1b00
--- /dev/null
+++ b/x11-libs/qt-phonon/qt-phonon-4.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/qt-phonon-4.4.2.ebuild,v 1.1 2008/09/19 00:13:45 yngwin Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The Phonon module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="dbus"
+
+DEPEND="~x11-libs/qt-gui-${PV}
+ !<=x11-libs/qt-4.4.0_alpha:${SLOT}
+ media-libs/gstreamer
+ media-libs/gst-plugins-base
+ dbus? ( =x11-libs/qt-dbus-${PV} )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/phonon
+src/plugins/phonon"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+src/3rdparty/kdelibs/phonon/
+src/3rdparty/kdebase/runtime/phonon/"
+QCONFIG_ADD="phonon"
+QCONFIG_DEFINE="QT_GSTREAMER"
+
+# see bug 225721
+QT4_BUILT_WITH_USE_CHECK="~x11-libs/qt-core-${PV} glib
+~x11-libs/qt-gui-${PV} glib"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -phonon -no-opengl -no-svg
+ $(qt_use dbus qdbus)"
+
+ qt4-build_src_compile
+}