summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:11:13 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:11:13 +0000
commit1e9d1cd8022c9b438b8fbb6d155ed1370b23c73a (patch)
tree59a614fd25fec54063e1e6c52e99777e520545d6 /x11-libs/qt-test
parentAdded Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled (diff)
downloadgentoo-2-1e9d1cd8022c9b438b8fbb6d155ed1370b23c73a.tar.gz
gentoo-2-1e9d1cd8022c9b438b8fbb6d155ed1370b23c73a.tar.bz2
gentoo-2-1e9d1cd8022c9b438b8fbb6d155ed1370b23c73a.zip
Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
`technical preview`, so this will appear as a downgrade if you installed that version. Thanks to David Leverton, Bo Andresen, Bernd Steinhauser & Arfrever Frehtes Taifersar Arahesis Fixes bugs: 206975, 212086, 172219, 212069, 206976 (Portage version: 2.1.4.4)
Diffstat (limited to 'x11-libs/qt-test')
-rw-r--r--x11-libs/qt-test/ChangeLog12
-rw-r--r--x11-libs/qt-test/qt-test-4.4.0_beta1.ebuild30
2 files changed, 40 insertions, 2 deletions
diff --git a/x11-libs/qt-test/ChangeLog b/x11-libs/qt-test/ChangeLog
index 3d5594eaaaa0..d83ac8c5e8af 100644
--- a/x11-libs/qt-test/ChangeLog
+++ b/x11-libs/qt-test/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/qt-test
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.1 2007/12/21 19:03:20 caleb Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.2 2008/03/05 23:11:13 ingmar Exp $
+
+*qt-test-4.4.0_beta1 (05 Mar 2008)
+
+ 05 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ +qt-test-4.4.0_beta1.ebuild:
+ Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
+ `technical preview`, so this will appear as a downgrade if you installed
+ that version.
*qt-test-4.4.0_rc1 (21 Dec 2007)
diff --git a/x11-libs/qt-test/qt-test-4.4.0_beta1.ebuild b/x11-libs/qt-test/qt-test-4.4.0_beta1.ebuild
new file mode 100644
index 000000000000..2880df983b09
--- /dev/null
+++ b/x11-libs/qt-test/qt-test-4.4.0_beta1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.4.0_beta1.ebuild,v 1.1 2008/03/05 23:11:13 ingmar Exp $
+
+inherit qt4-build
+
+DESCRIPTION="The testing framework module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/testlib"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-qdbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl"
+
+ qt4-build_src_compile
+}