summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-19 14:58:23 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-19 14:58:23 +0000
commit94250a30b4e9ed0d54d6dffdb2dd431ca7059366 (patch)
tree6de4a463dea611994ebb6bae95512f6649c1148f /x11-libs/qt-test
parentVersion bump (diff)
downloadgentoo-2-94250a30b4e9ed0d54d6dffdb2dd431ca7059366.tar.gz
gentoo-2-94250a30b4e9ed0d54d6dffdb2dd431ca7059366.tar.bz2
gentoo-2-94250a30b4e9ed0d54d6dffdb2dd431ca7059366.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-test')
-rw-r--r--x11-libs/qt-test/ChangeLog9
-rw-r--r--x11-libs/qt-test/qt-test-4.6.1.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/x11-libs/qt-test/ChangeLog b/x11-libs/qt-test/ChangeLog
index 4bc8291fcced..718e875b9bfd 100644
--- a/x11-libs/qt-test/ChangeLog
+++ b/x11-libs/qt-test/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-test
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.56 2009/12/25 15:46:29 abcd Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.57 2010/01/19 14:58:23 yngwin Exp $
+
+*qt-test-4.6.1 (19 Jan 2010)
+
+ 19 Jan 2010; Ben de Groot <yngwin@gentoo.org> +qt-test-4.6.1.ebuild:
+ Version bump
*qt-test-4.6.0-r1 (25 Dec 2009)
diff --git a/x11-libs/qt-test/qt-test-4.6.1.ebuild b/x11-libs/qt-test/qt-test-4.6.1.ebuild
new file mode 100644
index 000000000000..0fc10bb06c9b
--- /dev/null
+++ b/x11-libs/qt-test/qt-test-4.6.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.6.1.ebuild,v 1.1 2010/01/19 14:58:23 yngwin Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The testing framework module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/testlib"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtTest/
+include/QtCore/
+src/corelib/"
+
+PATCHES=(
+ "${FILESDIR}/qt-4.6-nolibx11.diff"
+)
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg"
+ qt4-build_src_configure
+}