summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-01-16 08:13:34 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-01-16 08:13:34 +0000
commit6e966cb38ce753d88e3d844073698c55c9420cb4 (patch)
treee9dac7a216c32b355a6c3253c4afb1ea737d02f2 /x11-libs/qt
parentAesop 0.4: a stackable encrypted tcp tunneling package (diff)
downloadgentoo-2-6e966cb38ce753d88e3d844073698c55c9420cb4.tar.gz
gentoo-2-6e966cb38ce753d88e3d844073698c55c9420cb4.tar.bz2
gentoo-2-6e966cb38ce753d88e3d844073698c55c9420cb4.zip
support for postgres sql plugin
Diffstat (limited to 'x11-libs/qt')
-rw-r--r--x11-libs/qt/files/digest-qt-3.0.1-r2 (renamed from x11-libs/qt/files/digest-qt-3.0.1-r1)1
-rw-r--r--x11-libs/qt/qt-3.0.1-r2.ebuild (renamed from x11-libs/qt/qt-3.0.1-r1.ebuild)22
2 files changed, 17 insertions, 6 deletions
diff --git a/x11-libs/qt/files/digest-qt-3.0.1-r1 b/x11-libs/qt/files/digest-qt-3.0.1-r2
index 6b90fbad670c..78349770bf94 100644
--- a/x11-libs/qt/files/digest-qt-3.0.1-r1
+++ b/x11-libs/qt/files/digest-qt-3.0.1-r2
@@ -1 +1,2 @@
+MD5 a92c77092034fb35c7b3bb82beebd54b postgresql-7.1.3.tar.gz 8126464
MD5 cf9afb61d08396c7ca9a290fc7567e92 qt-x11-free-3.0.1.tar.gz 17821696
diff --git a/x11-libs/qt/qt-3.0.1-r1.ebuild b/x11-libs/qt/qt-3.0.1-r2.ebuild
index b037e1a9780b..42621682114c 100644
--- a/x11-libs/qt/qt-3.0.1-r1.ebuild
+++ b/x11-libs/qt/qt-3.0.1-r2.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.1-r1.ebuild,v 1.1 2002/01/08 01:21:45 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.1-r2.ebuild,v 1.1 2002/01/16 08:13:34 gbevin Exp $
P=qt-x11-${PV}
S=${WORKDIR}/qt-x11-free-${PV}
DESCRIPTION="QT version ${PV}"
-SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-free-${PV}.tar.gz"
+SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-free-${PV}.tar.gz
+ postgres? (ftp://ftp.easynet.be/postgresql/v7.1.3/postgresql-7.1.3.tar.gz)"
HOMEPAGE="http://www.trolltech.com/"
DEPEND=">=media-libs/libpng-1.0.9
@@ -16,6 +17,7 @@ DEPEND=">=media-libs/libpng-1.0.9
opengl? ( virtual/opengl virtual/glu )
nas? ( >=media-libs/nas-1.4.1 )
mysql? ( >=dev-db/mysql-3.2.10 )
+ postgres? ( =dev-db/postgresql-7.1.3 )
odbc? ( >=dev-db/unixODBC-2.0 )
virtual/x11"
@@ -25,6 +27,13 @@ export QTDIR=${S}
src_unpack() {
unpack ${A}
+
+ if [ "`use postgres`" ]
+ then
+ cd ${WORKDIR}/postgresql-7.1.3
+ ./configure
+ fi
+
cd ${S}
cp configure configure.orig
sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
@@ -35,10 +44,11 @@ src_compile() {
export LDFLAGS="-ldl"
- use nas && myconf="${myconf} -system-nas-sound"
- use gif && myconf="${myconf} -qt-gif"
- use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
- use odbc && myconf="${myconf} -plugin-sql-odbc"
+ use nas && myconf="${myconf} -system-nas-sound"
+ use gif && myconf="${myconf} -qt-gif"
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
+ use postgres && myconf="${myconf} -plugin-sql-psql -I${WORKDIR}/postgresql-7.1.3/src/include -I${WORKDIR}/postgresql-7.1.3/src/interfaces/libpq -L/usr/lib"
+ use odbc && myconf="${myconf} -plugin-sql-odbc"
[ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
./configure -sm -thread -stl -system-zlib -system-libjpeg ${myconf} \