summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2009-11-02 09:13:31 +0000
committerJonathan Callen <abcd@gentoo.org>2009-11-02 09:13:31 +0000
commitdf4130b7d98c7f1d2714c21b65a4416d4d076644 (patch)
tree3c821ed4929f97e214cd5cd93087148784552b4a /x11-libs/qt
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-df4130b7d98c7f1d2714c21b65a4416d4d076644.tar.gz
gentoo-2-df4130b7d98c7f1d2714c21b65a4416d4d076644.tar.bz2
gentoo-2-df4130b7d98c7f1d2714c21b65a4416d4d076644.zip
Drop unneeded patches
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'x11-libs/qt')
-rw-r--r--x11-libs/qt/ChangeLog8
-rw-r--r--x11-libs/qt/files/0037-dnd-timestamp-fix.patch56
-rw-r--r--x11-libs/qt/files/qsslsocket-fix.patch43
-rw-r--r--x11-libs/qt/files/qt-3.3.8-mysql-unload-crash.diff47
-rw-r--r--x11-libs/qt/files/qt-ulibc.patch13
5 files changed, 7 insertions, 160 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index 7de74c6b1db4..a9ee677264b9 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.594 2009/10/31 13:44:23 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.595 2009/11/02 09:13:31 abcd Exp $
+
+ 02 Nov 2009; Jonathan Callen <abcd@gentoo.org>
+ -files/0037-dnd-timestamp-fix.patch,
+ -files/qt-3.3.8-mysql-unload-crash.diff, -files/qsslsocket-fix.patch,
+ -files/qt-ulibc.patch:
+ Drop unneeded patches
31 Oct 2009; Markus Meier <maekke@gentoo.org> qt-4.5.3.ebuild:
amd64 stable, bug #290922
diff --git a/x11-libs/qt/files/0037-dnd-timestamp-fix.patch b/x11-libs/qt/files/0037-dnd-timestamp-fix.patch
deleted file mode 100644
index 234e1b794705..000000000000
--- a/x11-libs/qt/files/0037-dnd-timestamp-fix.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-qt-bugs@ issue : 38794
-bugs.kde.org number : 69519
-applied: no
-author: Lubos Lunak <l.lunak@kde.org>
-
- Hello,
-
-please consider applying the attached patch. It changes XDND handling code to
-put the drop timestamp in the right field in the XdndDrop message according
-to http://www.newplanetsoftware.com/xdnd/ . I'm not quite sure why the code
-has the field moved by one, and puts 1<<24 in the flags, but I see it has a
-todo mark next to it. The last snippet of the patch changes it to match the
-XDND spec. I tested briefly with Gtk, Mozilla and OOo, and they still work
-with the patch.
-
-The rest of the patch is for fixing part of
-http://bugs.kde.org/show_bug.cgi?id=69519, when the user drags some data to
-the desktop, and desktop in response popups a dialog asking for filename.
-Without the X user timestamp (qt-bugs@ issue 24923) being updated after the
-drop, KWin's focus stealing prevention will refuse to activate the dialog. As
-the XdndDrop message is kind of an user action too, the timestamp should be
-updated.
-
---- src/kernel/qdnd_x11.cpp.sav 2004-01-05 19:18:33.000000000 +0100
-+++ src/kernel/qdnd_x11.cpp 2004-01-08 19:08:52.000000000 +0100
-@@ -81,6 +81,7 @@ extern void qt_leave_modal( QWidget *wid
- extern Window qt_x11_findClientWindow( Window, Atom, bool );
- extern Atom qt_wm_state;
- extern Time qt_x_time;
-+extern Time qt_x_user_time;
-
- // this stuff is copied from qclb_x11.cpp
-
-@@ -834,6 +835,9 @@ void qt_handle_xdnd_drop( QWidget *, con
- // l[0], qt_xdnd_dragsource_xid );
- return;
- }
-+
-+ if( l[2] != 0 )
-+ qt_x_user_time = l[2];
- if ( qt_xdnd_source_object )
- qt_xdnd_source_object->setTarget( qt_xdnd_current_widget );
-
-@@ -1366,9 +1370,9 @@ void QDragManager::drop()
- drop.format = 32;
- drop.message_type = qt_xdnd_drop;
- drop.data.l[0] = object->source()->winId();
-- drop.data.l[1] = 1 << 24; // flags
-- drop.data.l[2] = 0; // ###
-- drop.data.l[3] = qt_x_time;
-+ drop.data.l[1] = 0; // flags
-+ drop.data.l[2] = qt_x_time;
-+ drop.data.l[3] = 0;
- drop.data.l[4] = 0;
-
- QWidget * w = QWidget::find( qt_xdnd_current_proxy_target );
diff --git a/x11-libs/qt/files/qsslsocket-fix.patch b/x11-libs/qt/files/qsslsocket-fix.patch
deleted file mode 100644
index b44b78f2812f..000000000000
--- a/x11-libs/qt/files/qsslsocket-fix.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff src/network/qsslsocket_openssl.cpp src/network/qsslsocket_openssl.cpp
---- src/network/qsslsocket_openssl.cpp
-+++ src/network/qsslsocket_openssl.cpp
-@@ -188,8 +188,8 @@ struct QSslErrorList
- Q_GLOBAL_STATIC(QSslErrorList, _q_sslErrorList)
- static int q_X509Callback(int ok, X509_STORE_CTX *ctx)
- {
-- Q_UNUSED(ok);
-- _q_sslErrorList()->errors << ctx->error;
-+ if (!ok)
-+ _q_sslErrorList()->errors << ctx->error;
- return ctx->error;
- }
-
-@@ -297,6 +297,7 @@ bool QSslSocketBackendPrivate::initSslContext()
-
- // Clear the session.
- q_SSL_clear(ssl);
-+ errorList.clear();
-
- // Initialize memory BIOs for encryption and decryption.
- readBio = q_BIO_new(q_BIO_s_mem());
-@@ -570,7 +571,7 @@ bool QSslSocketBackendPrivate::testConnection()
- _q_sslErrorList()->mutex.lock();
- _q_sslErrorList()->errors.clear();
- int result = (mode == QSslSocket::SslClientMode) ? q_SSL_connect(ssl) : q_SSL_accept(ssl);
-- QList<int> errorList = _q_sslErrorList()->errors;
-+ errorList << _q_sslErrorList()->errors;
- _q_sslErrorList()->mutex.unlock();
-
- // Check if we're encrypted or not.
-diff src/network/qsslsocket_openssl_p.h src/network/qsslsocket_openssl_p.h
-index be57b87..00b9b45 100644
---- src/network/qsslsocket_openssl_p.h
-+++ src/network/qsslsocket_openssl_p.h
-@@ -77,6 +77,7 @@ public:
- SSL_SESSION *session;
- X509_STORE *certificateStore;
- X509_STORE_CTX *certificateStoreCtx;
-+ QList<int> errorList;
-
- // Platform specific functions
- void startClientEncryption();
diff --git a/x11-libs/qt/files/qt-3.3.8-mysql-unload-crash.diff b/x11-libs/qt/files/qt-3.3.8-mysql-unload-crash.diff
deleted file mode 100644
index 5f61edc672bc..000000000000
--- a/x11-libs/qt/files/qt-3.3.8-mysql-unload-crash.diff
+++ /dev/null
@@ -1,47 +0,0 @@
---- src/sql/drivers/mysql/qsql_mysql.cpp
-+++ src/sql/drivers/mysql/qsql_mysql.cpp
-@@ -37,7 +37,6 @@
- #include "qsql_mysql.h"
- #include <private/qsqlextension_p.h>
-
--#include <qapplication.h>
- #include <qdatetime.h>
- #include <qvaluevector.h>
- #include <qsqlrecord.h>
-@@ -341,14 +340,6 @@ int QMYSQLResult::numRowsAffected()
- }
-
- /////////////////////////////////////////////////////////
--static void qServerEnd()
--{
--#ifndef Q_NO_MYSQL_EMBEDDED
--# if MYSQL_VERSION_ID >= 40000
-- mysql_server_end();
--# endif // MYSQL_VERSION_ID
--#endif // Q_NO_MYSQL_EMBEDDED
--}
-
- static void qServerInit()
- {
-@@ -366,9 +357,7 @@ static void qServerInit()
- qWarning( "QMYSQLDriver::qServerInit: unable to start server." );
- # endif
- }
-- qAddPostRoutine(qServerEnd);
- init = TRUE;
--
- # endif // MYSQL_VERSION_ID
- #endif // Q_NO_MYSQL_EMBEDDED
- }
-@@ -411,6 +400,11 @@ QMYSQLDriver::~QMYSQLDriver()
- QSqlOpenExtension *ext = qSqlOpenExtDict()->take( this );
- delete ext;
- }
-+#ifndef Q_NO_MYSQL_EMBEDDED
-+# if MYSQL_VERSION_ID > 40000
-+ mysql_server_end();
-+# endif
-+#endif
- }
-
- bool QMYSQLDriver::hasFeature( DriverFeature f ) const
diff --git a/x11-libs/qt/files/qt-ulibc.patch b/x11-libs/qt/files/qt-ulibc.patch
deleted file mode 100644
index f188778e4bdf..000000000000
--- a/x11-libs/qt/files/qt-ulibc.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- qt-x11-free-3.3.4.orig/src/tools/qlocale.cpp 2005-01-21 17:16:05.000000000 +0000
-+++ qt-x11-free-3.3.4/src/tools/qlocale.cpp 2005-02-18 13:36:59.000000000 +0000
-@@ -55,6 +55,10 @@
- # undef INFINITY
- #endif
-
-+#if defined(Q_OS_LINUX) && defined(__UCLIBC__)
-+# undef Q_OS_LINUX
-+#endif
-+
- #ifdef Q_OS_LINUX
- # include <fenv.h>
- #endif