summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-05-13 17:52:02 +0000
committerAron Griffis <agriffis@gentoo.org>2004-05-13 17:52:02 +0000
commit3957de7f19cff855e63c386d5955d94f79c3b34d (patch)
tree247aceaef3243f727f4de61a7baa6acb7a621dd7 /x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild
parentclean stray digest (Manifest recommit) (diff)
downloadgentoo-2-3957de7f19cff855e63c386d5955d94f79c3b34d.tar.gz
gentoo-2-3957de7f19cff855e63c386d5955d94f79c3b34d.tar.bz2
gentoo-2-3957de7f19cff855e63c386d5955d94f79c3b34d.zip
Restore rep-gtk-0.15 which is needed by sawfish-1.0.1 which is needed by gnome-1.4
Diffstat (limited to 'x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild')
-rw-r--r--x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild b/x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild
new file mode 100644
index 000000000000..72ec51bdbe2b
--- /dev/null
+++ b/x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild,v 1.17 2004/05/13 17:52:02 agriffis Exp $
+
+IUSE="gnome"
+
+DESCRIPTION="GTK/GDK bindings for the librep Lisp environment"
+SRC_URI="mirror://sourceforge/rep-gtk/${P}.tar.gz"
+HOMEPAGE="http://rep-gtk.sourceforge.net/"
+
+SLOT="1.2"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc -ppc alpha"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=dev-libs/librep-0.13.4
+ gnome? ( <gnome-base/libglade-2
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ gnome? ( <gnome-base/libglade-2
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+src_compile() {
+ local myconf=""
+
+ if [ -n "`use gnome`" ]
+ then
+ myconf="--with-gnome --with-libglade"
+ else
+ myconf="--without-gnome \
+ --without-libglade \
+ --without-gdk-pixbuf \
+ --without-gnome-canvas-pixbuf"
+ fi
+
+ econf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS BUGS COPYING ChangeLog README* TODO
+ docinto examples
+ dodoc examples/*
+}