summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-02-14 23:57:45 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-02-14 23:57:45 +0000
commited5e162708c52bb952aa12844f5ab4850fee7182 (patch)
treed87a97f217729a5d2a50b8f348be0ecc701eab2e /x11-libs/wxGTK
parentremove old gimp ebuilds (diff)
downloadgentoo-2-ed5e162708c52bb952aa12844f5ab4850fee7182.tar.gz
gentoo-2-ed5e162708c52bb952aa12844f5ab4850fee7182.tar.bz2
gentoo-2-ed5e162708c52bb952aa12844f5ab4850fee7182.zip
Build fix for >=libpng-1.4.0 (bug #305119 by Poly-C). Also ensure system
libs are always being used. (Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/wxGTK')
-rw-r--r--x11-libs/wxGTK/ChangeLog7
-rw-r--r--x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild15
-rw-r--r--x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild5
3 files changed, 19 insertions, 8 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index ccd1d8ff7b64..e1d4ccc09a53 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.243 2010/02/02 19:10:58 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.244 2010/02/14 23:57:45 dirtyepic Exp $
+
+ 14 Feb 2010; Ryan Hill <dirtyepic@gentoo.org> wxGTK-2.6.4.0-r6.ebuild,
+ wxGTK-2.8.10.1-r5.ebuild:
+ Build fix for >=libpng-1.4.0 (bug #305119 by Poly-C). Also ensure system
+ libs are always being used.
*wxGTK-2.8.10.1-r5 (02 Feb 2010)
diff --git a/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild b/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild
index 75cd4e24820d..cd2e9bf056d0 100644
--- a/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild,v 1.1 2009/08/06 04:56:07 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild,v 1.2 2010/02/14 23:57:45 dirtyepic Exp $
inherit eutils versionator flag-o-matic
@@ -77,6 +77,9 @@ src_unpack() {
# wxBase has an automagic sdl dependency. short circuit it here.
# http://bugs.gentoo.org/show_bug.cgi?id=91574
use sdl || sed -i -e 's:$wxUSE_LIBSDL" != "no":$wxUSE_LIBSDL" = "yes":' configure
+
+ # Fix for >=libpng-1.4.0. Bug #305119.
+ sed -i -e 's:png_check_sig:png_sig_cmp:g' "${S}"/configure
}
src_compile() {
@@ -98,10 +101,10 @@ src_compile() {
use X && \
myconf="${myconf}
--enable-gui
- --with-libpng
- --with-libxpm
- --with-libjpeg
- --with-libtiff
+ --with-libpng=sys
+ --with-libxpm=sys
+ --with-libjpeg=sys
+ --with-libtiff=sys
$(use_enable opengl)
$(use_with opengl)
$(use_with gnome gnomeprint)"
diff --git a/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild b/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild
index bd0f34bb56c7..1d129638f120 100644
--- a/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild,v 1.1 2010/02/02 19:10:58 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild,v 1.2 2010/02/14 23:57:45 dirtyepic Exp $
EAPI="2"
@@ -64,6 +64,9 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-CVE-2009-2369.patch # Bug #277722
epatch "${FILESDIR}"/${P}-gsocket.patch # Bug #278778
epatch "${FILESDIR}"/${P}-wxTimer-unbounded-hook.patch # Bug #301143
+
+ # Fix for >=libpng-1.4.0 Bug #305119.
+ sed -i -e 's:png_check_sig:png_sig_cmp:g' "${S}"/configure{,.in}
}
src_configure() {