summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-08-15 11:08:49 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-08-15 11:08:49 +0000
commit67f90c1d092595f94d12e3e039bfc599ca5e7541 (patch)
tree5943371065913a7f48986db01ef4a6b1abf8d775 /x11-libs/xosd/files
parentversion bump (diff)
downloadgentoo-2-67f90c1d092595f94d12e3e039bfc599ca5e7541.tar.gz
gentoo-2-67f90c1d092595f94d12e3e039bfc599ca5e7541.tar.bz2
gentoo-2-67f90c1d092595f94d12e3e039bfc599ca5e7541.zip
version bump
Diffstat (limited to 'x11-libs/xosd/files')
-rw-r--r--x11-libs/xosd/files/Makefile-gentoo.diff85
-rw-r--r--x11-libs/xosd/files/configure-gentoo.diff150
-rw-r--r--x11-libs/xosd/files/digest-xosd-0.7.01
-rw-r--r--x11-libs/xosd/files/digest-xosd-1.0.21
-rw-r--r--x11-libs/xosd/files/digest-xosd-2.0.01
-rw-r--r--x11-libs/xosd/files/digest-xosd-2.0.11
-rw-r--r--x11-libs/xosd/files/digest-xosd-2.0.1-r11
-rw-r--r--x11-libs/xosd/files/digest-xosd-2.1.31
-rw-r--r--x11-libs/xosd/files/digest-xosd-2.2.21
-rw-r--r--x11-libs/xosd/files/digest-xosd-2.2.41
-rw-r--r--x11-libs/xosd/files/xmms_osd-2.2.4-gentoo.diff20
11 files changed, 21 insertions, 242 deletions
diff --git a/x11-libs/xosd/files/Makefile-gentoo.diff b/x11-libs/xosd/files/Makefile-gentoo.diff
deleted file mode 100644
index a82f7b12b4eb..000000000000
--- a/x11-libs/xosd/files/Makefile-gentoo.diff
+++ /dev/null
@@ -1,85 +0,0 @@
---- Makefile.orig 2002-04-18 14:26:49.000000000 -0600
-+++ Makefile 2002-04-18 14:48:26.000000000 -0600
-@@ -5,35 +5,22 @@
- LIBRARY_VERSION=0
- VERSION=0.7.0
-
--PREFIX=/usr/local
--EXEC_PREFIX=$(PREFIX)
--BINDIR=$(EXEC_PREFIX)/bin
--LIBDIR=$(EXEC_PREFIX)/lib
--MANDIR=$(PREFIX)/man
--INCLUDEDIR=$(PREFIX)/include
--XMMS_PLUGINDIR=$(HOME)/.xmms
--
--CC=gcc
--INSTALL=/usr/bin/install -c
--INSTALL_DATA=$(INSTALL) -m 644
--
--CFLAGS=-O2 -Wall -pipe -I. -DXOSD_VERSION=\"$(VERSION)\" -I/usr/X11R6/include
-+XOSDCFLAGS=$(CFLAGS) -I. -DXOSD_VERSION=\"$(VERSION)\" -I/usr/X11R6/include
- LDFLAGS=-L. -L/usr/X11R6/lib -lX11 -lXext -lpthread -lXt
-
- XOSDLIBS=-lxosd
-
--SOURCES=NEWS AUTHORS ChangeLog README COPYING Makefile testprog.c xosd.c \
-- xosd.h xmms_osd.c osd_cat.c xosd.3 osd_cat.1
-+SOURCES=xosd.c xosd.h osd_cat.c
-
- ARFLAGS=cru
-
--all: testprog libxosd.a libxosd.so libxmms_osd.so osd_cat
-+all: libxosd.a libxosd.so osd_cat
-
- %.o: %.c
-- $(CC) -c $(CFLAGS) $(CPPFLAGS) $< -o $@
-+ $(CC) -c $(XOSDCFLAGS) $(CPPFLAGS) $< -o $@
-
- %.o.pic: %.c
-- $(CC) -c $(CFLAGS) $(CPPFLAGS) $< -o $@ -fPIC
-+ $(CC) -c $(XOSDCFLAGS) $(CPPFLAGS) $< -o $@ -fPIC
-
- libxosd.so: xosd.o.pic
- $(CC) -shared -fPIC -o $@ $+ $(LDFLAGS) \
-@@ -43,40 +30,8 @@
- $(AR) $(ARFLAGS) libxosd.a $+
- ranlib libxosd.a
-
--xmms_osd.o: xmms_osd.c
-- $(CC) -c -o $@ xmms_osd.c `xmms-config --cflags` -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 $(CFLAGS)
--
--libxmms_osd.so: xmms_osd.o
-- $(CC) -shared -o $@ $+ $(LDFLAGS) `gtk-config --libs` $(XOSDLIBS)
--
--testprog: testprog.o libxosd.so
-- $(CC) -o $@ testprog.o $(LDFLAGS) $(XOSDLIBS)
--
- osd_cat: libxosd.so osd_cat.o
- $(CC) -o $@ osd_cat.o $(LDFLAGS) $(XOSDLIBS)
-
--tar: xosd-$(VERSION).tar.gz
--
--xosd-$(VERSION).tar.gz:
-- ln -s . xosd-$(VERSION)
-- tar cfz $@ $(patsubst %, xosd-$(VERSION)/%, $(SOURCES))
-- rm xosd-$(VERSION)
--
--install: all
-- $(INSTALL) libxosd.so $(LIBDIR)/libxosd.so.$(LIBRARY_VERSION)
-- rm -f $(PREFIX)/lib/libxosd.so
-- ln -s $(PREFIX)/lib/libxosd.so.$(LIBRARY_VERSION) $(PREFIX)/lib/libxosd.so
-- mkdir -p $(XMMS_PLUGINDIR)/Plugins/General
-- rm -f $(XMMS_PLUGINDIR)/Plugins/General/libxmms_osd.so
-- cp -a libxmms_osd.so $(XMMS_PLUGINDIR)/Plugins/General
-- $(INSTALL) osd_cat $(BINDIR)
-- mkdir -p $(MANDIR)/man1 $(MANDIR)/man3
-- $(INSTALL_DATA) osd_cat.1 $(MANDIR)/man1/
-- $(INSTALL_DATA) xosd.3 $(MANDIR)/man3/
--
--clean:
-- rm -f *~ *.o *.o.pic xosd testprog libxosd.so libxmms_osd.so libxosd.a osd_cat
-- rm -f xosd-$(VERSION).tar.gz
--
--.PHONY: all tar clean install
-+.PHONY: all
- # vim: noexpandtab
diff --git a/x11-libs/xosd/files/configure-gentoo.diff b/x11-libs/xosd/files/configure-gentoo.diff
deleted file mode 100644
index eacb868364e8..000000000000
--- a/x11-libs/xosd/files/configure-gentoo.diff
+++ /dev/null
@@ -1,150 +0,0 @@
---- /tmp/configure 2003-01-07 14:01:03.000000000 +0100
-+++ configure 2003-01-07 14:08:33.000000000 +0100
-@@ -7021,19 +7021,19 @@
-
- SELECTED_PLUGINS=
-
--# Extract the first word of "xmms-config", so it can be a program name with args.
--set dummy xmms-config; ac_word=$2
-+# Extract the first word of "gdk-pixbuf-config", so it can be a program name with args.
-+set dummy gdk-pixbuf-config; ac_word=$2
- echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
--echo "configure:7028: checking for $ac_word" >&5
--if eval "test \"`echo '$''{'ac_cv_path_xmms_config_script'+set}'`\" = set"; then
-+echo "configure:7083: checking for $ac_word" >&5
-+if eval "test \"`echo '$''{'ac_cv_path_gdk_pixbuf_config_script'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
- else
-- case "$xmms_config_script" in
-+ case "$gdk_pixbuf_config_script" in
- /*)
-- ac_cv_path_xmms_config_script="$xmms_config_script" # Let the user override the test with a path.
-+ ac_cv_path_gdk_pixbuf_config_script="$gdk_pixbuf_config_script" # Let the user override the test with a path.
- ;;
- ?:/*)
-- ac_cv_path_xmms_config_script="$xmms_config_script" # Let the user override the test with a dos path.
-+ ac_cv_path_gdk_pixbuf_config_script="$gdk_pixbuf_config_script" # Let the user override the test with a dos path.
- ;;
- *)
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
-@@ -7041,54 +7041,37 @@
- for ac_dir in $ac_dummy; do
- test -z "$ac_dir" && ac_dir=.
- if test -f $ac_dir/$ac_word; then
-- ac_cv_path_xmms_config_script="$ac_dir/$ac_word"
-+ ac_cv_path_gdk_pixbuf_config_script="$ac_dir/$ac_word"
- break
- fi
- done
- IFS="$ac_save_ifs"
-- test -z "$ac_cv_path_xmms_config_script" && ac_cv_path_xmms_config_script=""none""
-+ test -z "$ac_cv_path_gdk_pixbuf_config_script" && ac_cv_path_gdk_pixbuf_config_script=""none""
- ;;
- esac
- fi
--xmms_config_script="$ac_cv_path_xmms_config_script"
--if test -n "$xmms_config_script"; then
-- echo "$ac_t""$xmms_config_script" 1>&6
-+gdk_pixbuf_config_script="$ac_cv_path_gdk_pixbuf_config_script"
-+if test -n "$gdk_pixbuf_config_script"; then
-+ echo "$ac_t""$gdk_pixbuf_config_script" 1>&6
- else
- echo "$ac_t""no" 1>&6
- fi
-
--if test "x$xmms_config_script" = "xnone" ; then
-- echo "*** xmms-config script not found. xmms plugin will not be built"
--else
-- XMMS_CFLAGS=`$xmms_config_script --cflags`
-- XMMS_LIBS=`$xmms_config_script --libs`
-- echo $ac_n "checking for xmms plugin directory""... $ac_c" 1>&6
--echo "configure:7067: checking for xmms plugin directory" >&5
-- if test "x$XMMS_PLUGIN_DIR" = "x" ; then
-- XMMS_PLUGIN_DIR=`$xmms_config_script --general-plugin-dir`
-- fi
-- echo "$ac_t""$XMMS_PLUGIN_DIR" 1>&6
--
--
--
-- SELECTED_PLUGINS="$SELECTED_PLUGINS xmms_plugin"
--fi
-
-
--
--# Extract the first word of "gdk-pixbuf-config", so it can be a program name with args.
--set dummy gdk-pixbuf-config; ac_word=$2
-+# Extract the first word of "xmms-config", so it can be a program name with args.
-+set dummy xmms-config; ac_word=$2
- echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
--echo "configure:7083: checking for $ac_word" >&5
--if eval "test \"`echo '$''{'ac_cv_path_gdk_pixbuf_config_script'+set}'`\" = set"; then
-+echo "configure:7028: checking for $ac_word" >&5
-+if eval "test \"`echo '$''{'ac_cv_path_xmms_config_script'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
- else
-- case "$gdk_pixbuf_config_script" in
-+ case "$xmms_config_script" in
- /*)
-- ac_cv_path_gdk_pixbuf_config_script="$gdk_pixbuf_config_script" # Let the user override the test with a path.
-+ ac_cv_path_xmms_config_script="$xmms_config_script" # Let the user override the test with a path.
- ;;
- ?:/*)
-- ac_cv_path_gdk_pixbuf_config_script="$gdk_pixbuf_config_script" # Let the user override the test with a dos path.
-+ ac_cv_path_xmms_config_script="$xmms_config_script" # Let the user override the test with a dos path.
- ;;
- *)
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
-@@ -7096,24 +7079,46 @@
- for ac_dir in $ac_dummy; do
- test -z "$ac_dir" && ac_dir=.
- if test -f $ac_dir/$ac_word; then
-- ac_cv_path_gdk_pixbuf_config_script="$ac_dir/$ac_word"
-+ ac_cv_path_xmms_config_script="$ac_dir/$ac_word"
- break
- fi
- done
- IFS="$ac_save_ifs"
-- test -z "$ac_cv_path_gdk_pixbuf_config_script" && ac_cv_path_gdk_pixbuf_config_script=""none""
-+ test -z "$ac_cv_path_xmms_config_script" && ac_cv_path_xmms_config_script=""none""
- ;;
- esac
- fi
--gdk_pixbuf_config_script="$ac_cv_path_gdk_pixbuf_config_script"
--if test -n "$gdk_pixbuf_config_script"; then
-- echo "$ac_t""$gdk_pixbuf_config_script" 1>&6
-+xmms_config_script="$ac_cv_path_xmms_config_script"
-+if test -n "$xmms_config_script"; then
-+ echo "$ac_t""$xmms_config_script" 1>&6
- else
- echo "$ac_t""no" 1>&6
- fi
-
--GDK_PIXBUF_CFLAGS=`$gdk_pixbuf_config_script --cflags`
--GDK_PIXBUF_LIBS=`$gdk_pixbuf_config_script --libs`
-+if test "x$xmms_config_script" = "xnone" || test "x$gdk_pixbuf_config_script" = "xnone" ; then
-+ echo "*** xmms-config script not found. xmms plugin will not be built"
-+else
-+ XMMS_CFLAGS=`$xmms_config_script --cflags`
-+ XMMS_LIBS=`$xmms_config_script --libs`
-+
-+ GDK_PIXBUF_CFLAGS=`$gdk_pixbuf_config_script --cflags`
-+ GDK_PIXBUF_LIBS=`$gdk_pixbuf_config_script --libs`
-+
-+ echo $ac_n "checking for xmms plugin directory""... $ac_c" 1>&6
-+ echo "configure:7067: checking for xmms plugin directory" >&5
-+ if test "x$XMMS_PLUGIN_DIR" = "x" ; then
-+ XMMS_PLUGIN_DIR=`$xmms_config_script --general-plugin-dir`
-+ fi
-+ echo "$ac_t""$XMMS_PLUGIN_DIR" 1>&6
-+
-+
-+
-+ SELECTED_PLUGINS="$SELECTED_PLUGINS xmms_plugin"
-+fi
-+
-+
-+
-+
-
-
-
diff --git a/x11-libs/xosd/files/digest-xosd-0.7.0 b/x11-libs/xosd/files/digest-xosd-0.7.0
deleted file mode 100644
index 75025ef747d8..000000000000
--- a/x11-libs/xosd/files/digest-xosd-0.7.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ff80b31ea3ee52e33855b9723642b8a6 xosd-0.7.0.tar.gz 19593
diff --git a/x11-libs/xosd/files/digest-xosd-1.0.2 b/x11-libs/xosd/files/digest-xosd-1.0.2
deleted file mode 100644
index 6fc3d51ae818..000000000000
--- a/x11-libs/xosd/files/digest-xosd-1.0.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5d515feb604a279213171c08ce952167 xosd-1.0.2.tar.gz 221836
diff --git a/x11-libs/xosd/files/digest-xosd-2.0.0 b/x11-libs/xosd/files/digest-xosd-2.0.0
deleted file mode 100644
index 2b28c7bcf899..000000000000
--- a/x11-libs/xosd/files/digest-xosd-2.0.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 bd16c38ab6fe80cde6fbf21fc8d9f00c xosd-2.0.0.tar.gz 228528
diff --git a/x11-libs/xosd/files/digest-xosd-2.0.1 b/x11-libs/xosd/files/digest-xosd-2.0.1
deleted file mode 100644
index 2bf7c451beed..000000000000
--- a/x11-libs/xosd/files/digest-xosd-2.0.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5dd27d1753f639c44c87df0f0de0eae5 xosd-2.0.1.tar.gz 242579
diff --git a/x11-libs/xosd/files/digest-xosd-2.0.1-r1 b/x11-libs/xosd/files/digest-xosd-2.0.1-r1
deleted file mode 100644
index 2bf7c451beed..000000000000
--- a/x11-libs/xosd/files/digest-xosd-2.0.1-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5dd27d1753f639c44c87df0f0de0eae5 xosd-2.0.1.tar.gz 242579
diff --git a/x11-libs/xosd/files/digest-xosd-2.1.3 b/x11-libs/xosd/files/digest-xosd-2.1.3
deleted file mode 100644
index b9b4907fbdda..000000000000
--- a/x11-libs/xosd/files/digest-xosd-2.1.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 400315c785735d19cddaa98c78808448 xosd-2.1.3.tar.gz 290268
diff --git a/x11-libs/xosd/files/digest-xosd-2.2.2 b/x11-libs/xosd/files/digest-xosd-2.2.2
deleted file mode 100644
index b61a1f41bbad..000000000000
--- a/x11-libs/xosd/files/digest-xosd-2.2.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 b385858fb4ddeff0875fa5b4dc372e42 xosd-2.2.2.tar.gz 295184
diff --git a/x11-libs/xosd/files/digest-xosd-2.2.4 b/x11-libs/xosd/files/digest-xosd-2.2.4
new file mode 100644
index 000000000000..18a537058d72
--- /dev/null
+++ b/x11-libs/xosd/files/digest-xosd-2.2.4
@@ -0,0 +1 @@
+MD5 0b5669d2758470cbf717632b5d16dae8 xosd_2.2.4.orig.tar.gz 295886
diff --git a/x11-libs/xosd/files/xmms_osd-2.2.4-gentoo.diff b/x11-libs/xosd/files/xmms_osd-2.2.4-gentoo.diff
new file mode 100644
index 000000000000..9398d2089422
--- /dev/null
+++ b/x11-libs/xosd/files/xmms_osd-2.2.4-gentoo.diff
@@ -0,0 +1,20 @@
+--- src/xmms_plugin/xmms_osd.c-orig 2003-07-08 10:11:20.000000000 +1200
++++ src/xmms_plugin/xmms_osd.c 2003-08-13 16:33:03.000000000 +1200
+@@ -263,6 +263,7 @@
+ {
+ xosd_set_colour (osd, colour);
+ xosd_set_timeout (osd, timeout);
++ xosd_set_pos (osd, pos);
+ xosd_set_vertical_offset (osd, offset);
+ xosd_set_horizontal_offset (osd, h_offset);
+ xosd_set_shadow_offset (osd, shadow_offset);
+--- src/xmms_plugin/xmms_osd.c-orig 2003-07-08 10:11:20.000000000 +1200
++++ src/xmms_plugin/xmms_osd.c 2003-08-13 16:34:35.000000000 +1200
+@@ -267,7 +267,6 @@
+ xosd_set_horizontal_offset (osd, h_offset);
+ xosd_set_shadow_offset (osd, shadow_offset);
+ xosd_set_outline_offset (osd, outline_offset);
+- xosd_set_pos (osd, pos);
+ xosd_set_align (osd, align);
+ if (xosd_set_font (osd, font) == -1)
+ {