summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-02-19 04:37:06 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-02-19 04:37:06 +0000
commit758dcc2dcd501c9364090c33da658711dc76085c (patch)
treeb2f26a887ea07487e0e90fd95221caafa80da781 /x11-libs/xview
parentbeep-media-player is in package.mask, so masking the USE flag as well (diff)
downloadgentoo-2-758dcc2dcd501c9364090c33da658711dc76085c.tar.gz
gentoo-2-758dcc2dcd501c9364090c33da658711dc76085c.tar.bz2
gentoo-2-758dcc2dcd501c9364090c33da658711dc76085c.zip
Fixed conflicting type declarations for lseek in libxview.
(Portage version: 2.0.54)
Diffstat (limited to 'x11-libs/xview')
-rw-r--r--x11-libs/xview/ChangeLog8
-rw-r--r--x11-libs/xview/Manifest3
-rw-r--r--x11-libs/xview/files/digest-xview-3.2-r51
-rw-r--r--x11-libs/xview/files/lseek.diff26
-rw-r--r--x11-libs/xview/xview-3.2-r5.ebuild87
5 files changed, 124 insertions, 1 deletions
diff --git a/x11-libs/xview/ChangeLog b/x11-libs/xview/ChangeLog
index d0679f6f8c05..b93788e9b217 100644
--- a/x11-libs/xview/ChangeLog
+++ b/x11-libs/xview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/xview
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xview/ChangeLog,v 1.18 2006/01/25 22:19:10 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xview/ChangeLog,v 1.19 2006/02/19 04:37:06 ribosome Exp $
+
+*xview-3.2-r5 (19 Feb 2006)
+
+ 19 Feb 2006; Olivier Fisette <ribosome@gentoo.org> +files/lseek.diff,
+ +xview-3.2-r5.ebuild:
+ Fixed conflicting type declarations for lseek in libxview.
25 Jan 2006; Patrick McLean <chutzpah@gentoo.org> xview-3.2-r4.ebuild:
Fix dependencies for modular X.
diff --git a/x11-libs/xview/Manifest b/x11-libs/xview/Manifest
index 2e5394038d69..497ef0e24cbe 100644
--- a/x11-libs/xview/Manifest
+++ b/x11-libs/xview/Manifest
@@ -4,8 +4,11 @@ MD5 6de3c812dee458777db24502d252984f files/digest-xview-3.2 138
MD5 48636f5ace70cc3f5033a87188e4e7bf files/digest-xview-3.2-r1 138
MD5 d7d90bd733aab393a20a5919e05c0b49 files/digest-xview-3.2-r3 70
MD5 d7d90bd733aab393a20a5919e05c0b49 files/digest-xview-3.2-r4 70
+MD5 d7d90bd733aab393a20a5919e05c0b49 files/digest-xview-3.2-r5 70
+MD5 52d63a0f0747efefb09e61ce08f3bc1c files/lseek.diff 897
MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
MD5 1f80b853ffb94e1a3fcad18538a35918 xview-3.2-r1.ebuild 2596
MD5 9a0c239967b3664c61caac1548137243 xview-3.2-r3.ebuild 2669
MD5 bc369c9dbc5c218e8ffab0309fd98b8b xview-3.2-r4.ebuild 3066
+MD5 b483ba08cf360f4d37ea95a0f7b70298 xview-3.2-r5.ebuild 3105
MD5 d6f0240a1b502222522db7d875a66cd8 xview-3.2.ebuild 2280
diff --git a/x11-libs/xview/files/digest-xview-3.2-r5 b/x11-libs/xview/files/digest-xview-3.2-r5
new file mode 100644
index 000000000000..d467cbbf21c7
--- /dev/null
+++ b/x11-libs/xview/files/digest-xview-3.2-r5
@@ -0,0 +1 @@
+MD5 a61e7ce82cac041a2c613041dc003de5 xview-3.2p1.4-18c.tar.gz 3377010
diff --git a/x11-libs/xview/files/lseek.diff b/x11-libs/xview/files/lseek.diff
new file mode 100644
index 000000000000..6a9ea51e6e3e
--- /dev/null
+++ b/x11-libs/xview/files/lseek.diff
@@ -0,0 +1,26 @@
+--- lib/libxview/textsw/es_file.c.old 2006-02-18 23:26:14.000000000 -0500
++++ lib/libxview/textsw/es_file.c 2006-02-18 23:26:37.000000000 -0500
+@@ -119,9 +119,7 @@
+ extern int errno, sys_nerr;
+ extern char *sys_errlist[];
+ #endif
+-#ifndef __CYGWIN__
+-extern long lseek();
+-#endif
++extern off_t lseek();
+
+ static void update_read_buf(); /* update the read buf if overlaps write buf */
+ static Es_status es_file_commit();
+--- lib/libxview/sel/sel_agent.c.old 2006-02-18 23:17:33.000000000 -0500
++++ lib/libxview/sel/sel_agent.c 2006-02-18 23:18:23.000000000 -0500
+@@ -314,9 +314,7 @@
+ struct stat stat_buf;
+ int count, size;
+ char *destp;
+-#ifndef __CYGWIN__
+- extern long lseek();
+-#endif
++ extern off_t lseek();
+ if (fstat(fd, &stat_buf) != 0) {
+ perror(XV_MSG("Agent couldn't reply about a file"));
+ return SELN_FAILED;
diff --git a/x11-libs/xview/xview-3.2-r5.ebuild b/x11-libs/xview/xview-3.2-r5.ebuild
new file mode 100644
index 000000000000..48b5e84af7fb
--- /dev/null
+++ b/x11-libs/xview/xview-3.2-r5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xview/xview-3.2-r5.ebuild,v 1.1 2006/02/19 04:37:06 ribosome Exp $
+
+inherit eutils
+
+DESCRIPTION="The X Window-System-based Visual/Integrated Environment for Workstations"
+HOMEPAGE="http://physionet.caregroup.harvard.edu/physiotools/xview/"
+
+MY_PN="${P}p1.4-18c"
+
+# This is our compound patch derived from debian. We use it because:
+# * xview is a contribution made by Sun Microsystems (?) to the X community, but
+# fixes for it don't appear to be around other than in the other free distributions.
+# * It does little harm, only some defaults are changed which we can redefine anyway
+#SRC_PATCH="${PN}_3.2p1.4-16woody2.diff"
+
+# We use the xview tarball available from the X organization, but xfree86 appears
+# to be up and available more often so we use that (it's their primary mirror).
+SRC_URI="http://physionet.caregroup.harvard.edu/physiotools/xview/${MY_PN}.tar.gz"
+ #mirror://debian/pool/main/x/xview/${SRC_PATCH}.gz"
+S=${WORKDIR}/${MY_PN}
+LICENSE="sun-openlook"
+SLOT="0"
+KEYWORDS="-alpha -amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="|| ( ( x11-libs/libXpm
+ x11-proto/xextproto
+ )
+ virtual/x11
+ )"
+
+DEPEND="${RDEPEND}
+ || ( ( app-text/rman
+ x11-misc/gccmakedep
+ )
+ virtual/x11
+ )"
+
+src_unpack() {
+ unpack $A
+ cd "${S}"
+ epatch "${FILESDIR}"/CAN-2005-0076.patch
+ epatch "${FILESDIR}"/lseek.diff
+ # Do not build xgettext and msgfmt since they are provided by the gettext
+ # package. Using the programs provided by xview breaks many packages
+ # including vim, grep and binutils.
+ sed -e 's/MSG_UTIL = xgettext msgfmt/#MSG_UTIL = xgettext msgfmt/' \
+ -i util/Imakefile || die
+}
+
+src_compile() {
+ # Create the makefile
+ imake -DUseInstalled -I${S}/config -I/usr/X11R6/lib/X11/config \
+ || die "imake failed"
+
+ # This is crazy and I know it, but wait till you read the code in
+ # Build-LinuxXView.bash.
+ OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash libs \
+ || die "building libs failed"
+ OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash clients \
+ || die "building clients failed"
+ OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash contrib \
+ || die "building contrib failed"
+ OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash olvwm \
+ || die "building olvwm failed"
+}
+
+src_install() {
+ DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instlibs \
+ || die "installing libs failed"
+ DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instclients \
+ || die "installing clients failed"
+ DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instcontrib \
+ || die "installing contrib failed"
+ DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instolvwm \
+ || die "installing olvwm failed"
+ cd ${D}/usr
+ ln -s X11R6 openwin
+
+ # The rest of the docs is already installed
+ cd ${S}/doc
+ dodoc README xview-info olgx_api.txt olgx_api.ps sel_api.txt \
+ dnd_api.txt whats_new.ps bugform config/usenixws/paper.ps
+ rm -rf ${D}/usr/X11R6/share/doc/xview && rm -rf ${D}/usr/X11R6/share/doc
+}