summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-12-03 23:41:48 +0000
committerJeroen Roovers <jer@gentoo.org>2014-12-03 23:41:48 +0000
commit0faee254bfdf5c82a36aac9fe68ee9df48429231 (patch)
tree1b56f83ece5381c2f4c5c7f9a00d42d7e70ab9b1 /x11-libs
parentFix perl installation directory, bug 451190 (diff)
downloadgentoo-2-0faee254bfdf5c82a36aac9fe68ee9df48429231.tar.gz
gentoo-2-0faee254bfdf5c82a36aac9fe68ee9df48429231.tar.bz2
gentoo-2-0faee254bfdf5c82a36aac9fe68ee9df48429231.zip
Export Fl_XFont_On_Demand() (bug #529346).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/fltk/ChangeLog8
-rw-r--r--x11-libs/fltk/files/fltk-1.3.3-visibility.patch11
-rw-r--r--x11-libs/fltk/fltk-1.3.3-r2.ebuild (renamed from x11-libs/fltk/fltk-1.3.3-r1.ebuild)2
3 files changed, 19 insertions, 2 deletions
diff --git a/x11-libs/fltk/ChangeLog b/x11-libs/fltk/ChangeLog
index d959cdcb2b3f..e54f4f3629fd 100644
--- a/x11-libs/fltk/ChangeLog
+++ b/x11-libs/fltk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/fltk
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.243 2014/11/19 14:06:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.244 2014/12/03 23:41:48 jer Exp $
+
+*fltk-1.3.3-r2 (03 Dec 2014)
+
+ 03 Dec 2014; Jeroen Roovers <jer@gentoo.org> -fltk-1.3.3-r1.ebuild,
+ +fltk-1.3.3-r2.ebuild, files/fltk-1.3.3-visibility.patch:
+ Export Fl_XFont_On_Demand() (bug #529346).
*fltk-1.3.3-r1 (19 Nov 2014)
diff --git a/x11-libs/fltk/files/fltk-1.3.3-visibility.patch b/x11-libs/fltk/files/fltk-1.3.3-visibility.patch
index 99831e8d6815..491e0a18876d 100644
--- a/x11-libs/fltk/files/fltk-1.3.3-visibility.patch
+++ b/x11-libs/fltk/files/fltk-1.3.3-visibility.patch
@@ -9,3 +9,14 @@
/**
Sets the widget that will receive FL_KEYBOARD events.
+--- a/FL/x.H
++++ b/FL/x.H
+@@ -114,7 +114,7 @@ FL_EXPORT Fl_Region XRectangleRegion(int x, int y, int w, int h); // in fl_rect.
+ // With Xlib / X11 fonts, fl_xfont will return the current selected font.
+ // With XFT / X11 fonts, fl_xfont will attempt to return the bitmap "core" font most
+ // similar to (usually the same as) the current XFT font.
+-class Fl_XFont_On_Demand
++class FL_EXPORT Fl_XFont_On_Demand
+ {
+ public:
+ Fl_XFont_On_Demand(XFontStruct* p = NULL) : ptr(p) { }
diff --git a/x11-libs/fltk/fltk-1.3.3-r1.ebuild b/x11-libs/fltk/fltk-1.3.3-r2.ebuild
index 888218b09254..3f0b32e49b3e 100644
--- a/x11-libs/fltk/fltk-1.3.3-r1.ebuild
+++ b/x11-libs/fltk/fltk-1.3.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.3.3-r1.ebuild,v 1.1 2014/11/19 14:06:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.3.3-r2.ebuild,v 1.1 2014/12/03 23:41:48 jer Exp $
EAPI=5