summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2012-01-29 17:01:27 +0000
committerAlex Alexander <wired@gentoo.org>2012-01-29 17:01:27 +0000
commit17bfaad07e7f9120139662cedf4cb654f4eb4b97 (patch)
treef91405757a91acb429c7580ec66b4602d4d804a7 /x11-libs
parentarm stable, bug #395735 (diff)
downloadgentoo-2-17bfaad07e7f9120139662cedf4cb654f4eb4b97.tar.gz
gentoo-2-17bfaad07e7f9120139662cedf4cb654f4eb4b97.tar.bz2
gentoo-2-17bfaad07e7f9120139662cedf4cb654f4eb4b97.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-declarative/ChangeLog10
-rw-r--r--x11-libs/qt-declarative/metadata.xml22
-rw-r--r--x11-libs/qt-declarative/qt-declarative-4.8.0-r1.ebuild65
3 files changed, 85 insertions, 12 deletions
diff --git a/x11-libs/qt-declarative/ChangeLog b/x11-libs/qt-declarative/ChangeLog
index 351be72181ab..4aabfbd1ca33 100644
--- a/x11-libs/qt-declarative/ChangeLog
+++ b/x11-libs/qt-declarative/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-declarative
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/ChangeLog,v 1.33 2011/12/27 21:38:01 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/ChangeLog,v 1.34 2012/01/29 17:01:27 wired Exp $
+
+*qt-declarative-4.8.0-r1 (29 Jan 2012)
+
+ 29 Jan 2012; Alex Alexander <wired@gentoo.org>
+ +qt-declarative-4.8.0-r1.ebuild, metadata.xml:
+ version bump
27 Dec 2011; Markus Meier <maekke@gentoo.org> qt-declarative-4.7.4.ebuild:
x86 stable, bug #390963
diff --git a/x11-libs/qt-declarative/metadata.xml b/x11-libs/qt-declarative/metadata.xml
index 86e2b764d474..feb7d87cf3e3 100644
--- a/x11-libs/qt-declarative/metadata.xml
+++ b/x11-libs/qt-declarative/metadata.xml
@@ -1,16 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>qt</herd>
-<use>
- <flag name="private-headers">Install Qt declarative private headers required
- by Qt-creator QmlDesigner and QmlInspector plugins"</flag>
- <flag name='qt3support'>Enable the Qt3Support libraries for Qt4. Note that
- this does not mean you can compile pure Qt3 programs with Qt4.</flag>
- <flag name='exceptions'>Add support for exceptions - like catching them
- inside the event loop (recommended by Nokia)</flag>
- <flag name='webkit'>Build the WebView QML element</flag>
-</use>
+ <herd>qt</herd>
+ <use>
+ <flag name="private-headers">Install Qt declarative private headers required
+ by Qt-creator QmlDesigner and QmlInspector plugins"</flag>
+ <flag name='qt3support'>Enable the Qt3Support libraries for Qt4. Note that
+ this does not mean you can compile pure Qt3 programs with Qt4.</flag>
+ <flag name='exceptions'>Add support for exceptions - like catching them
+ inside the event loop (recommended by Nokia)</flag>
+ <flag name='webkit'>Build the WebView QML element</flag>
+ <flag name='c++0x'>Build Qt using the C++11 standard</flag>
+ <flag name='qpa'>Build a window system agnostic implementation of Qt</flag>
+ </use>
<longdescription lang="en">
</longdescription>
</pkgmetadata>
diff --git a/x11-libs/qt-declarative/qt-declarative-4.8.0-r1.ebuild b/x11-libs/qt-declarative/qt-declarative-4.8.0-r1.ebuild
new file mode 100644
index 000000000000..9d963ab30bad
--- /dev/null
+++ b/x11-libs/qt-declarative/qt-declarative-4.8.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/qt-declarative-4.8.0-r1.ebuild,v 1.1 2012/01/29 17:01:27 wired Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The Declarative module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="+accessibility qt3support webkit"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,c++0x=,qpa=,debug=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[accessibility=,aqua=,c++0x=,qpa=,debug=,qt3support=]
+ ~x11-libs/qt-opengl-${PV}[aqua=,c++0x=,qpa=,debug=,qt3support=]
+ ~x11-libs/qt-script-${PV}[aqua=,c++0x=,qpa=,debug=]
+ ~x11-libs/qt-sql-${PV}[aqua=,c++0x=,qpa=,debug=,qt3support=]
+ ~x11-libs/qt-svg-${PV}[accessibility=,aqua=,c++0x=,qpa=,debug=]
+ ~x11-libs/qt-xmlpatterns-${PV}[aqua=,c++0x=,qpa=,debug=]
+ qt3support? ( ~x11-libs/qt-qt3support-${PV}[accessibility=,aqua=,c++0x=,qpa=,debug=] )
+ webkit? ( ~x11-libs/qt-webkit-${PV}[aqua=,c++0x=,qpa=,debug=] )
+ "
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QCONFIG_ADD="declarative"
+
+ QT4_TARGET_DIRECTORIES="
+ src/declarative
+ src/imports
+ tools/designer/src/plugins/qdeclarativeview
+ tools/qml
+ tools/qmlplugindump"
+
+ if use webkit; then
+ QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ src/3rdparty/webkit/Source/WebKit/qt/declarative"
+ fi
+
+ QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/
+ translations/"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -declarative -no-gtkstyle
+ $(qt_use accessibility) $(qt_use qt3support) $(qt_use webkit)"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+ if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]] ; then
+ insinto "${QTLIBDIR#${EPREFIX}}"/QtDeclarative.framework/Headers/private
+ # ran for the 2nd time, need it for the updated headers
+ fix_includes
+ else
+ insinto "${QTHEADERDIR#${EPREFIX}}"/QtDeclarative/private
+ fi
+ find "${S}"/src/declarative/ -type f -name "*_p.h" -exec doins {} \;
+}