summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-02-08 00:11:40 +0000
committerMarinus Schraal <foser@gentoo.org>2003-02-08 00:11:40 +0000
commit2a3754e2711171698632e90c2ccb5b659ec1859d (patch)
tree11f8cb4427ea6ffc97e54af5b9fbd35683bf045a /x11-libs
parentdrop it for now. (diff)
downloadgentoo-2-2a3754e2711171698632e90c2ccb5b659ec1859d.tar.gz
gentoo-2-2a3754e2711171698632e90c2ccb5b659ec1859d.tar.bz2
gentoo-2-2a3754e2711171698632e90c2ccb5b659ec1859d.zip
added little enhancing patch
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog8
-rw-r--r--x11-libs/gtk+/files/gtk+-2.2.1-disable_icons_smooth_alpha.patch51
-rw-r--r--x11-libs/gtk+/gtk+-2.2.1.ebuild7
3 files changed, 59 insertions, 7 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index cf9db08bc4e6..7cc002b3e348 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,18 +1,18 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.49 2003/02/06 02:18:25 nall Exp $
-
-
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.50 2003/02/08 00:11:40 foser Exp $
*gtk+-2.2.1 (04 Feb 2003)
+ 07 Feb 2003; foser <foser@gentoo.org> gtk+-2.2.1.ebuild :
+ Added alpha blended disabled icons patch
+
05 Feb 2003; Jon Nall <nall@gentoo.org> gtk+--2.2.1.ebuild :
added patch to fix endian problem for 15/24 bit displays
04 Feb 2003; Spider <spider@gentoo.org> gtk+-2.2.1.ebuild :
bumped version
-
16 Jan 2003; foser <foser@gentoo.org> gtk+-2.2.0.ebuild :
Added some info about rebuilding gtk theme engines after an emerge
diff --git a/x11-libs/gtk+/files/gtk+-2.2.1-disable_icons_smooth_alpha.patch b/x11-libs/gtk+/files/gtk+-2.2.1-disable_icons_smooth_alpha.patch
new file mode 100644
index 000000000000..063f594e71ba
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-2.2.1-disable_icons_smooth_alpha.patch
@@ -0,0 +1,51 @@
+diff -ru gtk+-2.2.1/gtk/gtkstyle.c gtk+-2.2.1.patch/gtk/gtkstyle.c
+--- gtk+-2.2.1/gtk/gtkstyle.c 2003-01-31 05:42:34.000000000 +0100
++++ gtk+-2.2.1.patch/gtk/gtkstyle.c 2003-02-07 19:16:04.000000000 +0100
+@@ -1988,6 +1988,36 @@
+ }
+ }
+
++static void
++set_pixbuf_alpha (GdkPixbuf *src)
++{
++ int width, wb;
++ int height;
++ int rowstride;
++ gboolean has_alpha;
++ guchar *pixels, *p;
++ int i, j;
++
++ width = gdk_pixbuf_get_width (src);
++ height = gdk_pixbuf_get_height (src);
++ rowstride = gdk_pixbuf_get_rowstride (src);
++ has_alpha = gdk_pixbuf_get_has_alpha (src);
++
++ if (has_alpha == FALSE)
++ return;
++
++ pixels = gdk_pixbuf_get_pixels (src);
++
++ wb = width << 2;
++ for (i = 0; i < height; i ++)
++ {
++ p = pixels + (i * rowstride);
++
++ for (j = 0; j < wb; j += 4)
++ p[j + 3] = p[j + 3] >> 1;
++ }
++}
++
+ static GdkPixbuf *
+ gtk_default_render_icon (GtkStyle *style,
+ const GtkIconSource *source,
+@@ -2054,8 +2084,8 @@
+ stated = gdk_pixbuf_copy (scaled);
+
+ gdk_pixbuf_saturate_and_pixelate (scaled, stated,
+- 0.8, TRUE);
+-
++ 0.0, FALSE);
++ set_pixbuf_alpha (stated);
+ g_object_unref (scaled);
+ }
+ else if (state == GTK_STATE_PRELIGHT)
diff --git a/x11-libs/gtk+/gtk+-2.2.1.ebuild b/x11-libs/gtk+/gtk+-2.2.1.ebuild
index d55987934f89..eb9967b2454a 100644
--- a/x11-libs/gtk+/gtk+-2.2.1.ebuild
+++ b/x11-libs/gtk+/gtk+-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.2.1.ebuild,v 1.2 2003/02/06 02:18:25 nall Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.2.1.ebuild,v 1.3 2003/02/08 00:11:40 foser Exp $
inherit eutils libtool flag-o-matic
@@ -25,7 +25,6 @@ RDEPEND="virtual/x11
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0
doc? ( >=dev-util/gtk-doc-0.9 )"
-# app-text/sgmltools-lite )"
src_unpack() {
unpack ${A}
@@ -35,8 +34,10 @@ src_unpack() {
cd ${S}; epatch ${FILESDIR}/gtk+-2.0.6-exportsymbols.patch
# should speed up metacity
cd ${S}; epatch ${FILESDIR}/gtk+-wm.patch
+ # beautifying patch for disabled icons
+ epatch ${FILESDIR}/${P}-disable_icons_smooth_alpha.patch
- if [ "${ARCH}" == "ppc" ]
+ if [ "${ARCH}" == "ppc" ]
then
einfo "Fixing endianness issue in gdkpixbuf for 24-bit and 15-bit displays"
cd ${S}; epatch ${FILESDIR}/gtk+-2.2.1-gdkpixbuf-bigendian.patch