summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-02-01 15:24:54 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-02-01 15:24:54 +0000
commit45e0a570375b844bc89209fb565a57fa448114a4 (patch)
treeb0c1b36394762dba7f3905bc128dafc39f707482 /x11-libs
parentrevbump ebuilds to support multilib-build, changes reviewed by aballier (diff)
downloadgentoo-2-45e0a570375b844bc89209fb565a57fa448114a4.tar.gz
gentoo-2-45e0a570375b844bc89209fb565a57fa448114a4.tar.bz2
gentoo-2-45e0a570375b844bc89209fb565a57fa448114a4.zip
revbump ebuilds to support multilib-build, changes reviewed by aballier
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xvba-video/ChangeLog11
-rw-r--r--x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch11
-rw-r--r--x11-libs/xvba-video/xvba-video-0.8.0-r2.ebuild51
-rw-r--r--x11-libs/xvba-video/xvba-video-9999.ebuild39
4 files changed, 87 insertions, 25 deletions
diff --git a/x11-libs/xvba-video/ChangeLog b/x11-libs/xvba-video/ChangeLog
index b02335cdc8cd..98481dd47ee4 100644
--- a/x11-libs/xvba-video/ChangeLog
+++ b/x11-libs/xvba-video/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/xvba-video
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xvba-video/ChangeLog,v 1.15 2013/09/05 19:44:48 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xvba-video/ChangeLog,v 1.16 2014/02/01 15:24:53 axs Exp $
+
+*xvba-video-0.8.0-r2 (01 Feb 2014)
+
+ 01 Feb 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ +files/xvba-video-fix-out-of-source-builds.patch, +xvba-video-0.8.0-r2.ebuild,
+ xvba-video-9999.ebuild:
+ revbump ebuilds to support multilib-build, changes reviewed by aballier
05 Sep 2013; Michał Górny <mgorny@gentoo.org> xvba-video-0.8.0-r1.ebuild,
xvba-video-9999.ebuild:
diff --git a/x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch b/x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch
new file mode 100644
index 000000000000..23de8559a07a
--- /dev/null
+++ b/x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch
@@ -0,0 +1,11 @@
+--- src/shaders/Makefile.am 2012-11-23 08:29:10.000000000 -0500
++++ src/shaders/Makefile.am.new 2014-01-30 18:38:27.954753460 -0500
+@@ -25,7 +25,7 @@
+ CLEANFILES += $(shaders_h)
+
+ %.h: %.pso pso2h.py
+- $(PYTHON) pso2h.py -n $*_fp -o $@ $<
++ $(PYTHON) $(top_srcdir)/src/shaders/pso2h.py -n $*_fp -o $@ $<
+ endif
+
+ # Only add those targets if the Cg compiler is available
diff --git a/x11-libs/xvba-video/xvba-video-0.8.0-r2.ebuild b/x11-libs/xvba-video/xvba-video-0.8.0-r2.ebuild
new file mode 100644
index 000000000000..9b2b9a593ee5
--- /dev/null
+++ b/x11-libs/xvba-video/xvba-video-0.8.0-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xvba-video/xvba-video-0.8.0-r2.ebuild,v 1.1 2014/02/01 15:24:53 axs Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/xvba-driver"
+[[ ${PV} = 9999 ]] && inherit git-2
+PYTHON_COMPAT=( python{2_6,2_7} )
+AUTOTOOLS_AUTORECONF="yes"
+inherit eutils autotools-multilib python-any-r1
+
+DESCRIPTION="XVBA Backend for Video Acceleration (VA) API"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+SRC_URI="http://dev.gentooexperimental.org/~scarabeus/xvba-driver-${PV}.tar.bz2"
+# No source release yet, the src_uri is theoretical at best right now
+#[[ ${PV} = 9999 ]] || SRC_URI="http://www.freedesktop.org/software/vaapi/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ MIT"
+SLOT="0"
+# newline is needed for broken ekeyword
+[[ ${PV} = 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl"
+
+RDEPEND="x11-libs/libva[X(+),opengl?,${MULTILIB_USEDEP}]
+ x11-libs/libvdpau[${MULTILIB_USEDEP}]
+ x11-drivers/ati-drivers"
+DEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+DOCS=( NEWS README AUTHORS )
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix-mesa-gl.h.patch
+ "${FILESDIR}"/${PN}-fix-out-of-source-builds.patch
+)
+
+S="${WORKDIR}/xvba-driver-${PV}"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable opengl glx)
+ )
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/xvba-video/xvba-video-9999.ebuild b/x11-libs/xvba-video/xvba-video-9999.ebuild
index a79c2eaaa45d..9ea9417d11eb 100644
--- a/x11-libs/xvba-video/xvba-video-9999.ebuild
+++ b/x11-libs/xvba-video/xvba-video-9999.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xvba-video/xvba-video-9999.ebuild,v 1.7 2013/09/05 19:44:48 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xvba-video/xvba-video-9999.ebuild,v 1.8 2014/02/01 15:24:53 axs Exp $
EAPI=5
EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/xvba-driver"
[[ ${PV} = 9999 ]] && inherit git-2
PYTHON_COMPAT=( python{2_6,2_7} )
-inherit eutils autotools python-any-r1
+AUTOTOOLS_AUTORECONF="yes"
+inherit eutils autotools-multilib python-any-r1
DESCRIPTION="XVBA Backend for Video Acceleration (VA) API"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
@@ -21,35 +22,27 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug opengl"
-RDEPEND="
- x11-libs/libva[X(+),opengl?]
- x11-libs/libvdpau
- x11-drivers/ati-drivers
-"
+RDEPEND="x11-libs/libva[X(+),opengl?,${MULTILIB_USEDEP}]
+ x11-libs/libvdpau[${MULTILIB_USEDEP}]
+ x11-drivers/ati-drivers"
DEPEND="${DEPEND}
${PYTHON_DEPS}
virtual/pkgconfig"
DOCS=( NEWS README AUTHORS )
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix-mesa-gl.h.patch
+ "${FILESDIR}"/${PN}-fix-out-of-source-builds.patch
+)
pkg_setup() {
python-any-r1_pkg_setup
}
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-fix-mesa-gl.h.patch
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable debug) \
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
$(use_enable opengl glx)
-}
-
-src_install() {
- default
- prune_libtool_files --all
+ )
+ autotools-utils_src_configure
}