summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-02 10:51:50 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-02 10:51:50 +0000
commit575dacb629bf7bc68138a79f6c806b47ea560bb1 (patch)
tree2b12fd79e242833eb05c7b66039791062fa265d6 /x11-libs
parentStable for amd64, wrt bug #418559 (diff)
downloadgentoo-2-575dacb629bf7bc68138a79f6c806b47ea560bb1.tar.gz
gentoo-2-575dacb629bf7bc68138a79f6c806b47ea560bb1.tar.bz2
gentoo-2-575dacb629bf7bc68138a79f6c806b47ea560bb1.zip
Version bump.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xcb-util/ChangeLog8
-rw-r--r--x11-libs/xcb-util/xcb-util-0.3.9.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-libs/xcb-util/ChangeLog b/x11-libs/xcb-util/ChangeLog
index 3ee023a3fa56..14addae09db0 100644
--- a/x11-libs/xcb-util/ChangeLog
+++ b/x11-libs/xcb-util/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/xcb-util
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util/ChangeLog,v 1.60 2012/05/05 03:52:23 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util/ChangeLog,v 1.61 2012/06/02 10:51:50 chithanh Exp $
+
+*xcb-util-0.3.9 (02 Jun 2012)
+
+ 02 Jun 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xcb-util-0.3.9.ebuild:
+ Version bump.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> xcb-util-0.3.6.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/x11-libs/xcb-util/xcb-util-0.3.9.ebuild b/x11-libs/xcb-util/xcb-util-0.3.9.ebuild
new file mode 100644
index 000000000000..fad06bf248cf
--- /dev/null
+++ b/x11-libs/xcb-util/xcb-util-0.3.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util/xcb-util-0.3.9.ebuild,v 1.1 2012/06/02 10:51:50 chithanh Exp $
+
+EAPI=4
+
+XORG_MODULE=/
+XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
+XORG_DOC=doc
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util"
+EGIT_HAS_SUBMODULES=yes
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND=">=x11-libs/libxcb-1.7
+ x11-proto/xproto"
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.1
+ test? ( >=dev-libs/check-0.9.4 )"
+
+PDEPEND="
+ >=x11-libs/xcb-util-image-${PV}
+ >=x11-libs/xcb-util-keysyms-${PV}
+ >=x11-libs/xcb-util-renderutil-0.3.8
+ >=x11-libs/xcb-util-wm-${PV}
+"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc doxygen)
+ )
+
+ xorg-2_pkg_setup
+}