summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-03-10 16:05:31 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-03-10 16:05:31 +0000
commit81cdbe719af3c7631c7ecd15f6e3e700e6d0a926 (patch)
tree22f6f3868b25ed9d37a419906a0c8898eb9dffdc /x11-libs
parentFix build failure against forthcoming ghc-7.4 (diff)
downloadgentoo-2-81cdbe719af3c7631c7ecd15f6e3e700e6d0a926.tar.gz
gentoo-2-81cdbe719af3c7631c7ecd15f6e3e700e6d0a926.tar.bz2
gentoo-2-81cdbe719af3c7631c7ecd15f6e3e700e6d0a926.zip
Fix bug #406443. Remove old.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-webkit/ChangeLog6
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.8.0-r1.ebuild6
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.8.0.ebuild59
3 files changed, 10 insertions, 61 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index 30963598aca1..ecd84a0cfb80 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.135 2012/03/08 15:34:40 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.136 2012/03/10 16:05:31 pesa Exp $
+
+ 10 Mar 2012; Davide Pesavento <pesa@gentoo.org> -qt-webkit-4.8.0.ebuild,
+ qt-webkit-4.8.0-r1.ebuild:
+ Fix bug #406443. Remove old.
08 Mar 2012; Davide Pesavento <pesa@gentoo.org> qt-webkit-4.8.0-r1.ebuild:
No need to append -mminimal-toc for ppc64, it's already added by
diff --git a/x11-libs/qt-webkit/qt-webkit-4.8.0-r1.ebuild b/x11-libs/qt-webkit/qt-webkit-4.8.0-r1.ebuild
index 5ff27a7ecff8..1dda18f9fc4d 100644
--- a/x11-libs/qt-webkit/qt-webkit-4.8.0-r1.ebuild
+++ b/x11-libs/qt-webkit/qt-webkit-4.8.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.8.0-r1.ebuild,v 1.4 2012/03/08 15:34:40 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.8.0-r1.ebuild,v 1.5 2012/03/10 16:05:31 pesa Exp $
EAPI="3"
inherit qt4-build flag-o-matic
@@ -49,6 +49,10 @@ pkg_setup() {
src_prepare() {
use c++0x && append-cxxflags -fpermissive
+ # Fix version number in generated pkgconfig file, bug 406443
+ sed -i -e 's/^isEmpty(QT_BUILD_TREE)://' \
+ src/3rdparty/webkit/Source/WebKit/qt/QtWebKit.pro || die
+
# Always enable icu to avoid build failure, bug 407315
sed -i -e '/CONFIG\s*+=\s*text_breaking_with_icu/ s:^#\s*::' \
src/3rdparty/webkit/Source/JavaScriptCore/JavaScriptCore.pri || die
diff --git a/x11-libs/qt-webkit/qt-webkit-4.8.0.ebuild b/x11-libs/qt-webkit/qt-webkit-4.8.0.ebuild
deleted file mode 100644
index 908ce42a1412..000000000000
--- a/x11-libs/qt-webkit/qt-webkit-4.8.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.8.0.ebuild,v 1.1 2012/01/29 17:10:32 wired Exp $
-
-EAPI="3"
-inherit qt4-build
-
-DESCRIPTION="The Webkit module for the Qt toolkit"
-SLOT="4"
-KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="dbus +jit kde"
-
-DEPEND="
- dev-db/sqlite:3
- ~x11-libs/qt-core-${PV}[aqua=,c++0x=,qpa=,debug=,ssl]
- ~x11-libs/qt-gui-${PV}[aqua=,c++0x=,qpa=,dbus?,debug=]
- ~x11-libs/qt-xmlpatterns-${PV}[aqua=,c++0x=,qpa=,debug=]
- dbus? ( ~x11-libs/qt-dbus-${PV}[aqua=,c++0x=,qpa=,debug=] )
- !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,c++0x=,qpa=,dbus=,debug=]
- media-libs/phonon[aqua=] ) )
- kde? ( || ( media-libs/phonon[aqua=] ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug=] ) )"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-c++0x-fix.patch" )
-
-pkg_setup() {
- QT4_TARGET_DIRECTORIES="
- src/3rdparty/webkit/Source/JavaScriptCore/
- src/3rdparty/webkit/Source/WebCore/
- src/3rdparty/webkit/Source/WebKit/qt/
- tools/designer/src/plugins/qwebview"
-
- QT4_EXTRACT_DIRECTORIES="
- include/
- src/
- tools/"
-
- QCONFIG_ADD="webkit"
- QCONFIG_DEFINE="QT_WEBKIT"
-
- qt4-build_pkg_setup
-}
-
-src_prepare() {
- [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
- use c++0x && append-flags -fpermissive
- sed -i -e "/Werror/d" "${S}/src/3rdparty/webkit/Source/WebKit.pri" || die
- qt4-build_src_prepare
-}
-
-src_configure() {
- # won't build with gcc 4.6 without this for now
- myconf="${myconf}
- -webkit -system-sqlite -no-gtkstyle
- -D GST_DISABLE_DEPRECATED
- $(qt_use jit javascript-jit)
- $(qt_use dbus qdbus)"
- qt4-build_src_configure
-}