summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2001-12-15 14:26:48 +0000
committerGeert Bevin <gbevin@gentoo.org>2001-12-15 14:26:48 +0000
commita0dbf87bf55b864e35e2921d4b66411938ee3090 (patch)
tree580a3877ae8407a2a2327151d53653e191013526 /x11-libs
parentmeep (diff)
downloadgentoo-2-a0dbf87bf55b864e35e2921d4b66411938ee3090.tar.gz
gentoo-2-a0dbf87bf55b864e35e2921d4b66411938ee3090.tar.bz2
gentoo-2-a0dbf87bf55b864e35e2921d4b66411938ee3090.zip
Upgraded to new version and re-enabled xft support since it seems to
work well now.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-x11/files/45qt-x11-3.0.15
-rw-r--r--x11-libs/qt-x11/files/digest-qt-x11-3.0.11
-rw-r--r--x11-libs/qt-x11/qt-x11-3.0.1.ebuild112
3 files changed, 118 insertions, 0 deletions
diff --git a/x11-libs/qt-x11/files/45qt-x11-3.0.1 b/x11-libs/qt-x11/files/45qt-x11-3.0.1
new file mode 100644
index 000000000000..5b783578be63
--- /dev/null
+++ b/x11-libs/qt-x11/files/45qt-x11-3.0.1
@@ -0,0 +1,5 @@
+PATH=/usr/lib/qt-x11-3.0.1/bin
+ROOTPATH=/usr/lib/qt-x11-3.0.1/bin
+LDPATH=/usr/lib/qt-x11-3.0.1/lib
+MANPATH=/usr/lib/qt-x11-3.0.1/share/man
+QMAKESPEC=linux-g++
diff --git a/x11-libs/qt-x11/files/digest-qt-x11-3.0.1 b/x11-libs/qt-x11/files/digest-qt-x11-3.0.1
new file mode 100644
index 000000000000..6b90fbad670c
--- /dev/null
+++ b/x11-libs/qt-x11/files/digest-qt-x11-3.0.1
@@ -0,0 +1 @@
+MD5 cf9afb61d08396c7ca9a290fc7567e92 qt-x11-free-3.0.1.tar.gz 17821696
diff --git a/x11-libs/qt-x11/qt-x11-3.0.1.ebuild b/x11-libs/qt-x11/qt-x11-3.0.1.ebuild
new file mode 100644
index 000000000000..b48cbd7f9432
--- /dev/null
+++ b/x11-libs/qt-x11/qt-x11-3.0.1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-x11/qt-x11-3.0.1.ebuild,v 1.1 2001/12/15 14:26:48 gbevin Exp $
+
+P=qt-x11-${PV}
+S=${WORKDIR}/qt-x11-free-${PV}
+
+DESCRIPTION="QT version ${PV}"
+
+SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-free-${PV}.tar.gz"
+HOMEPAGE="http://www.trolltech.com/"
+
+DEPEND=">=media-libs/libpng-1.0.9
+ >=media-libs/libmng-1.0.0
+ opengl? ( virtual/opengl virtual/glu )
+ nas? ( >=media-libs/nas-1.4.1 )
+ objprelink? ( dev-util/objprelink )
+ virtual/x11"
+
+QTBASE=/usr/lib/qt-x11-${PV}
+export QTDIR=${S}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
+
+ cd ${S}/mkspecs/linux-g++
+# mv qmake.conf tmp
+# echo "
+#QMAKE_CFLAGS = ${CFLAGS}
+#QMAKE_CXXFLAGS = ${CXXFLAGS}
+#" > tmp2
+# cat tmp tmp2 > qmake.conf
+# rm tmp tmp2
+
+ use objprelink && patch -p0 < ${FILESDIR}/qt-x11-3-objprelink.patch
+
+ cd ${S}
+ mv tools/assistant/helpdialogimpl.cpp tools/assistant/helpdialogimpl.cpp_orig
+ sed -e 's:"/doc/html:"/share/doc/html:g' \
+ tools/assistant/helpdialogimpl.cpp_orig > tools/assistant/helpdialogimpl.cpp
+ mv tools/assistant/mainwindow.ui.h tools/assistant/mainwindow.ui.h_orig
+ sed -e 's:"/doc/html:"/share/doc/html:g' \
+ tools/assistant/mainwindow.ui.h_orig > tools/assistant/mainwindow.ui.h
+
+}
+
+src_compile() {
+
+ export LDFLAGS="-ldl"
+
+ use nas && myconf="${myconf} -system-nas-sound"
+ use gif && myconf="${myconf} -qt-gif"
+ [ "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
+
+ ./configure -sm -thread -stl -system-zlib -system-libjpeg ${myconf} \
+ -system-libmng -system-libpng -ldl -lpthread -prefix ${D}/${QTBASE} \
+ -docdir ${D}${QTBASE}/share/doc || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ cd ${S}
+ mkdir -p ${D}${QTBASE}
+ cp -r examples tutorial ${D}${QTBASE}
+
+ for x in bin include include/private; do
+ mkdir -p ${D}${QTBASE}/${x}
+ cd ${S}/${x}
+ cp -f * ${D}${QTBASE}/${x}
+ done
+
+ for x in lib mkspecs/linux-g++; do
+ mkdir -p ${D}${QTBASE}/${x}
+ cd ${S}/${x}
+ cp -af * ${D}${QTBASE}/${x}
+ done
+
+ sed -e "s:${D}::g" \
+ -e "s:qt-x11-free-3.0.1:qt-x11-3.0.1:g" \
+ -e "s:${WORKDIR}:${QTBASE}:" \
+ ${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
+
+ cd ${S}
+ plugins=`find plugins -name "lib*.so" -print`
+ for x in $plugins; do
+ mkdir -p ${D}${QTBASE}/`dirname $x`
+ cp $x ${D}${QTBASE}/$x
+ done
+
+ cd ${S}
+ dodoc ANNOUNCE INSTALL FAQ LICENSE* MANIFEST PLATFORMS PORTING README* changes-*
+ dodir ${QTBASE}/share
+ dodir ${QTBASE}/share/doc
+ cp -af ${S}/doc/man ${D}${QTBASE}/share
+ cp -af ${S}/doc/*.doc ${D}${QTBASE}/share/doc
+ cp -af ${S}/doc/html ${D}${QTBASE}/share/doc
+
+
+ cd ${D}
+ ln -s /${QTBASE} usr/lib/qt-x11-3
+ insinto /etc/env.d
+ newins ${FILESDIR}/30qt.3 30qt
+ doins ${FILESDIR}/45qt-x11-3.0.1
+
+}