summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-07-29 14:27:27 +0000
committerMichał Górny <mgorny@gentoo.org>2014-07-29 14:27:27 +0000
commitc6006c7dc535362701862e66e66fb9e52d68f9b5 (patch)
tree4c78ef1b766b45276a19789d949e6ed67bf59f06 /x11-libs
parentRemove old. (diff)
downloadgentoo-2-c6006c7dc535362701862e66e66fb9e52d68f9b5.tar.gz
gentoo-2-c6006c7dc535362701862e66e66fb9e52d68f9b5.tar.bz2
gentoo-2-c6006c7dc535362701862e66e66fb9e52d68f9b5.zip
Fix finding Python when building in a root, bug #503228. Patch by James Le Cuirot.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxcb/ChangeLog7
-rw-r--r--x11-libs/libxcb/libxcb-1.10.ebuild4
-rw-r--r--x11-libs/libxcb/libxcb-1.9.3-r1.ebuild4
3 files changed, 10 insertions, 5 deletions
diff --git a/x11-libs/libxcb/ChangeLog b/x11-libs/libxcb/ChangeLog
index c2949665f6eb..b3fc2dbf78b3 100644
--- a/x11-libs/libxcb/ChangeLog
+++ b/x11-libs/libxcb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libxcb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.142 2014/06/18 21:05:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.143 2014/07/29 14:27:27 mgorny Exp $
+
+ 29 Jul 2014; Michał Górny <mgorny@gentoo.org> libxcb-1.10.ebuild,
+ libxcb-1.9.3-r1.ebuild:
+ Fix finding Python when building in a root, bug #503228. Patch by James Le
+ Cuirot.
18 Jun 2014; Michał Górny <mgorny@gentoo.org> libxcb-1.10.ebuild,
libxcb-1.9.1-r1.ebuild, libxcb-1.9.1.ebuild, libxcb-1.9.3-r1.ebuild,
diff --git a/x11-libs/libxcb/libxcb-1.10.ebuild b/x11-libs/libxcb/libxcb-1.10.ebuild
index 0591ed750d4c..9b03f97b29db 100644
--- a/x11-libs/libxcb/libxcb-1.10.ebuild
+++ b/x11-libs/libxcb/libxcb-1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.10.ebuild,v 1.13 2014/06/18 21:05:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.10.ebuild,v 1.14 2014/07/29 14:27:27 mgorny Exp $
EAPI=5
@@ -30,7 +30,7 @@ DEPEND="${RDEPEND}
">=x11-proto/xcb-proto-1.10[${MULTILIB_USEDEP},\${PYTHON_USEDEP}]")"
python_check_deps() {
- has_version ">=x11-proto/xcb-proto-1.10[${MULTILIB_USEDEP},${PYTHON_USEDEP}]"
+ has_version --host-root ">=x11-proto/xcb-proto-1.10[${MULTILIB_USEDEP},${PYTHON_USEDEP}]"
}
pkg_setup() {
diff --git a/x11-libs/libxcb/libxcb-1.9.3-r1.ebuild b/x11-libs/libxcb/libxcb-1.9.3-r1.ebuild
index 5adcdbe9a75c..bdcccff0ac1c 100644
--- a/x11-libs/libxcb/libxcb-1.9.3-r1.ebuild
+++ b/x11-libs/libxcb/libxcb-1.9.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.9.3-r1.ebuild,v 1.2 2014/06/18 21:05:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.9.3-r1.ebuild,v 1.3 2014/07/29 14:27:27 mgorny Exp $
EAPI=5
@@ -30,7 +30,7 @@ DEPEND="${RDEPEND}
">=x11-proto/xcb-proto-1.9-r1[${MULTILIB_USEDEP},\${PYTHON_USEDEP}]")"
python_check_deps() {
- has_version ">=x11-proto/xcb-proto-1.9-r1[${MULTILIB_USEDEP},${PYTHON_USEDEP}]"
+ has_version --host-root ">=x11-proto/xcb-proto-1.9-r1[${MULTILIB_USEDEP},${PYTHON_USEDEP}]"
}
pkg_setup() {