summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-02-27 17:18:02 +0000
committerMarinus Schraal <foser@gentoo.org>2003-02-27 17:18:02 +0000
commitca30ce8b51b74f07fca9b6d78afa3a51b2400cb6 (patch)
tree42a7875f55c15990f63a4637a50418c8cbdb9273 /x11-libs
parentand some more info to changelog (diff)
downloadgentoo-2-ca30ce8b51b74f07fca9b6d78afa3a51b2400cb6.tar.gz
gentoo-2-ca30ce8b51b74f07fca9b6d78afa3a51b2400cb6.tar.bz2
gentoo-2-ca30ce8b51b74f07fca9b6d78afa3a51b2400cb6.zip
mark 0.8 stable, moved from dev-libs to x11-libs
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk-sharp/ChangeLog40
-rw-r--r--x11-libs/gtk-sharp/files/digest-gtk-sharp-0.7-r11
-rw-r--r--x11-libs/gtk-sharp/files/digest-gtk-sharp-0.81
-rw-r--r--x11-libs/gtk-sharp/gtk-sharp-0.7-r1.ebuild58
-rw-r--r--x11-libs/gtk-sharp/gtk-sharp-0.8.ebuild78
5 files changed, 178 insertions, 0 deletions
diff --git a/x11-libs/gtk-sharp/ChangeLog b/x11-libs/gtk-sharp/ChangeLog
new file mode 100644
index 000000000000..7c5a571e026e
--- /dev/null
+++ b/x11-libs/gtk-sharp/ChangeLog
@@ -0,0 +1,40 @@
+# ChangeLog for dev-libs/gtk-sharp
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk-sharp/ChangeLog,v 1.1 2003/02/27 17:18:02 foser Exp $
+
+*gtk-sharp-0.8 (24 Feb 2003)
+
+ 27 Feb 2003; foser <foser@gentoo.org> gtk-sharp* :
+ Moved category from dev-libs to x11-libs
+ gtk-sharp-0.8 now uses mono eclass
+
+ 24 Feb 2003; foser <foser@gentoo.org> gtk-sharp-0.8.ebuild :
+ New version
+
+*gtk-sharp-0.7-r1 (20 Feb 2003)
+
+ 20 Feb 2003; foser <foser@gentoo.org> gtk-sharp-0.7-r1.ebuild :
+ Revision bump to fix problems mentioned in #16015
+
+*gtk-sharp-0.7 (24 Jan 2003)
+
+ 24 Jan 2003; foser <foser@gentoo.org> gtk-sharp-0.7.ebuild :
+ New version
+
+*gtk-sharp-0.6 (10 Dec 2002)
+
+ 10 Dec 2002; foser <foser@gentoo.org> gtk-sharp-0.6.ebuild :
+ New version
+ Sandbox hack for mcs was needed
+
+*gtk-sharp-0.5 (02 Nov 2002)
+
+ 02 Nov 2002; foser <foser@gentoo.org> gtk-sharp-0.5.ebuild :
+ New version, thanks to Philip Chapman <pac1085@rochester.rr.com>
+
+*gtk-sharp-0.2.1 (28 Jul 2002)
+
+ 28 Jul 2002; Phil Bordelon <sunflare@gentoo.org> gtk-sharp-0.2.1.ebuild, ChangeLog:
+ Original submission of the ebuild. This ebuild was provided by
+ Luis Mayoral <satriani@okulto.net> with some help from Seemant
+ Kulleen <seemant@gentoo.org>. Very minor edits by me.
diff --git a/x11-libs/gtk-sharp/files/digest-gtk-sharp-0.7-r1 b/x11-libs/gtk-sharp/files/digest-gtk-sharp-0.7-r1
new file mode 100644
index 000000000000..072edb4a1e56
--- /dev/null
+++ b/x11-libs/gtk-sharp/files/digest-gtk-sharp-0.7-r1
@@ -0,0 +1 @@
+MD5 54237554ced8f772ab2b5e35c6200dde gtk-sharp-0.7.tar.gz 504357
diff --git a/x11-libs/gtk-sharp/files/digest-gtk-sharp-0.8 b/x11-libs/gtk-sharp/files/digest-gtk-sharp-0.8
new file mode 100644
index 000000000000..378597d98ccf
--- /dev/null
+++ b/x11-libs/gtk-sharp/files/digest-gtk-sharp-0.8
@@ -0,0 +1 @@
+MD5 0f796f788159b008ee8a7f656dedf363 gtk-sharp-0.8.tar.gz 770890
diff --git a/x11-libs/gtk-sharp/gtk-sharp-0.7-r1.ebuild b/x11-libs/gtk-sharp/gtk-sharp-0.7-r1.ebuild
new file mode 100644
index 000000000000..9270a2e38d97
--- /dev/null
+++ b/x11-libs/gtk-sharp/gtk-sharp-0.7-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk-sharp/gtk-sharp-0.7-r1.ebuild,v 1.1 2003/02/27 17:18:02 foser Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gtk# is a C# language binding for the GTK2 toolkit."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://gtk-sharp.sourceforge.net/"
+
+LICENSE="LGPL"
+SLOT="0"
+IUSE="gnome"
+
+DEPEND=">=dev-lang/mono-0.16
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ gnome? ( >=gnome-base/libgnomecanvas-2
+ >=gnome-base/libgnomeui-2 )"
+
+KEYWORDS="~x86 -ppc"
+
+src_unpack() {
+ unpack ${A}
+
+ # disable building of samples (#16015)
+ cd ${S}
+ mv makefile makefile.old
+ sed -e "s:sample::" makefile.old > makefile
+ mv configure.in configure.in.old
+ sed -e "s:sample/Makefile::" configure.in.old > configure.in
+}
+
+src_compile() {
+ local myconf
+ myconf="--enable-glade"
+
+ use gnome \
+ && myconf="${myconf} --enable-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ # disable samples
+ ./autogen.sh
+
+ econf ${myconf} || die "./configure failed"
+
+ # mcs wants this during build
+ addwrite ~/.wapi
+ emake || die
+}
+
+src_install () {
+ # Path for the installation of the libs is hardcoded in the Makefile,
+ # so we need to change it - Is being changed, check evry release
+ for i in $(find . -iname Makefile); do cp $i ${i}.orig; sed "s:${DESTDIR}/usr:${D}/usr:" $i.orig > $i; done
+
+ einstall || die
+ dodoc HACKING README* ChangeLog
+}
diff --git a/x11-libs/gtk-sharp/gtk-sharp-0.8.ebuild b/x11-libs/gtk-sharp/gtk-sharp-0.8.ebuild
new file mode 100644
index 000000000000..7e092eee8625
--- /dev/null
+++ b/x11-libs/gtk-sharp/gtk-sharp-0.8.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk-sharp/gtk-sharp-0.8.ebuild,v 1.1 2003/02/27 17:18:02 foser Exp $
+
+# WARNING
+# All gst-sharp hacks done in this build are nonfunctional
+# Do not try to use them, they don't work. Not for me, not for anybody.
+# They're just here for future reference
+#
+# foser <foser@gentoo.org>
+
+inherit eutils mono
+
+DESCRIPTION="Gtk# is a C# language binding for the GTK2 toolkit and GNOME libraries"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://gtk-sharp.sourceforge.net/"
+
+LICENSE="LGPL"
+SLOT="0"
+IUSE="gnome"
+
+DEPEND=">=dev-lang/mono-0.16
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ gnome? ( >=gnome-base/libgnomecanvas-2
+ >=gnome-base/libgnomeui-2 )"
+
+KEYWORDS="x86 -ppc"
+
+src_unpack() {
+ unpack ${A}
+
+ # disable building of samples (#16015)
+ cd ${S}
+ mv makefile makefile.old
+ sed -e "s:sample::" makefile.old > makefile
+ mv configure.in configure.in.old
+ sed -e "s:sample/Makefile::" configure.in.old > configure.in
+
+ # patch gst-sharp stuff
+ # epatch ${FILESDIR}/${P}-gst_sharp.patch
+}
+
+src_compile() {
+ local myconf
+ myconf="--enable-glade"
+
+ use gnome \
+ && myconf="${myconf} --enable-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ # disable samples
+ ./autogen.sh
+
+ econf ${myconf} || die "./configure failed"
+
+ emake || die
+
+ # gst-sharp hacks
+ # cd ${S}/gst/
+ # epatch ${FILESDIR}/${P}-generated_fix.patch
+ # rm gst-sharp.dll
+ # make || die "Died making gst-sharp bindings"
+}
+
+src_install () {
+ # Path for the installation of the libs is hardcoded in the Makefile,
+ # so we need to change it - Is being changed, check every release
+ for i in $(find . -iname Makefile); do cp $i ${i}.orig; sed "s:${DESTDIR}/usr:${D}/usr:" $i.orig > $i; done
+
+ einstall || die
+
+ # gst-sharp install
+ # cd ${S}/gst/
+ # make install || die "Gst-sharp install failed"
+
+ dodoc HACKING README* ChangeLog
+}