summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-11 16:14:17 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-11 16:14:17 +0000
commitd40ae8a9c72a8eaa28cff4232fd82d8c2baa2ffd (patch)
treec2123a21d6bfd9eaf5e36815cab113c6d02a1e37 /x11-libs
parentUpdated the fix-trayicon patch to include all the 4 commits by Kevin Funk ava... (diff)
downloadgentoo-2-d40ae8a9c72a8eaa28cff4232fd82d8c2baa2ffd.tar.gz
gentoo-2-d40ae8a9c72a8eaa28cff4232fd82d8c2baa2ffd.tar.bz2
gentoo-2-d40ae8a9c72a8eaa28cff4232fd82d8c2baa2ffd.zip
Imported doc building patch from sci overlay, #327599
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gl2ps/ChangeLog7
-rw-r--r--x11-libs/gl2ps/gl2ps-1.3.5-r1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-libs/gl2ps/ChangeLog b/x11-libs/gl2ps/ChangeLog
index 9c423d57439c..68ed46ebb1d3 100644
--- a/x11-libs/gl2ps/ChangeLog
+++ b/x11-libs/gl2ps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gl2ps
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/ChangeLog,v 1.7 2010/02/20 17:24:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/ChangeLog,v 1.8 2010/07/11 16:14:17 jlec Exp $
+
+*gl2ps-1.3.5-r1 (11 Jul 2010)
+
+ 11 Jul 2010; Justin Lecher <jlec@gentoo.org> +gl2ps-1.3.5-r1.ebuild:
+ Imported doc building patch from sci overlay, #327599
20 Feb 2010; Raúl Porcel <armin76@gentoo.org> gl2ps-1.3.5.ebuild:
Add ~alpha wrt #303675
diff --git a/x11-libs/gl2ps/gl2ps-1.3.5-r1.ebuild b/x11-libs/gl2ps/gl2ps-1.3.5-r1.ebuild
new file mode 100644
index 000000000000..122c033170f7
--- /dev/null
+++ b/x11-libs/gl2ps/gl2ps-1.3.5-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/gl2ps-1.3.5-r1.ebuild,v 1.1 2010/07/11 16:14:17 jlec Exp $
+
+EAPI="3"
+inherit cmake-utils multilib
+
+DESCRIPTION="OpenGL to PostScript printing library"
+HOMEPAGE="http://www.geuz.org/gl2ps/"
+SRC_URI="http://geuz.org/${PN}/src/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc png zlib"
+
+DEPEND="virtual/glut
+ png? ( media-libs/libpng )
+ zlib? ( sys-libs/zlib )
+ doc? (
+ dev-tex/tth
+ dev-texlive/texlive-latex
+ )"
+
+S=${WORKDIR}/${P}-source
+
+PATCHES=( "${FILESDIR}/${P}-CMakeLists.patch" )
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_has png PNG)
+ $(cmake-utils_use_has zlib ZLIB)
+ $(cmake-utils_use_has doc DOC)"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ prepalldocs
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # CMake produces an invalid dylib here, but I have no clue how to fix it
+ # hmm, it's also unversioned :(
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib \
+ "${D%/}${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib || die
+ fi
+}