summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2007-02-21 00:51:35 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2007-02-21 00:51:35 +0000
commitfc5af55f8651e11844943386bb997e2a13a5c368 (patch)
treed4d8864015e75e61766abc3cbce5277fd768d629 /x11-libs
parentRemoved multiple inherit line. (diff)
downloadgentoo-2-fc5af55f8651e11844943386bb997e2a13a5c368.tar.gz
gentoo-2-fc5af55f8651e11844943386bb997e2a13a5c368.tar.bz2
gentoo-2-fc5af55f8651e11844943386bb997e2a13a5c368.zip
Get rid of C++ symbol in Xrandr.h. (Bug #167714; Ginsu for the report, Doug
Goldstein for the patch) (Portage version: 2.1.2-r10)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libXrandr/ChangeLog10
-rw-r--r--x11-libs/libXrandr/files/digest-libXrandr-1.2.0-r1 (renamed from x11-libs/libXrandr/files/digest-libXrandr-1.2.0)0
-rw-r--r--x11-libs/libXrandr/files/libXrandr-1.2.0-delete-keyword-usage.patch33
-rw-r--r--x11-libs/libXrandr/libXrandr-1.2.0-r1.ebuild (renamed from x11-libs/libXrandr/libXrandr-1.2.0.ebuild)4
4 files changed, 45 insertions, 2 deletions
diff --git a/x11-libs/libXrandr/ChangeLog b/x11-libs/libXrandr/ChangeLog
index 2ebb99efbf43..6f14c5c006a5 100644
--- a/x11-libs/libXrandr/ChangeLog
+++ b/x11-libs/libXrandr/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/libXrandr
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXrandr/ChangeLog,v 1.30 2007/02/19 22:55:08 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXrandr/ChangeLog,v 1.31 2007/02/21 00:51:35 joshuabaergen Exp $
+
+*libXrandr-1.2.0-r1 (21 Feb 2007)
+
+ 21 Feb 2007; Joshua Baergen <joshuabaergen@gentoo.org>
+ +files/libXrandr-1.2.0-delete-keyword-usage.patch,
+ -libXrandr-1.2.0.ebuild, +libXrandr-1.2.0-r1.ebuild:
+ Get rid of C++ symbol in Xrandr.h. (Bug #167714; Ginsu for the report, Doug
+ Goldstein for the patch)
*libXrandr-1.2.0 (19 Feb 2007)
diff --git a/x11-libs/libXrandr/files/digest-libXrandr-1.2.0 b/x11-libs/libXrandr/files/digest-libXrandr-1.2.0-r1
index 4c658b14d35c..4c658b14d35c 100644
--- a/x11-libs/libXrandr/files/digest-libXrandr-1.2.0
+++ b/x11-libs/libXrandr/files/digest-libXrandr-1.2.0-r1
diff --git a/x11-libs/libXrandr/files/libXrandr-1.2.0-delete-keyword-usage.patch b/x11-libs/libXrandr/files/libXrandr-1.2.0-delete-keyword-usage.patch
new file mode 100644
index 000000000000..702b5b3602b4
--- /dev/null
+++ b/x11-libs/libXrandr/files/libXrandr-1.2.0-delete-keyword-usage.patch
@@ -0,0 +1,33 @@
+diff -Nur libXrandr-1.2.0/include/X11/extensions/Xrandr.h libXrandr-1.2.0-fix/include/X11/extensions/Xrandr.h
+--- libXrandr-1.2.0/include/X11/extensions/Xrandr.h 2006-12-13 04:24:25.000000000 -0500
++++ libXrandr-1.2.0-fix/include/X11/extensions/Xrandr.h 2007-02-20 15:24:11.000000000 -0500
+@@ -296,7 +296,7 @@
+ int
+ XRRGetOutputProperty (Display *dpy, RROutput output,
+ Atom property, long offset, long length,
+- Bool delete, Bool pending, Atom req_type,
++ Bool del, Bool pending, Atom req_type,
+ Atom *actual_type, int *actual_format,
+ unsigned long *nitems, unsigned long *bytes_after,
+ unsigned char **prop);
+diff -Nur libXrandr-1.2.0/src/XrrProperty.c libXrandr-1.2.0-fix/src/XrrProperty.c
+--- libXrandr-1.2.0/src/XrrProperty.c 2007-01-31 17:23:05.000000000 -0500
++++ libXrandr-1.2.0-fix/src/XrrProperty.c 2007-02-20 15:23:41.000000000 -0500
+@@ -250,7 +250,7 @@
+ int
+ XRRGetOutputProperty (Display *dpy, RROutput output,
+ Atom property, long offset, long length,
+- Bool delete, Bool pending, Atom req_type,
++ Bool del, Bool pending, Atom req_type,
+ Atom *actual_type, int *actual_format,
+ unsigned long *nitems, unsigned long *bytes_after,
+ unsigned char **prop)
+@@ -273,7 +273,7 @@
+ req->type = req_type;
+ req->longOffset = offset;
+ req->longLength = length;
+- req->delete = delete;
++ req->delete = del;
+ req->pending = pending;
+
+ if (!_XReply (dpy, (xReply *) &rep, 0, xFalse))
diff --git a/x11-libs/libXrandr/libXrandr-1.2.0.ebuild b/x11-libs/libXrandr/libXrandr-1.2.0-r1.ebuild
index f2d786997246..1c334c5f7e69 100644
--- a/x11-libs/libXrandr/libXrandr-1.2.0.ebuild
+++ b/x11-libs/libXrandr/libXrandr-1.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXrandr/libXrandr-1.2.0.ebuild,v 1.1 2007/02/19 22:55:08 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXrandr/libXrandr-1.2.0-r1.ebuild,v 1.1 2007/02/21 00:51:35 joshuabaergen Exp $
# Must be before x-modular eclass is inherited
# SNAPSHOT="yes"
@@ -18,3 +18,5 @@ RDEPEND="x11-libs/libX11
x11-proto/xproto"
DEPEND="${RDEPEND}
x11-proto/renderproto"
+
+PATCHES="${FILESDIR}/${P}-delete-keyword-usage.patch"