summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-05-28 17:28:42 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-05-28 17:28:42 +0000
commitf6ba621325d2757f1d6e26436ccbc0509aabf9a3 (patch)
tree4f33e9be47707d77e052a0222a28549a1148d026 /x11-misc/bbrun
parentFix configuration (bug #321783). (diff)
downloadgentoo-2-f6ba621325d2757f1d6e26436ccbc0509aabf9a3.tar.gz
gentoo-2-f6ba621325d2757f1d6e26436ccbc0509aabf9a3.tar.bz2
gentoo-2-f6ba621325d2757f1d6e26436ccbc0509aabf9a3.zip
Adding missing dependency and respect user flags. Thanks Patrick for the report and Andrew Brouwers for patch.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/bbrun')
-rw-r--r--x11-misc/bbrun/ChangeLog9
-rw-r--r--x11-misc/bbrun/bbrun-1.6.ebuild9
-rw-r--r--x11-misc/bbrun/files/bbrun-1.6-respectflags.patch26
3 files changed, 38 insertions, 6 deletions
diff --git a/x11-misc/bbrun/ChangeLog b/x11-misc/bbrun/ChangeLog
index 9701cd1c07b2..de909e5d3a83 100644
--- a/x11-misc/bbrun/ChangeLog
+++ b/x11-misc/bbrun/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/bbrun
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbrun/ChangeLog,v 1.21 2008/01/13 02:52:07 drac Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbrun/ChangeLog,v 1.22 2010/05/28 17:28:42 xarthisius Exp $
+
+ 28 May 2010; Kacper Kowalik <xarthisius@gentoo.org> bbrun-1.6.ebuild,
+ +files/bbrun-1.6-respectflags.patch:
+ Adding missing dependency and respect user flags. Thanks Patrick for the
+ report and Andrew Brouwers for patch.
13 Jan 2008; Samuli Suominen <drac@gentoo.org> bbrun-1.6.ebuild:
toolchanify and stable on amd64.
diff --git a/x11-misc/bbrun/bbrun-1.6.ebuild b/x11-misc/bbrun/bbrun-1.6.ebuild
index ff0bd090e4e1..b66d457f9bda 100644
--- a/x11-misc/bbrun/bbrun-1.6.ebuild
+++ b/x11-misc/bbrun/bbrun-1.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbrun/bbrun-1.6.ebuild,v 1.7 2008/01/13 02:52:07 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbrun/bbrun-1.6.ebuild,v 1.8 2010/05/28 17:28:42 xarthisius Exp $
-inherit multilib toolchain-funcs
+inherit eutils multilib toolchain-funcs
DESCRIPTION="blackbox program execution dialog box"
HOMEPAGE="http://www.darkops.net/bbrun"
@@ -15,6 +15,7 @@ IUSE=""
RDEPEND=">=x11-libs/gtk+-2"
DEPEND="${RDEPEND}
+ x11-libs/libXpm
dev-util/pkgconfig"
S=${WORKDIR}/${P}/${PN}
@@ -22,7 +23,7 @@ S=${WORKDIR}/${P}/${PN}
src_unpack() {
unpack ${A}
cd "${S}"
- sed -e "s:-O2::" -e "s:-g:${CFLAGS}:g" -i Makefile
+ epatch "${FILESDIR}"/${P}-respectflags.patch
}
src_compile() {
diff --git a/x11-misc/bbrun/files/bbrun-1.6-respectflags.patch b/x11-misc/bbrun/files/bbrun-1.6-respectflags.patch
new file mode 100644
index 000000000000..d81824b0ed0f
--- /dev/null
+++ b/x11-misc/bbrun/files/bbrun-1.6-respectflags.patch
@@ -0,0 +1,26 @@
+Respect {C,LD}FLAGS
+
+--- bbrun/Makefile
++++ bbrun/Makefile
+@@ -1,7 +1,7 @@
+ CC = gcc
+ LIBDIR = -L/usr/lib -L/usr/X11R6/lib
+ LIBS = -lXpm `pkg-config --libs gtk+-2.0`
+-CFLAGS = `pkg-config --cflags gtk+-2.0`
++GTK_CFLAGS = `pkg-config --cflags gtk+-2.0`
+
+ OBJS = bbrun.o \
+ ../wmgeneral/wmgeneral.o \
+@@ -11,10 +11,10 @@
+ all: bbrun
+
+ .c.o:
+- $(CC) -g -c -O2 -Wall $< -o $*.o $(CFLAGS)
++ $(CC) $(CFLAGS) $(GTK_CFLAGS) -c -Wall $< -o $*.o
+
+ bbrun: $(OBJS)
+- $(CC) -Wall -g -o bbrun $^ $(LIBDIR) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -Wall -o bbrun $^ $(LIBDIR) $(LIBS)
+
+ install:
+ cp bbrun /usr/local/bin/