summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-10-06 15:30:16 +0000
committerDan Armak <danarmak@gentoo.org>2001-10-06 15:30:16 +0000
commit3e511008adb1aba4e01c7a7455f2c0f2f73b750d (patch)
treea2c774b78d6585e40bd6cd6bf84d44f36146ae11 /x11-misc/bbweather/bbweather-0.3-r1.ebuild
parentadded -lm (diff)
downloadgentoo-2-3e511008adb1aba4e01c7a7455f2c0f2f73b750d.tar.gz
gentoo-2-3e511008adb1aba4e01c7a7455f2c0f2f73b750d.tar.bz2
gentoo-2-3e511008adb1aba4e01c7a7455f2c0f2f73b750d.zip
The Big Commit. Modifies apps to install into /usr instead of /usr/X11R6. If it breaks, fix it.
Diffstat (limited to 'x11-misc/bbweather/bbweather-0.3-r1.ebuild')
-rw-r--r--x11-misc/bbweather/bbweather-0.3-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-misc/bbweather/bbweather-0.3-r1.ebuild b/x11-misc/bbweather/bbweather-0.3-r1.ebuild
new file mode 100644
index 000000000000..f926539efdfe
--- /dev/null
+++ b/x11-misc/bbweather/bbweather-0.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Joe Bormolini <lordjoe@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbweather/bbweather-0.3-r1.ebuild,v 1.1 2001/10/06 15:30:16 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="blackbox weather monitor"
+SRC_URI="http://www.netmeister.org/apps/${P}.tar.bz2"
+HOMEPAGE="http://www.netmeister.org/apps/bbweather/index.html"
+
+DEPEND=">=x11-wm/blackbox-0.61
+ >=net-misc/wget-1.7
+ >=sys-devel/perl-5.6.1"
+
+src_compile() {
+ ./configure --prefix=/usr --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ rm -rf ${D}/usr/share/doc
+ dodoc README COPYING AUTHORS INSTALL ChangeLog NEWS TODO data/README.bbweather
+ docinto html
+ dodoc doc/*.html
+}