summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-20 17:00:05 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-20 17:00:05 +0000
commit238bdcbe30653be24b797ba17daec96e67607350 (patch)
treec5fc13303c6b32302b42a7cac893117bfac8bffe /x11-misc/bubblemon
parentsparc stable wrt #302326 (diff)
downloadgentoo-2-238bdcbe30653be24b797ba17daec96e67607350.tar.gz
gentoo-2-238bdcbe30653be24b797ba17daec96e67607350.tar.bz2
gentoo-2-238bdcbe30653be24b797ba17daec96e67607350.zip
Fix building with -Wl,--as-needed.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/bubblemon')
-rw-r--r--x11-misc/bubblemon/ChangeLog6
-rw-r--r--x11-misc/bubblemon/bubblemon-1.46-r1.ebuild23
-rw-r--r--x11-misc/bubblemon/files/bubblemon-1.46-asneeded.patch30
3 files changed, 47 insertions, 12 deletions
diff --git a/x11-misc/bubblemon/ChangeLog b/x11-misc/bubblemon/ChangeLog
index 143a6c5c52c0..165a9431b6d5 100644
--- a/x11-misc/bubblemon/ChangeLog
+++ b/x11-misc/bubblemon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/bubblemon
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bubblemon/ChangeLog,v 1.36 2010/01/10 18:39:54 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bubblemon/ChangeLog,v 1.37 2010/03/20 17:00:03 ssuominen Exp $
+
+ 20 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ bubblemon-1.46-r1.ebuild, +files/bubblemon-1.46-asneeded.patch:
+ Fix building with -Wl,--as-needed.
10 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
bubblemon-1.46-r1.ebuild, bubblemon-2.0.14.ebuild:
diff --git a/x11-misc/bubblemon/bubblemon-1.46-r1.ebuild b/x11-misc/bubblemon/bubblemon-1.46-r1.ebuild
index d1bd31473835..1ac3b3a0bcd9 100644
--- a/x11-misc/bubblemon/bubblemon-1.46-r1.ebuild
+++ b/x11-misc/bubblemon/bubblemon-1.46-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bubblemon/bubblemon-1.46-r1.ebuild,v 1.8 2010/01/10 18:39:54 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bubblemon/bubblemon-1.46-r1.ebuild,v 1.9 2010/03/20 17:00:03 ssuominen Exp $
-inherit eutils
+EAPI=2
+inherit eutils toolchain-funcs
DESCRIPTION="A fun monitoring applet for your desktop, complete with swimming duck"
HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
@@ -13,30 +14,30 @@ SLOT="0"
KEYWORDS="alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~x64-solaris"
IUSE=""
-RDEPEND=">=x11-libs/gtk+-2"
+RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
S=${WORKDIR}/${PN}-dockapp-${PV}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gtk.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gtk.patch \
+ "${FILESDIR}"/${P}-asneeded.patch
}
src_compile() {
+ tc-export CC
emake GENTOO_CFLAGS="${CFLAGS}" || die "emake failed."
}
-src_install () {
- dobin bubblemon
+src_install() {
+ dobin bubblemon || die
dodoc ChangeLog README doc/Xdefaults.sample
insinto /usr/share/${PN}
- doins misc/{*.xcf,*.wav}
+ doins misc/*.{xcf,wav} || die
exeinto /usr/share/${PN}
- doexe misc/wakwak.sh
+ doexe misc/wakwak.sh || die
}
diff --git a/x11-misc/bubblemon/files/bubblemon-1.46-asneeded.patch b/x11-misc/bubblemon/files/bubblemon-1.46-asneeded.patch
new file mode 100644
index 000000000000..3988f3796964
--- /dev/null
+++ b/x11-misc/bubblemon/files/bubblemon-1.46-asneeded.patch
@@ -0,0 +1,30 @@
+--- Makefile
++++ Makefile
+@@ -32,14 +32,12 @@
+ OBJS = bubblemon.o
+ BUBBLEMON = bubblemon
+
+-LDFLAGS = -shared -Wl
+-
+ STRIP = strip
+
+-CC = gcc
++CC ?= gcc
+ INSTALLMAN = -m 644
+
+-
++LIBS = -lX11
+
+ # special things for Linux
+ ifeq ($(OS), Linux)
+@@ -91,8 +89,8 @@
+ all: $(BUBBLEMON)
+
+ bubblemon: clean_obj
+- $(CC) $(GTK2_CFLAGS) $(CFLAGS) -o $(BUBBLEMON) \
+- $(LIBS) $(GTK2_LIBS) $(SRCS)
++ $(CC) $(LDFLAGS) $(GTK2_CFLAGS) $(CFLAGS) -o $(BUBBLEMON) \
++ $(SRCS) $(LIBS) $(GTK2_LIBS)
+
+ clean_obj:
+ rm -rf *.o