summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-03-16 12:12:09 +0000
committerCédric Krier <cedk@gentoo.org>2008-03-16 12:12:09 +0000
commite6cb53035091166751c7d0891367eabf851f2420 (patch)
tree9fabb881fdd2b88ce71416b928c8eb25946eedb3 /x11-misc/dmenu
parentamd64 stable. remove old for repoman, has unstable mips deps. (diff)
downloadgentoo-2-e6cb53035091166751c7d0891367eabf851f2420.tar.gz
gentoo-2-e6cb53035091166751c7d0891367eabf851f2420.tar.bz2
gentoo-2-e6cb53035091166751c7d0891367eabf851f2420.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-misc/dmenu')
-rw-r--r--x11-misc/dmenu/ChangeLog9
-rw-r--r--x11-misc/dmenu/dmenu-3.5.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/x11-misc/dmenu/ChangeLog b/x11-misc/dmenu/ChangeLog
index bba05a74952e..90ac464bd136 100644
--- a/x11-misc/dmenu/ChangeLog
+++ b/x11-misc/dmenu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/dmenu
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.28 2007/11/16 20:44:15 cedk Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.29 2008/03/16 12:12:09 cedk Exp $
+
+*dmenu-3.5 (16 Mar 2008)
+
+ 16 Mar 2008; Cédric Krier <cedk@gentoo.org> +dmenu-3.5.ebuild:
+ Version bump
*dmenu-3.4 (16 Nov 2007)
diff --git a/x11-misc/dmenu/dmenu-3.5.ebuild b/x11-misc/dmenu/dmenu-3.5.ebuild
new file mode 100644
index 000000000000..ff00ecc3019f
--- /dev/null
+++ b/x11-misc/dmenu/dmenu-3.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/dmenu-3.5.ebuild,v 1.1 2008/03/16 12:12:09 cedk Exp $
+
+inherit toolchain-funcs savedconfig
+
+DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
+HOMEPAGE="http://tools.suckless.org/view.sh/x+tools"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS += -g/" \
+ -e "s/LDFLAGS = -s/LDFLAGS += -g/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ restore_config config.h
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ dodoc README
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+}