summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-11 00:53:26 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-11 00:53:26 +0000
commitd3cfa38133790efd6d0b74fe85832a8ab9a6837f (patch)
tree32a648f4baf1e965996e7524b352dce3f0d2576b /x11-misc/entrance
parentsecurity mask mail-filter/libspf (diff)
downloadgentoo-2-d3cfa38133790efd6d0b74fe85832a8ab9a6837f.tar.gz
gentoo-2-d3cfa38133790efd6d0b74fe85832a8ab9a6837f.tar.bz2
gentoo-2-d3cfa38133790efd6d0b74fe85832a8ab9a6837f.zip
generate new entrance_config.cfg automatically based upon /etc/X11/Sessions
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'x11-misc/entrance')
-rw-r--r--x11-misc/entrance/entrance-9999.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/x11-misc/entrance/entrance-9999.ebuild b/x11-misc/entrance/entrance-9999.ebuild
index 6b11271b9972..ca845082ba8b 100644
--- a/x11-misc/entrance/entrance-9999.ebuild
+++ b/x11-misc/entrance/entrance-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/entrance-9999.ebuild,v 1.10 2006/08/11 00:07:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/entrance-9999.ebuild,v 1.11 2006/08/11 00:53:26 vapier Exp $
inherit enlightenment eutils
@@ -39,5 +39,13 @@ src_install() {
insinto /usr/share/entrance/images/sessions
doins "${WORKDIR}"/extraicons/*
exeinto /usr/share/entrance
- doexe data/config/build_config.sh
+ doexe data/config/build_config.sh || die
+}
+
+pkg_preinst() {
+ if [[ -d ${ROOT}/etc/X11/Sessions ]] ; then
+ "${D}"/usr/share/entrance/build_config.sh \
+ -c "${D}"/etc/entrance_config.cfg \
+ -d "${ROOT}"/etc/X11/Sessions
+ fi
}