summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-06 06:53:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-06 06:53:53 +0000
commita8acbbc5789301a9c1d8096ce5fbd9d83e289fc7 (patch)
tree619946d07e4896a488521d7dd774c98dff4f9890 /x11-misc/expocity/expocity-2.6.2.1.ebuild
parentForce Python 2.x wrt #317013. (diff)
downloadgentoo-2-a8acbbc5789301a9c1d8096ce5fbd9d83e289fc7.tar.gz
gentoo-2-a8acbbc5789301a9c1d8096ce5fbd9d83e289fc7.tar.bz2
gentoo-2-a8acbbc5789301a9c1d8096ce5fbd9d83e289fc7.zip
Missing USE depend "X" for pango wrt #248559 by Diego E. Pettenò. Also move use_enable out of global scope...
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/expocity/expocity-2.6.2.1.ebuild')
-rw-r--r--x11-misc/expocity/expocity-2.6.2.1.ebuild35
1 files changed, 18 insertions, 17 deletions
diff --git a/x11-misc/expocity/expocity-2.6.2.1.ebuild b/x11-misc/expocity/expocity-2.6.2.1.ebuild
index ecf764db58ce..ada36d4848a7 100644
--- a/x11-misc/expocity/expocity-2.6.2.1.ebuild
+++ b/x11-misc/expocity/expocity-2.6.2.1.ebuild
@@ -1,32 +1,33 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/expocity/expocity-2.6.2.1.ebuild,v 1.7 2007/02/11 00:56:09 troll Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/expocity/expocity-2.6.2.1.ebuild,v 1.8 2010/06/06 06:53:53 ssuominen Exp $
+EAPI=2
inherit gnome2
-DESCRIPTION="metacity app for switching between apps; similar to Expose on OSX"
+MY_P=${P/.1/-1}
+DESCRIPTION="metacity app for switching between apps; similar to Expose on OSX"
HOMEPAGE="http://www.pycage.de/#expocity"
-MY_P=${P/.1/-1}
SRC_URI="http://www.pycage.de/download/${MY_P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
-IUSE="xinerama"
KEYWORDS="~amd64 ppc x86"
+IUSE="xinerama"
-# All needed X11 related DEPEND atoms are in gtk+
-RDEPEND=">=x11-libs/pango-1.2
- >=x11-libs/gtk+-2.2.0-r1
- >=gnome-base/gconf-2
- >=x11-libs/startup-notification-0.4
- !x11-wm/metacity"
-
+RDEPEND=">=x11-libs/pango-1.2[X]
+ x11-libs/gtk+:2
+ >=gnome-base/gconf-2
+ >=x11-libs/startup-notification-0.4
+ !x11-wm/metacity"
DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.12.0
- >=dev-util/intltool-0.29"
+ >=dev-util/pkgconfig-0.12
+ >=dev-util/intltool-0.29"
S=${WORKDIR}/${MY_P}
-G2CONF="${G2CONF} $(use_enable xinerama)"
-DOCS="AUTHORS Changelog HACKING NEWS README*"
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable xinerama)"
+ DOCS="AUTHORS Changelog HACKING NEWS README*"
+}