summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-10-31 12:22:00 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-10-31 12:22:00 +0000
commitbd4207a8161953aca786233a65d3e998018abf57 (patch)
tree10e53148465cc1169b8e41ec6e5757db5e704859 /x11-misc/imake/imake-1.0.4.ebuild
parentStable on amd64 wrt bug #343399 (diff)
downloadgentoo-2-bd4207a8161953aca786233a65d3e998018abf57.tar.gz
gentoo-2-bd4207a8161953aca786233a65d3e998018abf57.tar.bz2
gentoo-2-bd4207a8161953aca786233a65d3e998018abf57.zip
Version bump
(Portage version: 2.2_rc98/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/imake/imake-1.0.4.ebuild')
-rw-r--r--x11-misc/imake/imake-1.0.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-misc/imake/imake-1.0.4.ebuild b/x11-misc/imake/imake-1.0.4.ebuild
new file mode 100644
index 000000000000..3780d0cbabc3
--- /dev/null
+++ b/x11-misc/imake/imake-1.0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/imake/imake-1.0.4.ebuild,v 1.1 2010/10/31 12:22:00 scarabeus Exp $
+
+EAPI=3
+
+XORG_STATIC=no
+inherit xorg-2
+
+DESCRIPTION="C preprocessor interface to the make utility"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-misc/xorg-cf-files"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ # don't use Sun compilers on Solaris, we want GCC from prefix
+ sed -i \
+ -e "1s/^/#if defined(sun)\n# undef sun\n#endif/" \
+ imake.c imakemdep.h || die "sed failed"
+ xorg-2_src_prepare
+}