summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-07-21 20:25:07 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-07-21 20:25:07 +0000
commite08dd376347782fc93b908a2f08218c3f86931cd (patch)
treea38828568a37827a36258b68e8452a895bd23e33 /x11-misc/keytouch-editor
parentalpha/ia64/x86 stable wrt #232523 (diff)
downloadgentoo-2-e08dd376347782fc93b908a2f08218c3f86931cd.tar.gz
gentoo-2-e08dd376347782fc93b908a2f08218c3f86931cd.tar.bz2
gentoo-2-e08dd376347782fc93b908a2f08218c3f86931cd.zip
Fix building with glibc-2.8, bug #231122
(Portage version: 2.2_rc1/cvs/Linux 2.6.26 x86_64)
Diffstat (limited to 'x11-misc/keytouch-editor')
-rw-r--r--x11-misc/keytouch-editor/ChangeLog6
-rw-r--r--x11-misc/keytouch-editor/files/keytouch-editor-3.1.3-glibc28.patch10
-rw-r--r--x11-misc/keytouch-editor/keytouch-editor-3.1.3.ebuild14
3 files changed, 25 insertions, 5 deletions
diff --git a/x11-misc/keytouch-editor/ChangeLog b/x11-misc/keytouch-editor/ChangeLog
index 37f5620fc433..8e8995f4aff8 100644
--- a/x11-misc/keytouch-editor/ChangeLog
+++ b/x11-misc/keytouch-editor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/keytouch-editor
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/keytouch-editor/ChangeLog,v 1.6 2008/02/29 20:49:02 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/keytouch-editor/ChangeLog,v 1.7 2008/07/21 20:25:07 nyhm Exp $
+
+ 21 Jul 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/keytouch-editor-3.1.3-glibc28.patch, keytouch-editor-3.1.3.ebuild:
+ Fix building with glibc-2.8, bug #231122
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org>
keytouch-editor-3.1.3.ebuild:
diff --git a/x11-misc/keytouch-editor/files/keytouch-editor-3.1.3-glibc28.patch b/x11-misc/keytouch-editor/files/keytouch-editor-3.1.3-glibc28.patch
new file mode 100644
index 000000000000..6c9680d2a4a2
--- /dev/null
+++ b/x11-misc/keytouch-editor/files/keytouch-editor-3.1.3-glibc28.patch
@@ -0,0 +1,10 @@
+--- src/ud_socket.c
++++ src/ud_socket.c
+@@ -3,6 +3,7 @@
+ * A few routines for handling UNIX domain sockets
+ */
+
++#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
diff --git a/x11-misc/keytouch-editor/keytouch-editor-3.1.3.ebuild b/x11-misc/keytouch-editor/keytouch-editor-3.1.3.ebuild
index 4df236b47da4..c2938209b513 100644
--- a/x11-misc/keytouch-editor/keytouch-editor-3.1.3.ebuild
+++ b/x11-misc/keytouch-editor/keytouch-editor-3.1.3.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/keytouch-editor/keytouch-editor-3.1.3.ebuild,v 1.2 2008/02/29 20:49:02 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/keytouch-editor/keytouch-editor-3.1.3.ebuild,v 1.3 2008/07/21 20:25:07 nyhm Exp $
inherit eutils linux-info
-DOC_V=3.0
DESCRIPTION="Generates keyboard files for use by keyTouch"
HOMEPAGE="http://keytouch.sourceforge.net/"
SRC_URI="mirror://sourceforge/keytouch/${P}.tar.gz
- doc? ( mirror://sourceforge/keytouch/keytouch_editor_${DOC_V}.pdf )"
+ doc? ( mirror://sourceforge/keytouch/keytouch_editor_3.0.pdf )"
LICENSE="GPL-2"
SLOT="0"
@@ -21,9 +20,16 @@ DEPEND="${RDEPEND}
RDEPEND="${RDEPEND}
kde? ( || (
kde-base/kdesu
- kde-base/kdebase ) )
+ kde-base/kdebase
+ ) )
!kde? ( x11-libs/gksu )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-glibc28.patch
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"