summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-12-25 00:26:12 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-12-25 00:26:12 +0000
commit598a5cd448d45ef828377619fe773c145b5e5738 (patch)
tree7a093c9a6bd9fca5c3233c0620d5f3f69821671c /x11-misc/lineak-kdeplugins/lineak-kdeplugins-0.8.4.ebuild
parentversion bump, fix installpath thanks to Vincziczki Gabor <vincziczki.gabor@ne... (diff)
downloadgentoo-2-598a5cd448d45ef828377619fe773c145b5e5738.tar.gz
gentoo-2-598a5cd448d45ef828377619fe773c145b5e5738.tar.bz2
gentoo-2-598a5cd448d45ef828377619fe773c145b5e5738.zip
version bump
(Portage version: 2.1_pre1)
Diffstat (limited to 'x11-misc/lineak-kdeplugins/lineak-kdeplugins-0.8.4.ebuild')
-rw-r--r--x11-misc/lineak-kdeplugins/lineak-kdeplugins-0.8.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/lineak-kdeplugins/lineak-kdeplugins-0.8.4.ebuild b/x11-misc/lineak-kdeplugins/lineak-kdeplugins-0.8.4.ebuild
new file mode 100644
index 000000000000..5faffcb04db9
--- /dev/null
+++ b/x11-misc/lineak-kdeplugins/lineak-kdeplugins-0.8.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineak-kdeplugins/lineak-kdeplugins-0.8.4.ebuild,v 1.1 2005/12/25 00:26:12 genstef Exp $
+
+inherit kde multilib
+
+MY_P=${PN/-/_}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="KDE plugins for LINEAK"
+HOMEPAGE="http://lineak.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lineak/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="=x11-misc/lineakd-${PV}*"
+DEPEND="${RDEPEND}"
+
+need-kde 3.2
+
+src_install() {
+ make DESTDIR=${D} \
+ PLUGINDIR=/usr/$(get_libdir)/lineakd/plugins \
+ lineakddocdir=/usr/share/doc/${P} \
+ install || die "make install failed"
+ dodoc AUTHORS README
+}