summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2008-02-14 12:31:52 +0000
committerJonathan Smith <smithj@gentoo.org>2008-02-14 12:31:52 +0000
commit27485b260eca2ef71fdef6f491f58e1768f4a23a (patch)
treec202a3c8266d13fec62dac06edc5ccfce22ce36b /x11-misc/mgm/mgm-1.1_p14506.ebuild
parentamd64 stable (diff)
downloadgentoo-2-27485b260eca2ef71fdef6f491f58e1768f4a23a.tar.gz
gentoo-2-27485b260eca2ef71fdef6f491f58e1768f4a23a.tar.bz2
gentoo-2-27485b260eca2ef71fdef6f491f58e1768f4a23a.zip
update to the latest svn snapshot, as upstream seems to no longer do stable releases. bug 210096
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-misc/mgm/mgm-1.1_p14506.ebuild')
-rw-r--r--x11-misc/mgm/mgm-1.1_p14506.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/mgm/mgm-1.1_p14506.ebuild b/x11-misc/mgm/mgm-1.1_p14506.ebuild
new file mode 100644
index 000000000000..ff0ecee115d8
--- /dev/null
+++ b/x11-misc/mgm/mgm-1.1_p14506.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/mgm/mgm-1.1_p14506.ebuild,v 1.1 2008/02/14 12:31:52 smithj Exp $
+
+inherit eutils
+
+DESCRIPTION="Moaning Goat Meter: load and status meter written in Perl"
+HOMEPAGE="http://www.linuxmafia.com/mgm/index.html"
+
+# upstream doesn't seem to like making source tarballs anymore. we made this one
+# with following command:
+# svn co --revision 14506 http://svn.xiph.org/trunk/mgm
+#SRC_URI="http://www.linuxmafia.com/mgm/${P}.tgz"
+SRC_URI="mirror://gentoo/${P}.tar.bz2" # FIXME
+
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+SLOT="0"
+LICENSE="as-is"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ >=dev-perl/perl-tk-800.024"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_install() {
+ dobin mgm || die "dobin failed"
+ insinto usr/share/mgm
+ doins lib/* || die "doins failed (lib)"
+ insinto usr/share/mgm/linux
+ doins modules/linux/* || die "doins failed (modules/linux)"
+ insinto usr/share/mgm/share
+ doins modules/share/* || die "doins failed (modules/share)"
+ dohtml doc/*
+}