summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-10-02 22:19:25 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-10-02 22:19:25 +0000
commita8d2e5d8a9fd827035f25ba47ebf69116e5f1919 (patch)
tree80f25e86ab4a34178b54eaba1ef9b6ceea6b9206 /x11-misc/qterm/qterm-0.5.7-r1.ebuild
parentFix doc installation. (diff)
downloadgentoo-2-a8d2e5d8a9fd827035f25ba47ebf69116e5f1919.tar.gz
gentoo-2-a8d2e5d8a9fd827035f25ba47ebf69116e5f1919.tar.bz2
gentoo-2-a8d2e5d8a9fd827035f25ba47ebf69116e5f1919.zip
Fixed desktop file, bug #287212.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/qterm/qterm-0.5.7-r1.ebuild')
-rw-r--r--x11-misc/qterm/qterm-0.5.7-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/qterm/qterm-0.5.7-r1.ebuild b/x11-misc/qterm/qterm-0.5.7-r1.ebuild
new file mode 100644
index 000000000000..6654ccf499a1
--- /dev/null
+++ b/x11-misc/qterm/qterm-0.5.7-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/qterm/qterm-0.5.7-r1.ebuild,v 1.1 2009/10/02 22:19:24 matsuu Exp $
+
+EAPI="1"
+inherit cmake-utils eutils
+
+DESCRIPTION="A BBS client for Linux"
+HOMEPAGE="http://qterm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qterm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/qt-gui:4
+ dev-libs/openssl"
+
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.7"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_install() {
+ cmake-utils_src_install
+ mv "${D}"/usr/bin/qterm "${D}"/usr/bin/QTerm || die
+ dodoc README TODO
+}
+
+pkg_postinst() {
+ elog
+ elog "Since 0.4.0-r1, /usr/bin/qterm has been renamed to /usr/bin/QTerm."
+ elog "Please see bug #176533 for more information."
+ elog
+}