summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Zhao <ming@gentoo.org>2006-07-28 05:59:39 +0000
committerMing Zhao <ming@gentoo.org>2006-07-28 05:59:39 +0000
commit98271276707bec6bd4719fbb76ae43185bca0401 (patch)
treeb285b612a3637bdda07c2496f8c9cbd086840c3e /x11-misc/qterm
parentRemove broken ebuild. (diff)
downloadgentoo-2-98271276707bec6bd4719fbb76ae43185bca0401.tar.gz
gentoo-2-98271276707bec6bd4719fbb76ae43185bca0401.tar.bz2
gentoo-2-98271276707bec6bd4719fbb76ae43185bca0401.zip
*qterm-0.4.0 (28 Jul 2006)
(Portage version: 2.1-r1)
Diffstat (limited to 'x11-misc/qterm')
-rw-r--r--x11-misc/qterm/ChangeLog9
-rw-r--r--x11-misc/qterm/files/digest-qterm-0.4.03
-rw-r--r--x11-misc/qterm/qterm-0.4.0.ebuild41
3 files changed, 52 insertions, 1 deletions
diff --git a/x11-misc/qterm/ChangeLog b/x11-misc/qterm/ChangeLog
index b992dc393e13..769af99a53dc 100644
--- a/x11-misc/qterm/ChangeLog
+++ b/x11-misc/qterm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/qterm
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/qterm/ChangeLog,v 1.14 2006/01/07 18:43:30 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/qterm/ChangeLog,v 1.15 2006/07/28 05:59:39 ming Exp $
+
+*qterm-0.4.0 (28 Jul 2006)
+
+ 28 Jul 2006; Ming Zhao <ming@gentoo.org> -files/qstring.patch,
+ -qterm-0.4.0_pre2.ebuild, -qterm-0.4.0_pre3.ebuild, +qterm-0.4.0.ebuild:
+ Version bumped. Remove beta versions and qstring.patch(integrated by
+ upstream).
07 Jan 2006; Carsten Lohrke <carlo@gentoo.org> qterm-0.4.0_pre3.ebuild:
QA: need-qt() needs to be called after R/DEPEND.
diff --git a/x11-misc/qterm/files/digest-qterm-0.4.0 b/x11-misc/qterm/files/digest-qterm-0.4.0
new file mode 100644
index 000000000000..109f4892c96c
--- /dev/null
+++ b/x11-misc/qterm/files/digest-qterm-0.4.0
@@ -0,0 +1,3 @@
+MD5 e948e6cda99f518881f3d241ab092d99 qterm-0.4.0.tar.bz2 805526
+RMD160 a9e5e43b70883d8dbdd719d5073770c33299e9f6 qterm-0.4.0.tar.bz2 805526
+SHA256 b79cd26eb57d9abc1e2eb530d5fb42f9fdcff86d544466596674273e3571156a qterm-0.4.0.tar.bz2 805526
diff --git a/x11-misc/qterm/qterm-0.4.0.ebuild b/x11-misc/qterm/qterm-0.4.0.ebuild
new file mode 100644
index 000000000000..4600ceb8e80e
--- /dev/null
+++ b/x11-misc/qterm/qterm-0.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/qterm/qterm-0.4.0.ebuild,v 1.1 2006/07/28 05:59:39 ming Exp $
+
+inherit kde-functions eutils
+
+DESCRIPTION="QTerm is a BBS client in Linux."
+HOMEPAGE="http://qterm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qterm/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="arts esd ssl"
+DEPEND=">=media-sound/esound-0.2.22
+ dev-lang/python
+ ssl? ( dev-libs/openssl )"
+need-qt 3
+
+src_compile() {
+
+ cd ${S}
+
+ # yeah, it's --disable-ssh to disable ssl
+ local myconf="`use_enable esd` `use_enable ssl ssh`"
+
+ # Although "configure --help" claims use "--with-arts-dir" to set aRts dir, it actually
+ # check the value of "--with-artsdir" option. To gracefully fix this bug, I have to run
+ # s/(artsdir/(arts-dir/ to ${S}/admin/acinclude.m4.in, then make -f Makefile.dist to
+ # regenerate the configure script. For simplicity I choose to just use the buggy script
+ # and give it the "wrong" option.
+ use arts && myconf="${myconf} --enable-arts --with-artsdir=`kde-config --prefix`" \
+ || myconf="${myconf} --disable-arts"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "install faled"
+ dodoc AUTHORS BUGS COPYING ChangeLog README* RELEASE_NOTES
+}