summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Bevitt <cyfred@gentoo.org>2004-03-01 09:28:33 +0000
committerAndrew Bevitt <cyfred@gentoo.org>2004-03-01 09:28:33 +0000
commit0fa02d3fb2eeed16e9b7209c5f2941b50927811a (patch)
treec4a7edf9b4e53ab5ab036924dc0d57b2c58eee6f /x11-misc/seyon/files
parentVersion bumped. (Manifest recommit) (diff)
downloadgentoo-2-0fa02d3fb2eeed16e9b7209c5f2941b50927811a.tar.gz
gentoo-2-0fa02d3fb2eeed16e9b7209c5f2941b50927811a.tar.bz2
gentoo-2-0fa02d3fb2eeed16e9b7209c5f2941b50927811a.zip
New package Seyon. Thanks to James Dumay for working through this, bug 38264
Diffstat (limited to 'x11-misc/seyon/files')
-rw-r--r--x11-misc/seyon/files/digest-seyon-2.20c1
-rw-r--r--x11-misc/seyon/files/seyon-2.20c-compile-fix.patch60
-rw-r--r--x11-misc/seyon/files/seyon-2.20c-lock-file-fix.patch32
-rw-r--r--x11-misc/seyon/files/seyon-2.20c-makefile-patch.patch12
4 files changed, 105 insertions, 0 deletions
diff --git a/x11-misc/seyon/files/digest-seyon-2.20c b/x11-misc/seyon/files/digest-seyon-2.20c
new file mode 100644
index 000000000000..bfd22d570973
--- /dev/null
+++ b/x11-misc/seyon/files/digest-seyon-2.20c
@@ -0,0 +1 @@
+MD5 82ab5470a93ef591fe4c3b2b40f91469 seyon_2.20c.orig.tar.gz 167487
diff --git a/x11-misc/seyon/files/seyon-2.20c-compile-fix.patch b/x11-misc/seyon/files/seyon-2.20c-compile-fix.patch
new file mode 100644
index 000000000000..75ddac579ff3
--- /dev/null
+++ b/x11-misc/seyon/files/seyon-2.20c-compile-fix.patch
@@ -0,0 +1,60 @@
+--- seyon-2.20c/SeDecl.h 1993-07-02 10:01:39.000000000 +1000
++++ seyon_2.20c_new/SeDecl.h 2004-02-11 05:56:50.002034512 +1100
+@@ -65,8 +65,7 @@
+ get_modem_fio();
+ extern FILE *open_file(),
+ *open_file_va();
+-extern void send_break(),
+- usleep(),
++extern void send_break(),
+ show(),
+ showf(),
+ SeyonMessage(),
+--- seyon-2.20c/SeParse.y 1993-07-02 10:01:42.000000000 +1000
++++ seyon_2.20c_new/SeParse.y 2004-02-11 06:01:36.347503384 +1100
+@@ -50,9 +50,9 @@
+ {
+ (*callbackProc)(4, msg);
+ }
+-
+-#ifdef TEST
+-void SignalBeginFunction(char *name)
++/*
++##ifdef TEST
++#void SignalBeginFunction(char *name)
+ {
+ printf("** Function call: %s(", name);
+ }
+@@ -103,3 +103,4 @@
+ ParseThis(long_line);
+ }
+ #endif TEST
++*/
+--- seyon-2.20c/SeScan.c 1993-07-02 10:01:42.000000000 +1000
++++ seyon_2.20c_new/SeScan.c 2004-02-11 05:58:56.144857888 +1100
+@@ -286,14 +286,3 @@
+ scSetInputBuffer(line);
+ return GetNextWord();
+ }
+-
+-#ifdef TEST
+-main()
+-{
+- scSetInputBuf("Just to see if we'\\'re \\n\\033 able to distinguish' words and strings
+-\"Also 'quotes' inside strings\" and 'strs \"inside quotes\"'
+-Not to forget ^S and ^q control ^ chars");
+-
+- while (lGetWord() != 0);
+-}
+-#endif
+--- seyon-2.20c/Seyon.ad.h 1993-07-02 10:01:41.000000000 +1000
++++ seyon_2.20c_new/Seyon.ad.h 2004-02-11 05:51:03.417723336 +1100
+@@ -21,7 +21,7 @@
+ "*XfwfMultiList.defaultColumns: 1",
+ "*XfwfMultiList.verticaList: true",
+ "*XfwfMultiList.maxSelectable: 100",
+-"*XfwfMultiList.Translations: #replcae \\n\
++"*XfwfMultiList.Translations: #replace \\n\
+ <Btn1Down>(2): Select() Notify() \\n\
+ <Btn1Down>: Toggle() \\n\
+ <Btn2Down>: Select() Notify() \\n\
diff --git a/x11-misc/seyon/files/seyon-2.20c-lock-file-fix.patch b/x11-misc/seyon/files/seyon-2.20c-lock-file-fix.patch
new file mode 100644
index 000000000000..7ea06a7d106a
--- /dev/null
+++ b/x11-misc/seyon/files/seyon-2.20c-lock-file-fix.patch
@@ -0,0 +1,32 @@
+--- seyon-2.20c/config.h 1993-07-02 10:01:42.000000000 +1000
++++ seyon-2.20c-new/config.h 2004-02-12 10:31:45.716008808 +1100
+@@ -101,7 +101,8 @@
+ #define HAVE_SELECT YES
+ #define LF_USE_ASCII_PID YES
+ #define LF_USE_DEV_NUMBERS YES
+-#define LF_PATH "/usr/spool/locks"
++//#define LF_PATH "/usr/spool/locks"
++#define LF_PATH "/var/lock/uucp"
+ #define LF_PREFIX "LK."
+ #endif
+
+@@ -199,7 +200,8 @@
+ #define HAVE_SELECT YES
+ #define LF_USE_ASCII_PID NO
+ #define LF_USE_DEV_NUMBERS NO
+-#define LF_PATH "/usr/spool/locks"
++//#define LF_PATH "/usr/spool/locks"
++#define LF_PATH "/var/lock/uucp"
+ #define LF_PREFIX "LCK.."
+ #define B19200 16
+ #define B38400 17
+@@ -319,7 +321,8 @@
+ */
+
+ #ifndef LF_PATH
+-#define LF_PATH "/usr/spool/uucp"
++//#define LF_PATH "/usr/spool/uucp"
++#define LF_PATH "/var/lock/uucp"
+ #endif
+
+ /*
diff --git a/x11-misc/seyon/files/seyon-2.20c-makefile-patch.patch b/x11-misc/seyon/files/seyon-2.20c-makefile-patch.patch
new file mode 100644
index 000000000000..70b66f3785a2
--- /dev/null
+++ b/x11-misc/seyon/files/seyon-2.20c-makefile-patch.patch
@@ -0,0 +1,12 @@
+--- seyon-2.20c/Makefile 2004-02-11 06:58:43.501496784 +1100
++++ seyon_2.20c_new/Makefile 2004-02-11 06:56:08.673034288 +1100
+@@ -1150,9 +1150,6 @@
+ fi
+ $(INSTALL) $(INSTALLFLAGS) $(INSTDATFLAGS) seyon.help $(DESTDIR)$(LIBDIR)/seyon.help
+
+-install::
+- @if [ ! -d $(HOME)/.seyon ]; then mkdir $(HOME)/.seyon; fi; echo "=== Copying example files (no overwrite) to $(HOME)/.seyon ..."; for i in phonelist protocols startup script.*; do if [ ! -f $(HOME)/.seyon/$$i ]; then cp $$i $(HOME)/.seyon; fi; done;
+-
+ cleandir::
+ rm -f version.h y.tab.* SeParse.c
+