summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-03-06 00:26:46 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-03-06 00:26:46 +0000
commitea513e05d9c63222852fff99299bcef747430d1c (patch)
tree301bdba0a37742893afe0ee7341c665d74629c71 /x11-misc/sunflower
parentupdate linguas (diff)
downloadgentoo-2-ea513e05d9c63222852fff99299bcef747430d1c.tar.gz
gentoo-2-ea513e05d9c63222852fff99299bcef747430d1c.tar.bz2
gentoo-2-ea513e05d9c63222852fff99299bcef747430d1c.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'x11-misc/sunflower')
-rw-r--r--x11-misc/sunflower/ChangeLog8
-rw-r--r--x11-misc/sunflower/sunflower-0.1_alpha58.ebuild93
2 files changed, 100 insertions, 1 deletions
diff --git a/x11-misc/sunflower/ChangeLog b/x11-misc/sunflower/ChangeLog
index b276688fd49d..e9eb7337b8ff 100644
--- a/x11-misc/sunflower/ChangeLog
+++ b/x11-misc/sunflower/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/sunflower
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sunflower/ChangeLog,v 1.10 2014/01/27 13:45:28 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sunflower/ChangeLog,v 1.11 2014/03/06 00:26:46 hasufell Exp $
+
+*sunflower-0.1_alpha58 (06 Mar 2014)
+
+ 06 Mar 2014; Julian Ospald <hasufell@gentoo.org>
+ +sunflower-0.1_alpha58.ebuild:
+ version bump
*sunflower-0.1_alpha57 (27 Jan 2014)
diff --git a/x11-misc/sunflower/sunflower-0.1_alpha58.ebuild b/x11-misc/sunflower/sunflower-0.1_alpha58.ebuild
new file mode 100644
index 000000000000..d37f3a5340ee
--- /dev/null
+++ b/x11-misc/sunflower/sunflower-0.1_alpha58.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sunflower/sunflower-0.1_alpha58.ebuild,v 1.1 2014/03/06 00:26:46 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit eutils fdo-mime gnome2-utils python-r1
+
+MY_PN="Sunflower"
+DESCRIPTION="Small and highly customizable twin-panel file manager with plugin-support"
+HOMEPAGE="http://code.google.com/p/sunflower-fm"
+SRC_URI="http://sunflower-fm.org/pub/sunflower-${PV/_alpha/a-}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/notify-python-0.1[${PYTHON_USEDEP}]
+ gnome-base/librsvg:2
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_PN}
+
+src_prepare() {
+ find "${S}" -name "*.py[co]" -delete || die
+ find "${S}"/translations -name "*.po" -delete || die
+ rm "${S}"/translations/${PN}.pot || die
+
+ sed -i \
+ -e '/^application_file/s/os.path.dirname(sys.argv\[0\])/os.getcwd()/' \
+ ${MY_PN}.py || die
+}
+
+src_install() {
+ touch __init__.py || die
+ installme() {
+ # install modules
+ python_moduleinto ${PN}
+ python_domodule images application ${MY_PN}.py \
+ AUTHORS CHANGES COPYING DEPENDS TODO __init__.py
+
+ # generate and install startup scripts
+ sed \
+ -e "s#@SITEDIR@#$(python_get_sitedir)/${PN}#" \
+ "${FILESDIR}"/${PN} > "${T}"/${PN} || die
+ python_doscript "${T}"/${PN}
+ }
+
+ # install for all enabled implementations
+ python_foreach_impl installme
+
+ insinto /usr/share/locale
+ # correct gettext behavior
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd "${S}"/translations ; echo *) ; do
+ if has ${i} ${LINGUAS} ; then
+ doins -r "${S}"/translations/${i}
+ fi
+ done
+ else
+ doins -r "${S}"/translations/*
+ fi
+
+ newicon -s 64 images/${PN}_64.png ${PN}.png
+ doicon -s scalable images/${PN}.svg
+ newmenu ${MY_PN}.desktop ${PN}.desktop
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+
+ # TODO: better description
+ elog "optional dependencies:"
+ elog " dev-python/libgnome-python"
+ elog " media-libs/mutagen"
+ elog " x11-libs/vte:0[python] (terminal support)"
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}