summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-04-24 00:44:27 +0000
committerIan Delaney <idella4@gentoo.org>2015-04-24 00:44:27 +0000
commit8d27322178cc9b5f3f977addeb6ed8846a5c76aa (patch)
tree149535ec2b340f497758ed69445c2c36eb8578a6 /x11-misc/x11vnc
parentRemove old. (diff)
downloadgentoo-2-8d27322178cc9b5f3f977addeb6ed8846a5c76aa.tar.gz
gentoo-2-8d27322178cc9b5f3f977addeb6ed8846a5c76aa.tar.bz2
gentoo-2-8d27322178cc9b5f3f977addeb6ed8846a5c76aa.zip
bump wrt bug #515268, runtests fine
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'x11-misc/x11vnc')
-rw-r--r--x11-misc/x11vnc/ChangeLog7
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.13_p20150111.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/x11-misc/x11vnc/ChangeLog b/x11-misc/x11vnc/ChangeLog
index 115a0d3ab690..fed323b5fa2f 100644
--- a/x11-misc/x11vnc/ChangeLog
+++ b/x11-misc/x11vnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/x11vnc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.118 2015/04/08 04:57:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.119 2015/04/24 00:44:27 idella4 Exp $
+
+*x11vnc-0.9.13_p20150111 (24 Apr 2015)
+
+ 24 Apr 2015; Ian Delaney <idella4@gentoo.org> +x11vnc-0.9.13_p20150111.ebuild:
+ bump wrt bug #515268, runtests fine
08 Apr 2015; Jeroen Roovers <jer@gentoo.org> x11vnc-0.9.13-r1.ebuild:
Stable for HPPA (bug #518214).
diff --git a/x11-misc/x11vnc/x11vnc-0.9.13_p20150111.ebuild b/x11-misc/x11vnc/x11vnc-0.9.13_p20150111.ebuild
new file mode 100644
index 000000000000..fdc154241df5
--- /dev/null
+++ b/x11-misc/x11vnc/x11vnc-0.9.13_p20150111.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.13_p20150111.ebuild,v 1.1 2015/04/24 00:44:27 idella4 Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A VNC server for real X displays"
+HOMEPAGE="http://www.karlrunge.com/x11vnc/"
+SRC_URI="https://github.com/LibVNC/x11vnc/archive/82eb9752485db87c9c6d3d6bb4aa1ae7ac81174a.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="avahi crypt fbcon ssl xinerama"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ >=x11-libs/libXtst-1.1.0
+ avahi? ( >=net-dns/avahi-0.6.4 )
+ ssl? ( dev-libs/openssl:= )
+ >=net-libs/libvncserver-0.9.8
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ x11-proto/inputproto
+ x11-proto/trapproto
+ x11-proto/recordproto
+ x11-proto/xproto
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )"
+
+S="${WORKDIR}/x11vnc-82eb9752485db87c9c6d3d6bb4aa1ae7ac81174a"
+
+DOCS=(ChangeLog README)
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ # --without-v4l because of missing video4linux 2.x support wrt #389079
+ econf \
+ $(use_with avahi) \
+ $(use_with crypt) \
+ $(use_with fbcon fbdev) \
+ $(use_with ssl) \
+ $(use_with ssl crypto) \
+ --without-v4l \
+ $(use_with xinerama)
+}