summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2010-04-08 16:12:22 +0000
committerChristian Birchinger <joker@gentoo.org>2010-04-08 16:12:22 +0000
commit4f1ead71cee04fc02e05d6ec4e75be885f65f95f (patch)
tree2b11523fde2838072e9a059c0feda3c38cd91b9b /x11-misc/xdotool
parentVersion bump <http://my.opera.com/desktopteam/blog/new-snapshot-focus-on-nsl-... (diff)
downloadgentoo-2-4f1ead71cee04fc02e05d6ec4e75be885f65f95f.tar.gz
gentoo-2-4f1ead71cee04fc02e05d6ec4e75be885f65f95f.tar.bz2
gentoo-2-4f1ead71cee04fc02e05d6ec4e75be885f65f95f.zip
Removing raw-ldflags() stops the QA notice about ignored LDFLAGS. The user LDFLAGS show up in raw form during src_compile and it seems to work
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xdotool')
-rw-r--r--x11-misc/xdotool/ChangeLog11
-rw-r--r--x11-misc/xdotool/xdotool-20090815.ebuild44
-rw-r--r--x11-misc/xdotool/xdotool-20091231.02.ebuild5
3 files changed, 13 insertions, 47 deletions
diff --git a/x11-misc/xdotool/ChangeLog b/x11-misc/xdotool/ChangeLog
index 50bbba7dd147..abb63b16aec1 100644
--- a/x11-misc/xdotool/ChangeLog
+++ b/x11-misc/xdotool/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-misc/xdotool
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/ChangeLog,v 1.8 2010/04/08 15:31:05 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/ChangeLog,v 1.9 2010/04/08 16:12:22 joker Exp $
+
+ 08 Apr 2010; Christian Birchinger <joker@gentoo.org>
+ -xdotool-20090815.ebuild, xdotool-20091231.02.ebuild:
+ Removing raw-ldflags() stops the QA notice about ignored LDFLAGS. The user
+ LDFLAGS show up in raw form during src_compile and it seems to work
+
+ 08 Apr 2010; Christian Birchinger <joker@gentoo.org>
+ -xdotool-20090815.ebuild:
+ Remove older versions.
*xdotool-1.20100318.2737 (08 Apr 2010)
diff --git a/x11-misc/xdotool/xdotool-20090815.ebuild b/x11-misc/xdotool/xdotool-20090815.ebuild
deleted file mode 100644
index 6cb3337b465e..000000000000
--- a/x11-misc/xdotool/xdotool-20090815.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-20090815.ebuild,v 1.1 2009/10/21 10:17:23 joker Exp $
-
-EAPI=2
-
-inherit toolchain-funcs
-
-DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows."
-HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
-SRC_URI="http://semicomplete.googlecode.com/files/${P}.tar.gz"
-LICENSE="as-is"
-
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="examples"
-
-DEPEND="x11-libs/libXtst
- x11-libs/libX11"
-
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- cd "${S}"
- sed -i -e "s:^CFLAGS=\?.*:CFLAGS=-std=c99 ${CFLAGS}:" \
- -e "s:^LIBS=.*:LIBS=$(pkg-config --libs x11 xtst):" \
- -e "s:^INC=.*:INC=$(pkg-config --cflags x11 xtst):" \
- -e "s:\$(CC):$(tc-getCC):" \
- -e 's:LDFLAGS+=$(LIBS)::' \
- -e 's:-o $@:$(LIBS) -o $@:' \
- -e "s:\$(CFLAGS):\$(INC) \$(CFLAGS):" \
- Makefile \
- || die "sed Makefile failed."
-}
-
-src_install() {
- dobin ${PN}
- doman ${PN}.1
- dodoc CHANGELIST README
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*
- fi
-}
diff --git a/x11-misc/xdotool/xdotool-20091231.02.ebuild b/x11-misc/xdotool/xdotool-20091231.02.ebuild
index 22cd77cbfdd0..c699c47ffd5b 100644
--- a/x11-misc/xdotool/xdotool-20091231.02.ebuild
+++ b/x11-misc/xdotool/xdotool-20091231.02.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-20091231.02.ebuild,v 1.3 2010/01/14 07:33:26 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-20091231.02.ebuild,v 1.4 2010/04/08 16:12:22 joker Exp $
EAPI=2
@@ -33,7 +33,8 @@ src_prepare() {
src_compile() {
tc-export CC LD
- export LDFLAGS="$(raw-ldflags)"
+ # Seems to handle LDFLAGS fine without it and prevents QA message bug #312729
+ #export LDFLAGS="$(raw-ldflags)"
default
emake libxdo.so || die "Unable to build libxdo.so"
}